LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 10-10-2004, 05:46 AM   #1
Terrence Hinds
LQ Newbie
 
Registered: Oct 2004
Distribution: Redhat
Posts: 7

Rep: Reputation: 0
Installed the wrong SAMBA packages.Now samba doesn't start


Hello to all
Can someone be kind enough to help.I tried to update to samba 3.0 from the version that comes with Redhat 9.0.Unfortunately one of the files I download and installed was the wrong RPM which is samba-winbind-3.0.4-1.32i586.rpm.And Samba won't start anymore.I have managed to un-installed all the other files,but I can't delete the samba winbind-3.0.1-1.32 file.When I run the command "rpm -e above file-name".I get this error "code.Line 26:/etc/rc.status:No such file or directory error %preun(samba winbind-3.0.1-1.32)scriplet failed".But when I run the command "rpm -qa | grep samba"I can see the mention file.Please guide to how to find this file and delete it.So I can get samba working again.
Many thanks
Best regard
Terrence
 
Old 10-10-2004, 06:52 AM   #2
hitesh_linux
Member
 
Registered: Dec 2001
Location: /root
Distribution: FreeBSD,NETBSD,redhat
Posts: 472

Rep: Reputation: 30
You may want to install Samba Forcly. just follow the below command and try with it..

rpm -ivh --force samba.x.x.xxx [package name] OR

rpm -U samba.x.x.xxx [package name]

Also, you can check pacakage information with following command.

rpm -qi samba-winbind

Hope this helps.

-/Hitesh

Last edited by hitesh_linux; 10-10-2004 at 06:59 AM.
 
Old 10-10-2004, 08:37 AM   #3
Terrence Hinds
LQ Newbie
 
Registered: Oct 2004
Distribution: Redhat
Posts: 7

Original Poster
Rep: Reputation: 0
Thanks very much Hitesh
For your quick reply.I tried those commands but without luck.The file is still there and,funnily it has dependency as was well,because I can't even delete the former Samba version 2.27.Is there a way that I can manually edit the RPM database to get rid of that file,and where would you find that database.
Thanks again
Terrence
 
Old 10-11-2004, 03:40 AM   #4
rabeea
Member
 
Registered: Aug 2004
Location: Pakistan
Posts: 52

Rep: Reputation: 15
hi there

u can even try the command rpm -e --nodeps samba.x.x.xxx [package name] .This command will delete it without considering its dependencies.best of luck
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
when i try to start samba pdc's smb service nmbd failed to start . sandeepchau123 Linux - Newbie 2 10-20-2007 01:59 PM
Samba - My Config has something wrong surfduke Linux - Networking 3 09-25-2005 09:12 AM
samba working, then installed openSSL and not samba not working hamish Linux - Networking 3 05-17-2004 01:50 PM
Samba, what am I doing wrong? zetsui Linux - Networking 17 09-06-2003 06:26 AM
when i restart SAMBA,it says:stop samba failed,start SAMBA OK! whepin Linux - Networking 3 12-26-2001 05:54 AM


All times are GMT -5. The time now is 09:33 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration