LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 06-11-2003, 06:27 PM   #1
cmritter
LQ Newbie
 
Registered: Jun 2003
Location: Memphis, TN
Distribution: RedHat 8.0
Posts: 4

Rep: Reputation: 0
Angry imap and pop3 won't start


I am running RedHat 8.0, and I'm trying to set up SquirrelMail. I've installed all of the mail-related packages, but when I try to start either the POP3 or IMAP services, I am informed that I need to enable xinetd in order to use any of them, and the services won't start.

Problem is, xinetd is already running happily.

I can't seem to find any glaring configuration errors. Any suggestions?

v/r
Colby
 
Old 06-11-2003, 06:39 PM   #2
GAVollink
Member
 
Registered: Apr 2002
Location: St. Paul, Minnesota
Distribution: UbuntuStudio, Ubuntu
Posts: 357

Rep: Reputation: 31
POP3 and IMAP both require setup information to be installed into the /etc/xinetd.d directory.

If they are not there, add them. If they are there, post them.

my ipop3 entry looks like this:

service pop3
{
socket_type = stream
wait = no
user = root
server = /usr/sbin/ipop3d
log_on_success += USERID
log_on_failure += USERID
disable = yes
}

Last edited by GAVollink; 06-11-2003 at 06:41 PM.
 
Old 06-15-2003, 05:38 AM   #3
Robert0380
Guru
 
Registered: Apr 2002
Location: Atlanta
Distribution: Gentoo
Posts: 1,280

Rep: Reputation: 47
rather than starting a new thread i figured i'd just ask my question here since i found this thread:


imap runs on port 143 by default right? how do i confirm this once it is running?
 
Old 06-15-2003, 05:44 AM   #4
evslin
LQ Newbie
 
Registered: Jun 2003
Location: Omaha, NE
Distribution: Fedora Core 2
Posts: 21

Rep: Reputation: 15
Yeah, IMAP runs on port 143. Real quick way to check is to open up a terminal and do 'telnet <server address here> 143'. You should get a welcome message if the server is accepting connections.
 
Old 06-15-2003, 06:08 AM   #5
Robert0380
Guru
 
Registered: Apr 2002
Location: Atlanta
Distribution: Gentoo
Posts: 1,280

Rep: Reputation: 47
thanks, got it.
 
Old 06-15-2003, 12:35 PM   #6
Qzukk
Member
 
Registered: Jun 2003
Posts: 132

Rep: Reputation: 15
You can see all internet activity on the system and the programs that are using them by running

netstat --inet -anp

Look for the lines reading LISTEN to see which servers you are running.
 
Old 06-16-2003, 07:23 AM   #7
cmritter
LQ Newbie
 
Registered: Jun 2003
Location: Memphis, TN
Distribution: RedHat 8.0
Posts: 4

Original Poster
Rep: Reputation: 0
GAVollink -

Sorry it took so long to reply. Here's the contents of the files in the /etc/xinetd.d directory:

ipop3:

# default: off
# description: The POP3 service allows remote users to access their mail \
# using an POP3 client such as Netscape Communicator, mutt, \
# or fetchmail.
service pop3
{
disable = yes
socket_type = stream
wait = no
user = root
server = /usr/sbin/ipop3d
log_on_success += HOST DURATION
log_on_failure += HOST
}


imap:

# default: off
# description: The IMAP service allows remote users to access their mail using \
# an IMAP client such as Mutt, Pine, fetchmail, or Netscape \
# Communicator.
service imap
{
disable = no
socket_type = stream
wait = no
user = root
server = /usr/sbin/imapd
log_on_success += HOST DURATION
log_on_failure += HOST
}


There are also ipop2 and imaps files that look similar to these.

v/r
cmritter
 
Old 06-20-2003, 01:49 PM   #8
GAVollink
Member
 
Registered: Apr 2002
Location: St. Paul, Minnesota
Distribution: UbuntuStudio, Ubuntu
Posts: 357

Rep: Reputation: 31
Actually, I can't say how embarrassed I am for mis-posting.

Funny - I run pop just fine - but not from the machine I posted it from!

Anyway - the thing that's still wrong is your "disable=yes" - which was plain wrong. On same machine - here is the imap entry (the file is called "imap") and it really does work...

service imap
{
socket_type = stream
wait = no
user = root
server = /usr/sbin/imapd
log_on_success += DURATION USERID
log_on_failure += USERID
disable = no
}

>edit> Also check Qzukk 's post above to see if the services are listening. And remember to "HUP" the xinetd process.

Last edited by GAVollink; 06-20-2003 at 02:00 PM.
 
Old 06-20-2003, 05:52 PM   #9
cmritter
LQ Newbie
 
Registered: Jun 2003
Location: Memphis, TN
Distribution: RedHat 8.0
Posts: 4

Original Poster
Rep: Reputation: 0
GAVollink,

What do you mean by "HUP" the xinetd process?

v/r
cmritter
 
Old 06-20-2003, 06:16 PM   #10
cmritter
LQ Newbie
 
Registered: Jun 2003
Location: Memphis, TN
Distribution: RedHat 8.0
Posts: 4

Original Poster
Rep: Reputation: 0
GAVollink,

By the way, it's working now. I guess my problem was that I didn't know how to see if the service was running properly. Thanks to Qzukk for the netstat command.

v/r
cmritter
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
qmail - different between POP3-IMAP -- Please help me b:z Linux - General 1 06-14-2005 06:14 AM
POP3 Imap Problems Cynthia Blue Linux - Software 2 11-13-2004 10:55 PM
Can't Start IMAP/POP3 Services stevewilliams Linux - Software 6 08-08-2003 12:04 PM
Question on Imap and Pop3 cojo Linux - Software 2 06-17-2003 09:51 AM
pop3 and imap configration tarak4u Linux - Networking 1 05-29-2002 04:54 AM


All times are GMT -5. The time now is 02:05 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration