LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 08-06-2003, 04:18 AM   #1
shyam
LQ Newbie
 
Registered: Aug 2003
Posts: 11

Rep: Reputation: 0
Red face ifcfg-eth0 configuration problem


In my Linux server(Wipro EzyNet Server) there are two network cards.

1. eth0 for LAN

2. eth1 for DSL modem

The configuration files are as below

ifcfg-eth0
------------
ONBOOT=yes
NETWORK=192.168.1.0
NETMASK=255.255.255.0
IPADDR=192.168.1.6


ifcfg-eth1
------------
ONBOOT=yes
NETWORK=192.168.1.0
NETMASK=255.255.255.240
IPADDR=10.23.0.9

When the server starts it shows the IP address 192.168.1.6 on the LCD screen.

To configure the server(to enable DSL modem) i changed the ifcfg-eth0 as below


ifcfg-eth0
------------
ONBOOT=yes
NETWORK=192.168.1.0
NETMASK=255.255.255.0
IPADDR=192.168.1.6
GATEWAY=10.23.0.9

When the server restarts it shows the IP address as 10.23.0.9 instead of 192.168.1.6 and i am unable to ping the server. How i can connect the server , so that i can edit the ifcfg-eth0 file, to restore default configuration.

Pl help to short out the problem.

Rgds,

Shyam

Last edited by shyam; 08-06-2003 at 05:54 AM.
 
Old 08-06-2003, 05:22 AM   #2
ppuru
Senior Member
 
Registered: Mar 2003
Location: Beautiful BC
Distribution: RedHat & clones, Slackware, SuSE, OpenBSD
Posts: 1,791

Rep: Reputation: 47
shouldn't GATEWAY appear in /etc/sysconfig/network
 
Old 08-06-2003, 06:25 AM   #3
cIx
Member
 
Registered: Aug 2003
Location: /dev/null
Posts: 40

Rep: Reputation: 15
Why did you setup NETWORK for eth1 to be 192.168.1.0 ?

I'm not sure that I correctly understood you, but I guess you should do the following settings:

ifcfg-eth0
------------
ONBOOT=yes
NETWORK=192.168.1.0
NETMASK=255.255.255.240 #why?
IPADDR=192.168.1.6

ifcfg-eth1
------------
ONBOOT=yes
NETWORK=10.0.0.0
NETMASK=255.0.0.0
IPADDR=10.23.0.9

I don't understand what are you trying to do, but if you try to enable internet access for you LAN, you should use NAT.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
fedora/redhat: ifcfg-eth0 and ifcfg-eth1 Shaun2222 Linux - Networking 9 01-23-2008 03:25 PM
RH9 ignoring /etc/.../.../ifcfg-eth0 eccles23 Linux - Networking 12 07-16-2005 02:14 PM
editing ifcfg-eth0 nkeever Linux - Newbie 4 05-05-2005 02:46 PM
Diff b/w 'network' and 'ifcfg-eth0' files linuxistan Linux - Networking 2 10-18-2004 05:30 AM
ifcfg-eth0:X alias problem dgenne Linux - Networking 1 03-17-2002 01:43 AM


All times are GMT -5. The time now is 07:38 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration