LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices



Reply
 
Search this Thread
Old 03-11-2003, 01:12 AM   #1
-G-
LQ Newbie
 
Registered: Mar 2003
Location: North West USA
Distribution: Redhat 8.0 & 9.0, Mandrake 9.0 & 9.2, Fedora Core 1, Knoppix
Posts: 28

Rep: Reputation: 15
If X server (Cygwin) is the answer, I need a new Question


HowD all,

First off, what my goal here is, is to be able to turn on my Linux box, maybe type a few commands here and there, nothing much (preferably nothing), turn on my box running the other OS, do what ever I have to do, and be able to sit at my box running that other OS and seem as though I'm sitting at the Linux box.

Now, from what I've read, and I've read a ton, is that I have to have an X server running on the box that runs that other OS and then some form of an X client running on the Linux box.

So I was pointed to cygwin as a open source (free) alternative to the commercial X servers (going for over $100). Ok, did that. Downloaded it. Installed it. Installed the X11R6 stuff. Okay, run the startxwin.bat file, yep, get the BASH window, type the prescribed /usr/X11R6/bin/xhost ip.number.here, yep, okay, then type the /usr/bin/telnet ip.host.here ....bzz...gong....get a blank screen. In-fact, I don't even see telnet in that folder.

Here's my hunch...I have no idea what I'm doing.

Here's my second hunch...I need to start something on the Linux box. I'm running Redhat 8.0. Telnet and SSH have been started.

Maybe I'm doing something almost right, but I doubt it.

Anyway, here's my vitals.

Other OS box - P4-2.4, WinXP, 512 RAM
Linux box - Celeron 350Mhz, 128 RAM, Redhat 8.0

Both are connected to a Linksys router, works fine, both can get out on the net.

I really want to get rid of my monitor on the Linux box.

TIA...

-G-
 
Old 03-11-2003, 06:25 AM   #2
irish_rover
Member
 
Registered: Sep 2002
Location: IN, USA
Distribution: Debian, Endian FW
Posts: 368

Rep: Reputation: 30
You could alternatively use vnc? I would make sure you don't leave the vnc port open to the outside world, but other than that it works quite well across a local network.
 
Old 03-11-2003, 06:57 AM   #3
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,415

Rep: Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968
you don't want cygwin for that, vnc is a much better choice... you'll get linux's X server running in a window. but i think there's an option to make it run full screen.... i'd suggest using tightvnc as it's got encryption and compression methods to make it run faster over your network
 
Old 03-11-2003, 08:20 AM   #4
yngwin
Member
 
Registered: Dec 2002
Location: China
Distribution: Arch
Posts: 359

Rep: Reputation: 33
If I understand you, you want to see the output of your linux box while working on a windows box. Then the X server should be on the linux box, not the windows one! That's what you've got mixed up. But indeed tightvnc might just be the answer you're looking for.
 
Old 03-11-2003, 11:53 AM   #5
stikboy
Member
 
Registered: Mar 2003
Location: Colorado
Distribution: RedHat 7.1/Redhat 8.0/Gentoo 1.4
Posts: 45

Rep: Reputation: 15
If you want to chek that telnet is running properly, try to telnet from a command promt in XP, instead of Cygen's bash shell.

Start > Run > cmd

telnet <ip.host.here>

if you can connect through that, then you may have to make sure cygen actually installed telnet, and if not find a way to get it reinstalled (i.e. install telnet client yourself or go through the whole re-install process for Cygen)

also, on your linux box, as a test, turn off iptables (service iptables stop) and see if this works. If you had set up a firewall, RedHat 8 sets up some very closed rules by default.

Now, after all that, as someone who's used both Cygen and TightVNC, I would recommend the VNC route. It's a lot easier to use and setup. Download and install the server rpm on your linux box, get the client for XP, on the linux box, type vncserver and it will come back with a port #. start the XP client, enter <ip.host.name.here>:<vncport#>
just as easy as that :-)

and since I didn't see it posted before, here's the url:
http://www.tightvnc.com/
 
Old 03-12-2003, 09:22 AM   #6
-G-
LQ Newbie
 
Registered: Mar 2003
Location: North West USA
Distribution: Redhat 8.0 & 9.0, Mandrake 9.0 & 9.2, Fedora Core 1, Knoppix
Posts: 28

Original Poster
Rep: Reputation: 15
Hey there,

Thanks for the tip on tightVNC. It worked...sort of.

I installed the server on the linux box, stopped iptables (don't know if I had to do this...too much of a noob to understand iptables totally), fired up vncserver, saw that it was on port 1.

Installed vncviewer/server on the xp machine, started up the viewer, typed in the LAN address of the machine with the port number, logged in using the password I setup when executing vncserver on th elinux box, and then a blank, black and white screen came up with the little "X" as the pointer. That was as far as I could get.

Any thoughts on this?

Btw, thanks again. To get this far with tightVNC was way easier than cygwin was.

-G-
 
Old 03-12-2003, 09:56 AM   #7
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,415

Rep: Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968
you should read the documentation more.. you need a ~/.vnc/xstartup file to tell vnc what do load on the server it creates.
 
Old 03-12-2003, 10:54 PM   #8
-G-
LQ Newbie
 
Registered: Mar 2003
Location: North West USA
Distribution: Redhat 8.0 & 9.0, Mandrake 9.0 & 9.2, Fedora Core 1, Knoppix
Posts: 28

Original Poster
Rep: Reputation: 15
Okay, so after some reading...guess what, I'm still lost.

First, after doing some reading, I started up the vncserver using the "vncserver -name box -geometry 1024x768" and up it went, fine, just like before.
I then went to the xp box, started up putty, connected to 192.168.1.101 and bingo, I'm in a bash terminal.

First, what happened to the black and white window with the "X" mouse pointer?

And i looked at the ~/.vnc/xstartup file, and this is what I got...

exec /etc/X11/xinit/xinitrc

...uh, okay.

I didn't find anything at tightVNC or at VNC websites that was any help in this. I'm a REAL NOOB so maybe it might be obvious, but poop, it ain't obvious to me.

I did find some, what appeard to be good, info HERE ...but again, no silver bullet.

As always, any help would be appreciated.

-G-
 
Old 03-13-2003, 05:13 AM   #9
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,415

Rep: Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968
ok so that xstartup will just attempt to run the system default. have a look what that xinitrc file says. maybe it just doens't list a window manager at all, more likely though it's running twm which is disgusting. you'd be fine to just replace that line with "exec yourfavouritewindowmanager" and it should load find next time when you load vncserver
 
Old 03-13-2003, 06:33 AM   #10
irish_rover
Member
 
Registered: Sep 2002
Location: IN, USA
Distribution: Debian, Endian FW
Posts: 368

Rep: Reputation: 30
"First, what happened to the black and white window with the "X" mouse pointer?"

You said you connected with putty and got a bash shell? You need to connect using the vncviewer.

And your ~/.vnc/xstartup file can be very simple like this:
########
#/bin/sh
fluxbox &
########

Of course replace fluxbox with your favorite window manager. After you edit the xstartup file you'll need to restart vncserver.
 
Old 03-13-2003, 11:06 AM   #11
-G-
LQ Newbie
 
Registered: Mar 2003
Location: North West USA
Distribution: Redhat 8.0 & 9.0, Mandrake 9.0 & 9.2, Fedora Core 1, Knoppix
Posts: 28

Original Poster
Rep: Reputation: 15
So, part of me feels kind of dumb here. After I posted that last message of mine, I googled every possible combination I could think of and found a very detailed description of setting up VNCserver and WinNT to talk to each other. However, it was written in broken english and still left some holes.

After reading that, I when and looked at /etc/X11/xinit/xinitrc file, and there was a bunch of stuff there that I couldn't read. It seemed to me that I should be able to change the ~/.vnc/xstartup file to not go over to xinitrc but rather just start something I wanted.

So I changed xstartup, and changed again, and changed, and changed. My main problem is that I'm such a noob that I don't really know what the syntax is. Anyway, I got the "black and white screen with the "X" mouse pointer" to turn to a solid grey backround with the "X" mouse pointer...but that's about it.

I tried
exec gnome-session

and
gnome-session &

and
/usr/bin/gnome-session

and
exec /usr/bin/gnome-session

and...
and I think you get the point.

And btw, irish_rover, I realized I had been stupid enough to connect through putty and not vncviewer. That was probably the low point after I posted that message and realized what I was doing.

Anway, I will say the help here has gotten me further that I would have ever done on my own. Thanks for the help, and as always, any more help would be appreciated.

-G-
 
Old 03-13-2003, 12:27 PM   #12
stikboy
Member
 
Registered: Mar 2003
Location: Colorado
Distribution: RedHat 7.1/Redhat 8.0/Gentoo 1.4
Posts: 45

Rep: Reputation: 15
Do you have a default desktop already set up on the Linux box? If you login and type startx, does a desktop startup, or does it automatically load when you login?

I'm not sure about the xinitrc script, but from what I know, if you have the desktop setup, it should run your defauls automatically.
 
Old 03-13-2003, 12:40 PM   #13
-G-
LQ Newbie
 
Registered: Mar 2003
Location: North West USA
Distribution: Redhat 8.0 & 9.0, Mandrake 9.0 & 9.2, Fedora Core 1, Knoppix
Posts: 28

Original Poster
Rep: Reputation: 15
When I turn on the linux box, the graphical login screen comes up. I log in, and up starts gnome...kind of like starting that other OS that is out there.

I don't have to start up gnome from the command line if that's what you're asking.

Which brings me to another question I was thinking about. Is there a problem with running gnome on the linux box and then trying to get gnome to run through the tightVNC connection? What I mean to ask is it seems like the linux box would have to be running two sessions of gnome...can it do that...or am I off here?

Thanks again...

-G-
 
Old 03-13-2003, 01:59 PM   #14
cmfarley19
Member
 
Registered: Nov 2002
Location: Central VA
Distribution: Ubuntu/Debian
Posts: 228

Rep: Reputation: 32
Where is this file (~/.vnc/xstartup) located?
 
Old 03-13-2003, 02:05 PM   #15
-G-
LQ Newbie
 
Registered: Mar 2003
Location: North West USA
Distribution: Redhat 8.0 & 9.0, Mandrake 9.0 & 9.2, Fedora Core 1, Knoppix
Posts: 28

Original Poster
Rep: Reputation: 15
mine is in the root home...

/root/.vnc/xstartup

The "~/" represents the "home" directory for the user, if I'm not mistaken (some one correct me here if I'm wrong). In my case, it's the root user that installed the tightVNC stuff, so the xstartup file was created in the root's home directory under the .vnc directory.

Hope that helps...

-G-
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Executing cron jobs on a w2k3 server using cygwin hq4ever General 4 06-01-2005 07:45 AM
connecting to X using Cygwin : Concept Question, not technical Chadian22 Linux - Software 0 08-28-2004 04:43 PM
Noone knows the answer to this question??? lexington Linux - Newbie 5 05-02-2004 04:12 PM
Where do Cygwin question go? marz2 General 2 03-07-2004 05:55 PM
i have a question that noone can answer p4yb4ck Linux - General 2 02-13-2004 06:54 PM


All times are GMT -5. The time now is 07:35 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration