LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (http://www.linuxquestions.org/questions/linux-networking-3/)
-   -   I would not connect to suse 10 server from a windows PC using ssh. 'access denied' (http://www.linuxquestions.org/questions/linux-networking-3/i-would-not-connect-to-suse-10-server-from-a-windows-pc-using-ssh-access-denied-445804/)

zhangy 05-17-2006 03:39 PM

I would not connect to suse 10 server from a windows PC using ssh. 'access denied'
 
It is the fisrt time for me to use suse 10. I could not make ssh works. Someone said this is because .xsession file was not correctly configured or does not locate in a correct place.

When I try to login to suse server from a windows PC using ssh, it says 'access denied' all the time.

I di not get this problem when I install Suse 8.

I would be very happy if someone can help me with this.

zhangy
from Netherland

J_K9 05-17-2006 03:53 PM

Hi,
Quote:

Originally Posted by zhangy
When I try to login to suse server from a windows PC using ssh, it says 'access denied' all the time.

How is the service configured? SSH is configured using the file /etc/sshd_config, so you may want to look at 'man sshd' and then have a go at configuring that.

If you run the SSH server with unix password logins, then all you have to do from the Windows PC is download an application called PuTTY, and then following the documentation ;)

It's quite simple - start PuTTY, enter the SSH server's IP address, type in a username and password (for example, those of a user account on the server) and then select the protocol as 'ssh'. Then, try connecting - it should work ;)

Cheers,

-jk

Ps. Welcome to LQ! ;)

zhangy 05-18-2006 05:19 PM

I still could not make my ssh works in Suse 10
 
Hi dear friend,

I still could not make my ssh works in Suse 10.
My sshd_config settings are not wrong, because is is just like the settings in my suse 8.2 in where ssh works well.

port:22
permitrootlogin yes
passwordauthentication no
usePAM yes
X11forwarding yes
allowusers myusername

I stopped firewall, so port is not blocked.

Could someone tell me what could be wrong?

Thank you very much again!

Zhangy

gultapa 10-12-2006 05:24 AM

I was able to connect to suse 9.1 and surely 10 server with putty or ssh
 
All the setting are fine asked by zhangy but you have to just change the passwordauthentication from "no" to "yes" as i have mentioned below.

port:22
permitrootlogin yes
passwordauthentication yes
usePAM yes
X11forwarding yes
allowusers myusername

I stopped firewall, so port is not blocked.
You can also enable the firewall and allow ssh port default 22 or any port you define in sshd_config file.


All times are GMT -5. The time now is 11:13 AM.