LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 05-17-2006, 03:39 PM   #1
zhangy
LQ Newbie
 
Registered: May 2006
Posts: 6

Rep: Reputation: 0
Question I would not connect to suse 10 server from a windows PC using ssh. 'access denied'


It is the fisrt time for me to use suse 10. I could not make ssh works. Someone said this is because .xsession file was not correctly configured or does not locate in a correct place.

When I try to login to suse server from a windows PC using ssh, it says 'access denied' all the time.

I di not get this problem when I install Suse 8.

I would be very happy if someone can help me with this.

zhangy
from Netherland
 
Old 05-17-2006, 03:53 PM   #2
J_K9
Member
 
Registered: Nov 2004
Distribution: Slackware 11, Ubuntu 6.06 LTS
Posts: 700

Rep: Reputation: 30
Hi,
Quote:
Originally Posted by zhangy
When I try to login to suse server from a windows PC using ssh, it says 'access denied' all the time.
How is the service configured? SSH is configured using the file /etc/sshd_config, so you may want to look at 'man sshd' and then have a go at configuring that.

If you run the SSH server with unix password logins, then all you have to do from the Windows PC is download an application called PuTTY, and then following the documentation

It's quite simple - start PuTTY, enter the SSH server's IP address, type in a username and password (for example, those of a user account on the server) and then select the protocol as 'ssh'. Then, try connecting - it should work

Cheers,

-jk

Ps. Welcome to LQ!
 
Old 05-18-2006, 05:19 PM   #3
zhangy
LQ Newbie
 
Registered: May 2006
Posts: 6

Original Poster
Rep: Reputation: 0
I still could not make my ssh works in Suse 10

Hi dear friend,

I still could not make my ssh works in Suse 10.
My sshd_config settings are not wrong, because is is just like the settings in my suse 8.2 in where ssh works well.

port:22
permitrootlogin yes
passwordauthentication no
usePAM yes
X11forwarding yes
allowusers myusername

I stopped firewall, so port is not blocked.

Could someone tell me what could be wrong?

Thank you very much again!

Zhangy
 
Old 10-12-2006, 05:24 AM   #4
gultapa
LQ Newbie
 
Registered: Oct 2006
Posts: 1

Rep: Reputation: 0
I was able to connect to suse 9.1 and surely 10 server with putty or ssh

All the setting are fine asked by zhangy but you have to just change the passwordauthentication from "no" to "yes" as i have mentioned below.

port:22
permitrootlogin yes
passwordauthentication yes
usePAM yes
X11forwarding yes
allowusers myusername

I stopped firewall, so port is not blocked.
You can also enable the firewall and allow ssh port default 22 or any port you define in sshd_config file.

Last edited by gultapa; 10-12-2006 at 05:26 AM.
 
  


Reply

Tags
ssh, suse


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
samba client Access denied unable to connect Systest7 Linux - Networking 11 12-12-2010 08:45 PM
Access Denied when I try to login remotely to my SSH server running on Cygwin. andrew_cz General 0 05-02-2006 09:46 AM
XP Client Returns 'Access is Denied' Error When Trying to Connect to a Samba Server BuckRogers01 Linux - Networking 1 05-25-2005 11:55 AM
SSH login ... access denied (suse 9.1) saxxon1 Linux - Networking 3 09-14-2004 02:34 PM
access denied to a windows 2003 server Tanc Linux - Networking 2 01-08-2004 09:06 AM


All times are GMT -5. The time now is 11:37 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration