LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 10-31-2008, 11:12 PM   #1
aussie.ian
LQ Newbie
 
Registered: Apr 2008
Posts: 8

Rep: Reputation: 0
huawei E169 - authenticates then modem hangs up


I'm using a huawei e169 wireless modem on the Virginbroadband network in Australia, with a toshiba A200, OS is opensuse 11.0. I have installed umtsmon and the modem is configured and recognised. The problem is, when I try to connect I get the following error.
Quote:
Using interface ppp0
Connect: ppp0 <--> /dev/ttyUSB0
CHAP authentication succeeded
CHAP authentication succeeded
Modem hangup
Connection terminated.
I've also tried connecting with kinternet, network manager and wvdial from konsole, with the same result.
One thing I've found in yast/network devices/modem, yast will not recognise the modem correctly. The modem is at /dev/ttyUSB0 but yast does not have it as an option.

How can I stop the modem from hanging up? Is there a way to force yast to see the modem correctly? I've already tried typing /dev/ttyUSB0 as the location but when I save in yast it defaults back to /dev/modem.

Thanks......
 
Old 10-31-2008, 11:56 PM   #2
pinniped
Senior Member
 
Registered: May 2008
Location: planet earth
Distribution: Debian
Posts: 1,732

Rep: Reputation: 50
There are a few possibilities:

1. the modem is fooling you - there isn't actually a service available. You can find out by connecting to the modem port with minicom and issuing an AT+CSQ command (signal quality). If the signal is awful, then the modem messages are really meaningless and misleading.

2. the service provider is not currently giving you a lease - usually because voice is in demand at the time and the network operators always give priority to voice.

3. the service provider is not giving you a lease; GSM only exists in the area for sending text messages, not for GPRS connections. The service providers can do this at will - I put an instrument into the field one day and the service provider shut down GPRS services and denied it for about two weeks, then admitted to it but would do no more than agree to cancel the data subscription without penalties. They couldn't possibly penalize me anyway or I'd take them to court - they weren't providing the service they promised so they were the ones in breach of contract, not me.

So once you rule out a signal quality problem all you can do is wait ... and wait ... and wait. If there are other indications that the local cell is faulty, you might get somewhere by complaining about the service in the area.
 
Old 11-01-2008, 01:57 AM   #3
aussie.ian
LQ Newbie
 
Registered: Apr 2008
Posts: 8

Original Poster
Rep: Reputation: 0
Quote:
There are a few possibilities:
Thankyou for your response pinniped, My connection under vista has good line speed and connection, so I don't think the connection lease is a problem. I can boot to vista connect and run a line speed test with good results (usually), then reboot to suse and receive the error.

I have just downloaded a copy of minicom and will give it a try to see if I can find out whats going on... Tech support at virgin will soon get sick of me if I can't sort this out. LOL...
 
Old 11-01-2008, 02:12 AM   #4
pinniped
Senior Member
 
Registered: May 2008
Location: planet earth
Distribution: Debian
Posts: 1,732

Rep: Reputation: 50
Can you post your pppd configuration script and chat "connect" scripts? Just black out any details like user/password (although for GPRS user/password is usually any garbage you want so it's not a security issue). Oh - if the PIN is there, take that out.

Also post the entire pppd log for an attempted connection so we can see what negotiations are going on.

[edit]

With 'minicom', do:
AT+CPIN?
and
AT+CGDCONT?

Usually the PIN is disabled (if not, you can disable it if you wish).
Also usual is for CGDCONT to already be set; otherwise you will have to set it in the chat scripts.

Last edited by pinniped; 11-01-2008 at 02:14 AM.
 
Old 11-01-2008, 06:15 PM   #5
aussie.ian
LQ Newbie
 
Registered: Apr 2008
Posts: 8

Original Poster
Rep: Reputation: 0
I can't find the location of the scripts you asked for. If you could tell me where they are located I would be happy to post them.
This is what umtsmon does:
http://www.box.net/shared/c0fegxmgho
 
Old 11-01-2008, 07:45 PM   #6
pinniped
Senior Member
 
Registered: May 2008
Location: planet earth
Distribution: Debian
Posts: 1,732

Rep: Reputation: 50
The ppp configuration file should be in /etc/ppp/peers; the connect script should be in /etc/chatscripts.
 
Old 11-01-2008, 10:01 PM   #7
aussie.ian
LQ Newbie
 
Registered: Apr 2008
Posts: 8

Original Poster
Rep: Reputation: 0
I went back and had another look and found I don't have either of those at those locations.

/etc/ppp/peers
kppp,ppp,pppoatm,pppoe,pppoe-rp,pppt,wvdial

/etc/chatscripts - doesn't exist

Is there another location they could be?

Thanks
 
Old 11-02-2008, 01:25 AM   #8
pinniped
Senior Member
 
Registered: May 2008
Location: planet earth
Distribution: Debian
Posts: 1,732

Rep: Reputation: 50
Well, one of those scripts in /etc/ppp/peers is responsible for connecting your modem - which one is it? I'm surprised there's no chatscripts, but the ppp configuration file (once you identify which one) should give us some clues what's going on.
 
Old 11-02-2008, 03:08 AM   #9
aussie.ian
LQ Newbie
 
Registered: Apr 2008
Posts: 8

Original Poster
Rep: Reputation: 0
I did a bit of hunting around and found these. I hope they might help.
pptp.command is quite long so I uploaded it at the link below.
wvdial.conf isn't quite as long.

I hope these help.

pppd is found in /usr/sbin/ and is a binary executable
chat is in the same path and is also a binary executable

pptp.command
http://www.box.net/shared/v2dmjek5xy


wvdial.conf
http://www.box.net/shared/go2k03khi9
 
Old 11-02-2008, 04:04 AM   #10
pinniped
Senior Member
 
Registered: May 2008
Location: planet earth
Distribution: Debian
Posts: 1,732

Rep: Reputation: 50
Quote:
kppp,ppp,pppoatm,pppoe,pppoe-rp,pppt,wvdial
Well, of those, I assume 'kppp' is a profile which is invoked by kpppd - do you use kpppd to connect or not?

wvdial I would also expect to be a profile used by wvdial to connect - so are you using wvdial?

pppoe and pppoe-rp sound suspiciously like pppoe connection settings - which you don't need for that modem; these are only needed for ADSL modems which use pppoe to communicate with the computer.

pppoatm isn't needed unless you have an ATM card; ADSL modems usually have ATM hardware in them, but that's rarely exposed to the end user.

pptp is the point-to-point tunneling protocol, which you also don't need to connect your modem.

I guess the only real candidates for the dial-up configuration are kppp and wvdial

I've looked at the wvdial stuff - next time can you post it as a quote or code rather than an OpenOffice document? The wvdial settings are pretty awful and cryptic (one reason I hate tools like wvdial or kpppd).

Do you have a directory named /etc/chatscripts at all? (ls -d /etc/chatscripts) There is no requirement to use that name, but it's the usual name used.

Anyway, in /etc/ppp/peers you can create a file named "usbmodem" and put lines like this into it (using a text editor only):

Code:
lock
connect "/usr/sbin/chat -v -f /etc/chatscripts/usbconnect"
/dev/ttyUSB0
hide-password
noauth
novj
460800
defaultroute
replacedefaultroute
noipdefault
user anyone
password anything
modem
crtscts
usepeerdns
nodeflate
nobsdcomp
lcp-echo-interval 0
You will also need to create the directory /etc/chatscripts and create a file named usbconnect in it. The contents of usbconnect would be:

Code:
ABORT BUSY
ABORT ERROR
ABORT 'NO ANSWER'
REPORT CONNECT
TIMEOUT 50
"" ATZ
OK 'ATDT*99***1#'
CONNECT \d\c
The "ATDT" line is telling your GPRS modem to create a connection in "roaming" mode; if you want to ensure "local" mode only, you can use *99# instead of *99***1# - if you're in your 'local' area, the long number will still connect you as local not as roaming.

You can then kill off any instance of pppd, just to make life easier:
kill -SIGINT $(pidof pppd)
Then attempt to dial:
pon usbmodem
 
Old 11-02-2008, 06:03 AM   #11
aussie.ian
LQ Newbie
 
Registered: Apr 2008
Posts: 8

Original Poster
Rep: Reputation: 0
i've tried wvdial, networkmanager, kinternet, umtsmon and kppp........

I created the files and tried initializing with "pon usbmodem" both as user and root. In both cases the response was: bash; pon not found......
 
Old 11-02-2008, 05:02 PM   #12
aussie.ian
LQ Newbie
 
Registered: Apr 2008
Posts: 8

Original Poster
Rep: Reputation: 0
I found pon.
Using: find, I was able to locate it in, /usr/share/doc/packages/ppp/scripts. Funny place for it to be. I also found the chat scripts in the same folder. chatchat.c needs to be configured. I copied pon to /usr/sbin and ran, pon usbmodem and the result is the same.

Is there a way I can extend the time for the modem to authenticate, I've noticed in windows sometimes the authentication can take up to a minute, but in all apps I've tried with suse this process seems to end in about 30 seconds. If I can extend the process I might be able to connect.
 
Old 11-03-2008, 03:35 AM   #13
pinniped
Senior Member
 
Registered: May 2008
Location: planet earth
Distribution: Debian
Posts: 1,732

Rep: Reputation: 50
Quote:
Originally Posted by aussie.ian View Post
Is there a way I can extend the time for the modem to authenticate, I've noticed in windows sometimes the authentication can take up to a minute, but in all apps I've tried with suse this process seems to end in about 30 seconds. If I can extend the process I might be able to connect.
It's rather bizarre that the whole negotiation can take so long (perhaps your cell is severely oversubscribed). In the chat 'connect' script set the timeout (time 'chat' waits for a response) to any value you wish.

[edit]

In the chat script I had posted previously, the timeout was set to 50.

Last edited by pinniped; 11-03-2008 at 03:37 AM.
 
Old 12-04-2009, 02:08 AM   #14
mazinoz
Member
 
Registered: Mar 2003
Location: Mansfield Queensland Australia
Distribution: Debian Squeeze. Various live CD's Win7
Posts: 359

Rep: Reputation: 32
Quote:
Originally Posted by aussie.ian View Post
Thankyou for your response pinniped, My connection under vista has good line speed and connection, so I don't think the connection lease is a problem. I can boot to vista connect and run a line speed test with good results (usually), then reboot to suse and receive the error.

I have just downloaded a copy of minicom and will give it a try to see if I can find out whats going on... Tech support at virgin will soon get sick of me if I can't sort this out. LOL...
Dear Ian

I live in Mansfield Qld and have tried Vodafone, 3, Virgin prepaid and postpaid. There are two issues going on here:

1. The networks are congested and people find it hard to get a connection or decent speeds at times. Virgin are testing the network and stuffing around and have put peoples speeds back to GSM. Because of this I found it best to enable any 'persist' options in scripts, and it can take a few such efforts after it has authenticated using pap-secrets. You are extremely lucky if it connects the first time. At times my mobile phone doesn't work here!

2. I use Debian but used SuSE for many years previously. I had wireless networking connecting for all the above. I happened to use pap-authentication successfully and was looking at chap as a safer alternative but some kubuntu users say it won't work in Australia and to disable it and only enable pap-secrets. Haven't looked at vpn yet.

3. I assume you are using KDE, and would like to suggest you try kppp to establish a connection. You need to add yourself to the dialout group in user settings and run it as sudo su. If you are using gnome try gnome-ppp or try kppp in gnome, it should work. This is probably the least painful option. The APN is VirginBroadband if you are using postpaid but it may be VirginInternet if prepaid. ID is your mobile sim number, pw is what is in your /etc/ppp/pap-secrets file. Their phone number is *99# If you use the command line to start kppp, you may get helpful messages about errors.

You need to setup a symbolic link for the modem. ln -sf /dev/ttyUSB0 /dev/modem.

As a side note make sure firewalls etc are open on 80 443, 8080 or 3128. Firestarter is easy to use and quite powerful.

4. If you still have problems I will email you the scripts you need to edit to connect. This is how I originally did it.

Last edited by mazinoz; 12-04-2009 at 02:11 AM.
 
Old 12-08-2009, 04:54 PM   #15
mazinoz
Member
 
Registered: Mar 2003
Location: Mansfield Queensland Australia
Distribution: Debian Squeeze. Various live CD's Win7
Posts: 359

Rep: Reputation: 32
Aussie Ian, any luck?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
SMStools and Huawei E220 3G modem makobu Linux - Software 0 08-10-2008 01:46 PM
Setting up 3g modem (Huawei E220) Arla Linux - Wireless Networking 4 06-13-2008 01:17 AM
how to use huawei modem to linux jothikrish Linux - Software 1 05-02-2008 10:44 AM
please help! how to use huawei wll modem on linux gul_the_bull Linux - Hardware 13 08-09-2007 03:21 PM
Huawei Wireless Modem AtinLango Linux - General 0 02-19-2006 04:22 AM


All times are GMT -5. The time now is 10:25 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration