LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices



Reply
 
Search this Thread
Old 11-21-2006, 02:54 PM   #1
gakusei
LQ Newbie
 
Registered: Feb 2003
Posts: 18

Rep: Reputation: 0
http://localhost:631 Loops Instead of Displaying Page


In Fedora Core 6, when from the Firefox browser I enter: http://localhost:631 instead of seeing the expected cups page, "nothing happens" Firefox shows a moving circular arrow like its trying to connect, but no error message, and no timeout (it probably would eventually)

This worked at one time, so I have done "something" to kill it. Searched in linuxquestions and also Googled localhost:631 and found no hits on this. I did find posts with these diagostic commands saying both should show tcp 0.0.0.0:631

netstat -nl | grep 631 and netstat -pan | grep tcp

They both show "udp" instead of "tcp", viz: udp 0 0 0.0.0.0:631
Am guessing this is the problem. Can anyone suggest corrective action to get "tcp" to replace "udp"?

localhost 127.0.0.1 is in the /etc/hosts file and I am able to use turboprint to print to my canon i950 printer.

Thank you.
 
Old 11-21-2006, 03:24 PM   #2
Lenard
Senior Member
 
Registered: Dec 2005
Location: Indiana
Distribution: RHEL/CentOS/SL 5 i386 and x86_64 pata for IDE in use
Posts: 4,790

Rep: Reputation: 56
Are you sure about 127.0.0.1 being in /etc/hosts for FC6??? Did you manually edit this file because I see;

$ cat /etc/hosts
# Do not remove the following line, or various programs
# that require network functionality will fail.
::1 localhost.localdomain localhost

Which is perfectly fine, also any problem with using; http://127.0.0.1:631 instead??
 
Old 11-21-2006, 03:59 PM   #3
gakusei
LQ Newbie
 
Registered: Feb 2003
Posts: 18

Original Poster
Rep: Reputation: 0
Thank you for the reply.

http://127.0.0.1 returns "unable to connect" "firefox can't establish a connection to the server at 127.0.0.1" But at least it didn't loop. :-)))

My /etc/hosts content:
# Do not remove the following line, or various programs
# that require network functionality will fail.
::1 kpchisai.com
127.0.0.1 kpchisai.com
192.168.1.101 DELLDT01

The ::1 and 127 lines were already there when the "hosts" panel was displayed. I added the 192.168.1.101 line via Gnome's system/Administration/network/hosts/new panel. Cannot get Samba's smbtree or smbclient to work (Get "connection refused" message - its a Windows XP SP2 box), so added its address to hosts hoping it would clear that in case the "refused" was coming from Samba, but of course it wasn't.

I just deleted that line - via the Gnome panels, and rebooted, but no change in symptom.
 
Old 11-21-2006, 04:20 PM   #4
michaelk
Moderator
 
Registered: Aug 2002
Posts: 12,152

Rep: Reputation: 783Reputation: 783Reputation: 783Reputation: 783Reputation: 783Reputation: 783Reputation: 783
Is the cups daemon running? If it isn't no page will be displayed in the browser as described. Check via the top or ps command.
 
Old 11-21-2006, 05:09 PM   #5
gakusei
LQ Newbie
 
Registered: Feb 2003
Posts: 18

Original Poster
Rep: Reputation: 0
Its running, I think (I'm still learning Linux, so may be wrong)
Line from ps -ef
...
root 2822 1 0 11:14 ? 00:00:00 cupsd
...
 
Old 11-22-2006, 12:37 PM   #6
gakusei
LQ Newbie
 
Registered: Feb 2003
Posts: 18

Original Poster
Rep: Reputation: 0
Problem solved. Am posting this in case someone else runs into the same issue.

I took the coward's way out and re-installed Fedora Core 6 and now http://localhost:631 works.

Did a netstat -nl | grep 631 and it shows
tcp 0 0 ::1:631
so looks like my thought in the original post where that command showed "udp" instead of "tcp" was the cause. I have no idea what I did to get it changed from "tcp" to "udp", but will definetely keep a better "settings change log" from now on.
 
Old 11-22-2006, 12:48 PM   #7
michaelk
Moderator
 
Registered: Aug 2002
Posts: 12,152

Rep: Reputation: 783Reputation: 783Reputation: 783Reputation: 783Reputation: 783Reputation: 783Reputation: 783
FYI the results from netstat -nl | grep 631 show both TCP and UDP on my server that runs trustix.
 
Old 11-23-2006, 11:51 AM   #8
gakusei
LQ Newbie
 
Registered: Feb 2003
Posts: 18

Original Poster
Rep: Reputation: 0
Thanks, Michaelk. My last post was sloppy. After the FC6 reinstall, the netstat -nl | grep 631 does show upd and tcp for port 631. When I had the original problem, it only showed the udp entry, and the post I'd found with Google only talked about "tcp" so I didn't realize that both protocols were involved.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
CUPS http://localhost:631/ LUB997 Linux - Software 1 09-26-2005 08:52 PM
Can't find http://localhost:631 encore Slackware 5 03-07-2005 07:26 PM
can't load http://localhost:631 in browser cragwolf Slackware 2 09-06-2004 07:43 PM
http://localhost:631 zaicheke Linux - Software 5 08-01-2004 02:13 PM
What the heck is http://localhost:631 glenn69 Linux - Newbie 5 10-04-2003 03:02 PM


All times are GMT -5. The time now is 12:55 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration