LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
LinkBack Search this Thread
Old 02-15-2007, 04:11 PM   #1
SentralOrigin
Member
 
Registered: Jul 2005
Distribution: Gentoo, Ubuntu
Posts: 318

Rep: Reputation: 30
How to stop eth0 interface on boot before dhcpcd lease


I think I am running Gentoo though I have a vanilla kernel.

Whenever I boot up my computer, it starts ath0 and eth0 (the wireless card and the ethernet interface). How do I stop the eth0 from starting? Basically I want to do "ifconfig eth0 down" at boot before it starts connecting to anything automatically. I tried rc-update del net.eth0 default or whatever, and there are no net eth0 files in /etc/conf.d. I dunno about the files in /etc/init.d/net.ath0 and /etc/init.d/net.eth0 and /etc/init.d/net.lo. Those are pretty long files. But I want to keep the ath0 up.

So, how would I go about doing this?

Thanks in advance.

Last edited by SentralOrigin; 02-15-2007 at 10:04 PM.
 
Old 02-15-2007, 05:27 PM   #2
Micro420
Senior Member
 
Registered: Aug 2003
Location: Berkeley, CA
Distribution: Mac OS X Leopard 10.6.2, Windows 2003 Server/Vista/7/XP/2000/NT/98, Ubuntux64, CentOS4.8/5.4
Posts: 2,986

Rep: Reputation: 45
Never used Gentoo, but you can either remove/disable the service or edit the network interfaces file and comment out the eth0

With redhat, you could disable service by:
Code:
chkconfig network off
Also in RedHat, when you boot you can press 'I' for interactive start up where YOU call the shots on what to start and what not to start.

On ubuntu, you could just edit
Code:
/etc/network/interfaces
 
Old 02-15-2007, 07:12 PM   #3
SentralOrigin
Member
 
Registered: Jul 2005
Distribution: Gentoo, Ubuntu
Posts: 318

Original Poster
Rep: Reputation: 30
I don't want to disable all the services. I just want eth0 out but ath0 on. The Network interface files are all empty. I built from the raw vanilla kernel up, so there is nothing on the files.

If I had to press "I" during bootup, that wouldn't make it automatic, now would it I want it configured so that I don't HAVE to do anything, and all the services I want start up.
 
Old 04-17-2007, 11:59 PM   #4
UhhMaybe
Member
 
Registered: Jul 2004
Location: Salt Lake City, Utah
Distribution: Absolute 12.0 Studio 64 1.3.0
Posts: 470

Rep: Reputation: 30
Cool

With all due respect...no flaming from me. If YOU no longer need the Eth0 setup,...remove the Ethernet Card from the system. Seriously,...if YOU'RE not going to use it again, for a while.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
What does dhcpcd do when it fails to lease an IP address? bulldozer Linux - Networking 2 11-26-2006 04:57 PM
Disable dhcpcd for eth0 on boot thomasw92 Linux - Newbie 2 04-10-2006 01:49 AM
Can't bring up eth0 Interface at boot robertmenezes Linux - Networking 8 02-21-2005 01:13 AM
Stop eth0:1 from starting on boot magicdev Linux - Networking 3 09-13-2004 08:46 AM
how do i stop eth0 from trying to config at boot? h1tman Linux - Networking 2 04-04-2004 10:38 PM


All times are GMT -5. The time now is 02:40 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration