LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
LinkBack Search this Thread
Old 10-22-2003, 02:02 AM   #1
rmanocha
Member
 
Registered: Oct 2003
Location: Austin,TX
Distribution: Debian SID-->fully content-->Love APT,kernel 2.6.4
Posts: 327

Rep: Reputation: 30
How to start Swat(SuSE 8.2 samba 2.2.7)


hi!I have trying for a while but i cant seem to be able to start up SWAT but all it gives me is that "The connection was refused when attempting to contact localhost:901
(yes i did reboot aftre changing the services file and the other files and i did put the given howto both in inetd.conf and in xinetd.d i think i am running inetd though...i am not sure.)
I followed some online HOWTO's:samba.linuxbe.org/en/samba/learn/swat.html
However i still cant get it working.I even start swat from the console and then type in localhost:901 but it still does not give me anything.
Any help would really be appreciated....i am running SuSE 8.2 wilh samba 2.2.7.
(sorry about no http's/URL's in here but it seems like i have to have had5 posts before i can put in url's).
 
Old 10-22-2003, 07:41 AM   #2
tgflynn
Member
 
Registered: Oct 2003
Location: Rochester, New York (USA)
Distribution: Debian
Posts: 119

Rep: Reputation: 15
The first thing you need to determine is if you are really running inetd. To do this enter the following command at a console prompt :

ps aux | grep inetd

If inetd is running you should see a line that ends with /usr/sbin/inetd or something very similar. You may also see a line that ends with grep inetd but this is to be ignored. If you're still not sure you can post the results of the above command.

If you are running inetd then you can try the following command as root :

netstat -tap |grep inetd

You should see several lines, one for each service that is activated in inetd. One of the lines should contain the word swat in the third column. Again if your not sure you can post the output of the command.

If it turns out that you're running xinetd then the inetd configuration line would not work since xinetd uses a different syntax.

By the way you don't have to reboot after editing /etc/inetd.conf, just send a signal to the inetd process. To do this look at the output of the ps aux command above. The process id (PID) of the inetd process is the number in the second column. If that number were, say 639, you would use the following command to reconfigure inetd :

kill -SIGHUP 639

Tim
 
Old 10-22-2003, 10:21 AM   #3
rmanocha
Member
 
Registered: Oct 2003
Location: Austin,TX
Distribution: Debian SID-->fully content-->Love APT,kernel 2.6.4
Posts: 327

Original Poster
Rep: Reputation: 30
Smile not running inetd

thanks for the reply...well it rurns out i am not running inetd-the output i get for ps aux | grep inetd was:
rmanocha 2563 0.0 0.2 3528 552 pts/1 R 10:16 0:00 grep inetd
i tried it with root too but got the same result.
i tried to do the same(ps aux | grep xinetd) but that gave me the same result as inetd:
root 2830 0.0 0.2 3528 552 pts/1 R 10:25 0:00 grep xinetd
newayz i have i created a file called swat in my /etc/xinetd.d folder with the following in it:
service swat
{
port = 901
socket_type = stream
wait = no
only_from = localhost
# only_from = 192.168.0.4m
user = root
server = /usr/sbin/swat
log_on_failure += USERID
disable = no
}

i dot know if this is valid but i am running some process called init(excuse me if this is somethign else completely....i just think it kind of sounds similar-)
i dont know why this is not working either....well newayz i got webmin and that is working....it has an option for swat too so i clicked on it and i did get an identification screen but even that did not allow me to log into swat.
do i have to do something in my smb.conf?
i even added root to my list of smbusers.
I dont mind using webmain but i would really love to get swat working as i am going for a job interview 2morow and i am pretty sure they would ask me if i know how to administer samba using swat.
well thanks for the help.

Last edited by rmanocha; 10-22-2003 at 10:40 AM.
 
Old 10-22-2003, 10:56 AM   #4
porous
Member
 
Registered: Oct 2003
Distribution: redhat 9
Posts: 147

Rep: Reputation: 15
if you are trying to configure samba the manually editing smb.cong would be a better idea , coz i have read somewhere that configuring samba with swat has its security flaws...

if i understood you wrongly , forget it ....
 
Old 10-24-2003, 10:20 AM   #5
tgflynn
Member
 
Registered: Oct 2003
Location: Rochester, New York (USA)
Distribution: Debian
Posts: 119

Rep: Reputation: 15
Sorry I wasn't able to get back to you sooner.

It sounds like you're running neither inetd nor xinetd (init is something else entirely). You need to get one of these running first if you want to use SWAT.

You should first check to see if the binaries are installed. You should have either /usr/sbin/inetd or /usr/sbin/xinetd. If one of these is installed then there's probably a configuration option you need to select to enable it. It's been a number of years since I've used SuSe so I can't tell you exactly how to enable it. If you've been using YAST for graphical configuration then you should probably start looking there and/or consult the SuSe manuals. There are ways to do this without using the SuSe tools but it would be a bit complicated to walk you through them.

If neither binary is installed then you'll need to install some other package. In this case, if you have the choice I would suggest you start with inetd since the SWAT instructions are written for it. Xinetd does have advantages but since it's less widely used you'll have more trouble getting help with its configuration.

Tim
 
Old 10-24-2003, 10:44 AM   #6
rmanocha
Member
 
Registered: Oct 2003
Location: Austin,TX
Distribution: Debian SID-->fully content-->Love APT,kernel 2.6.4
Posts: 327

Original Poster
Rep: Reputation: 30
thanks for your reply but i dont think i am going to be using swat...i have tried this thing called webmin, but after trying all this i think i willl just configure samba by hand...that seems the best way to go about it.
thanks newayz
 
Old 10-24-2003, 03:55 PM   #7
mjenkins
Member
 
Registered: Jun 2003
Location: kc
Distribution: fc2
Posts: 52

Rep: Reputation: 15
http://startlinux.co.nz/articles/article_146.php
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Help with Samba/SWAT driesel Linux - Newbie 3 02-13-2005 09:33 AM
How to start Samba server in SuSE? fclifton Linux - Newbie 1 09-23-2004 04:33 PM
cant start nmbd in SWAT or Samba jack cards Linux - Networking 5 08-08-2003 08:14 PM
Swat Samba whatever! theguy311 Linux - Software 8 01-25-2003 01:42 PM
SWAT won't start Harryc Linux - Newbie 1 01-01-2003 07:25 PM


All times are GMT -5. The time now is 09:02 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration