LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
LinkBack Search this Thread
Old 04-18-2005, 04:52 PM   #1
chammoud
LQ Newbie
 
Registered: Dec 2004
Location: lebanon
Distribution: redhat 9
Posts: 5

Rep: Reputation: 0
How To Rename Ethernet Card Eth1 to Eth0


I have Mandrake 10.1.
I downloaded a file and tried to register it. This file looks for ethernet card and expects eth0 , otherwise it doesn't register. Originally I had two cards, a buit-in (eth1) and a RealTek(eth0). Later, I removed the Realtek (eth0) and the built-in still named eth1 by Mandrake.
How can I configure the eth1 card to be eth0.

Thanks in advance
 
Old 04-18-2005, 05:27 PM   #2
jonaskoelker
Senior Member
 
Registered: Jul 2004
Location: Denmark
Distribution: Ubuntu, Debian
Posts: 1,524

Rep: Reputation: 46
Can't you just change the file to expect eth1 instead?
$ sed -i -e 's/eth0/eth1/g' filename #but make a backup first
also, you should file a bug report for lame hardcoded behavior to the maintainers.
 
Old 04-18-2005, 11:06 PM   #3
chammoud
LQ Newbie
 
Registered: Dec 2004
Location: lebanon
Distribution: redhat 9
Posts: 5

Original Poster
Rep: Reputation: 0
i already asked about the vendor about changing the file script to expect eth1, but the technician wasn't helpful.
I tried the above command and still wasn't able to register the file.

Any other suggestion?

Thanks
 
Old 04-18-2005, 11:33 PM   #4
chammoud
LQ Newbie
 
Registered: Dec 2004
Location: lebanon
Distribution: redhat 9
Posts: 5

Original Poster
Rep: Reputation: 0
At the booting time, Mandrake still tries to activate eth0 device and fail although card eth0 was removed, but Mandrake doesn't seems to see that.

Any suggestions please?
 
Old 04-20-2005, 06:01 AM   #5
jonaskoelker
Senior Member
 
Registered: Jul 2004
Location: Denmark
Distribution: Ubuntu, Debian
Posts: 1,524

Rep: Reputation: 46
regarding the `bug' report:
I was thinking more in the lines of suggesting a command-line/config-file option that lets the user select which file to act on (be it /dev/eth0, /dev/eth1, /dev/hda (*grin*) or whatever); maybe they'd be more understanding.

Asking to change one hardcoded value to another hardcoded value (that works for you) is never the Right Thing. Have you tried the sed approach?

I'm sorry, but I don't know how to remap eth[01] into the other; gurus?

--Jonas
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
x86 board PCM 6892 with dual ethernet port.eth1 doesnt ping if eth0 cable removed rani_162 Linux - Newbie 0 07-23-2005 12:29 PM
Start ethernet device numbering at 1 instead of 0 (eth1 instead of eth0) rbecker Linux - Networking 2 02-24-2005 01:43 PM
Wireless network on eth1 diabled Ethernet eth0 and eth0 never comes back tadatoshi Linux - Wireless Networking 4 09-23-2004 05:57 PM
How do you switch the default ethernet adapter (eth0 to eth1)? scoobdoobery Linux - Networking 3 09-05-2004 01:29 PM
eth1 added, mysql connections FROM this machine are from eth1. Need bound to eth0??? kreese Linux - Networking 9 03-31-2004 12:12 PM


All times are GMT -5. The time now is 05:30 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration