LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices



Reply
 
Search this Thread
Old 08-07-2002, 03:01 PM   #1
aldaeron
LQ Newbie
 
Registered: Aug 2001
Distribution: Slackware 8.0
Posts: 10

Rep: Reputation: 0
How to not init eth0 at boot time


I have been trying to install rp pppoe and the howto file says "DO NOT assign an IP address to the Ethernet card. DO NOT configure the card to come up at boot time."

How do I do that? I tried commenting out all the ip stuff in /etc/rc.d/rc.inet-eth0 but it tried to load on boot. Should I just delete /etc/rc.d/rc.inet-eth0 ?? Thanks for your help!
 
Old 08-07-2002, 04:55 PM   #2
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,539

Rep: Reputation: 149Reputation: 149
I think you can delete it.
 
Old 08-07-2002, 06:42 PM   #3
trickykid
Guru
 
Registered: Jan 2001
Posts: 24,133

Rep: Reputation: 199Reputation: 199
If your using Slack 8, you need to comment out the lines for /etc/rc.d/rc.inet1 so it doesn't try to configure your ethernet card and assign a IP to it.
But you can either just delete the file probably would work as well. Not sure or never seen a rc.inet-eth0 startup script for Slack unless you created it yourself.
 
Old 08-07-2002, 07:00 PM   #4
krunkwick
Member
 
Registered: Jun 2002
Location: Memphis
Distribution: Suse 8.0 Pro
Posts: 45

Rep: Reputation: 15
You may also want to check out webmin. Its a web administration tool (I have had no problems with the base product from the web site) that allows you to configure all aspects of the machine.

It also allow for you to not have an interface load at boot time.
 
Old 08-07-2002, 08:30 PM   #5
lopezjo49
Member
 
Registered: Jun 2002
Location: NJ
Distribution: Mainly Kubuntu 8.10
Posts: 44

Rep: Reputation: 15
I don't use slackware, I use RH but you could try to see if this file exists.
/etc/sysconfig/networking/devices/ifcfg-eth0
and set ONBOOT='no'
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Starting eth0 at boot time ? Antonius Linux - Newbie 1 01-19-2005 08:27 PM
eth0 causes looooong boot time mrsolo Linux - Software 10 11-07-2004 10:29 PM
want to reduce system boot / init time 964racer Linux - Laptop and Netbook 7 06-09-2004 04:11 AM
First time user can't get linux to boot. Locks on ETH0 DGath Linux - Newbie 10 06-29-2003 06:48 PM
howto disable eth0 at boot time rydogg Linux - Newbie 2 06-16-2003 10:33 AM


All times are GMT -5. The time now is 06:41 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration