LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
LinkBack Search this Thread
Old 11-17-2007, 01:08 PM   #1
kustomjs
Member
 
Registered: Apr 2007
Posts: 37

Rep: Reputation: 15
How To Get Ubuntu work without having stupid DHCP server?


Hey Guys
is there anyway that when you setup ubuntu server get around that stupid DHCP setting for network settings because everytime I get to configuring apt the stupid thing just sets there at 40% and its starting to piss me off and I am on static IP (FTTH) internet and the FTTH is behind a linksys wrt54g router what can I do to finish the setup!!!!!!
 
Old 11-17-2007, 02:01 PM   #2
686plus
Member
 
Registered: Nov 2004
Location: Portland, Oregon
Distribution: Ubuntu
Posts: 114

Rep: Reputation: 17
I'm not sure DHCP is your problem. You may have a static internet ip address, but you're router (unless you configured it otherwise) probably assigns addresses using DHCP.

Its been a while since I've installed ubuntu server, but I think you can just accept the default settings and change it later to complete the installation.

Is your install media ok? Did you verify the md5sum on the iso if you downloaded it?
 
Old 11-17-2007, 02:29 PM   #3
KrahnacK
Member
 
Registered: Nov 2007
Location: /dev/volcano
Posts: 70

Rep: Reputation: 15
the way you connect to the internet isn't related to this, the only thing that matters is your connection with your router.
check your network config at /etc/network/interfaces and make sure there isn't a line specifying dhcp

here's my eth0 config in /etc/network/interfaces

# The primary network interface
iface eth0 inet static
address 192.168.1.9
netmask 255.255.255.0
gateway 192.168.1.1


you may also need to configure a DNS (in /etc/resolv.conf), which should point to your router, as the gateway cited above :
nameserver 192.168.1.1


sorry but i don't really know about the ubuntu server's installation process
 
Old 11-17-2007, 05:42 PM   #4
hamster
Member
 
Registered: Apr 2003
Location: Waterford, Ireland
Distribution: Mandrivia 2006.1, Ubuntu 7.10
Posts: 188

Rep: Reputation: 30
Quote:
Originally Posted by KrahnacK View Post
you may also need to configure a DNS (in /etc/resolv.conf), which should point to your router, as the gateway cited above :
nameserver 192.168.1.1
This worked for me. However should we add the primary and secondary dns addresses on the router (its connected to my ADSL BB).
eg add two more lines for the dns.?
nameserver 192.168.1.1 # gateway
nameserver 213.94.190.163 # 1st dns
nameserver 213.94.190.156 # 2nd dns

It works without them but may it is best to put them in.

Last edited by hamster; 11-17-2007 at 05:43 PM.
 
Old 11-17-2007, 08:18 PM   #5
kustomjs
Member
 
Registered: Apr 2007
Posts: 37

Original Poster
Rep: Reputation: 15
so how do I get this to fix? because its really starting to piss me off.
 
Old 11-17-2007, 08:40 PM   #6
hamster
Member
 
Registered: Apr 2003
Location: Waterford, Ireland
Distribution: Mandrivia 2006.1, Ubuntu 7.10
Posts: 188

Rep: Reputation: 30
Quote:
Originally Posted by kustomjs View Post
so how do I get this to fix? because its really starting to piss me off.
Hi kustomjs,
I have my router on DCHP still but I have my ip made static and it works fine for me (except for a weird ping issue which isn't stopping me doing anything)

Compare your setup to these if you want static ips. If still no joy, try changing your router to use static as well.

My ip example is 192.168.1.50
My gateway is 192.168.1.254 (some folks have theirs end in .1)
Put your desired hostname in for "yourhostname" - if you are doing that.
Code:
1. sudo vim /etc/network/interfaces
# primary network interface
auto eth0
iface eth0 inet static
address 192.168.1.50
netmask 255.255.255.0
network 192.168.1.0
broadcast 192.168.1.255
gateway 192.168.1.254
Code:
1b. sudo vim /etc/resolv.conf		# adding the primary and secondary dns of router and gateway
nameserver 192.168.1.254
nameserver 213.94.190.194
nameserver 213.94.190.236
Code:
2. sudo /etc/init.d/networking restart	# restart the network
   sudo /etc/init.d/networking restart	# stops the network (if desired)

3. sudo /bin/hostname yourhostname		# setting a new hostname if desired
   When system boots it will read the /etc/hostname

4. update /etc/hosts to include your hostname
127.0.0.1 yourhostname localhost
Code:
5. slow internet:
Ipv6 (Internet Protocol v6 will someday supercede v4). It can cause speed issues. Disable it if it is slow.
To fully disable Ipv6:
sudo vim /etc/modprobe.d/aliases
Find the line alias net-pf-10 ipv6 and change it to read alias net-pf-10 off. Reboot.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
I cant get Ubuntu Server 7.10 networking to work kustomjs Linux - Networking 2 11-12-2007 01:39 AM
No IP address from DHCP server on Ubuntu 6.06, 6.1, Knoopix, Fedoce 5 and SuSE 10.1 MatWab Linux - Wireless Networking 8 06-19-2007 05:44 PM
Config DHCP server Ubuntu safapombo Linux - Networking 4 05-09-2007 09:20 AM
Ubuntu server DHCP troubles. Compliant Ubuntu 1 04-24-2007 01:35 PM
DHCP server problems -- can't get my box to work as a router KingofBLASH Linux - Networking 1 03-21-2004 06:19 AM


All times are GMT -5. The time now is 02:14 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration