-   Linux - Networking (
-   -   How to exit vncviewer's fullscreen mode? F8 doesn't work. (

earthw0rmjim 09-13-2011 10:17 AM

How to exit vncviewer's fullscreen mode? F8 doesn't work.

This problem is kind of strange and i have no idea what causing it.
When i'm connecting to my PC (from a notebook) through vncviewer, i can use F8 to enter fullscreen mode. However when i'm at fullscreen mode F8 doesn't seem to work anymore. I have to either reboot or kill the vncserver to exit.
I'm using xtightvncviewer on Debian with xfce.

Any ideas how to fix this?

ocstjf 09-15-2011 03:13 PM

You've probably figured out by now, but mine says, "To exit from full-screen mode, press Ctrl-Alt-Shift-F. Alternately, press Ctrl-Esc Esc and then right-click on the vncviewer taskbar icon to see the menu."

Skaperen 09-15-2011 05:04 PM

If you cannot get vnc to exit the full screen, you might at least be able to switch virtual desktops to get around it. Using Ctrl+Alt+(one of the arrow keys) is a common way to do that. If you have not used or set up virtual desktops, you should try it. By starting up vnc in a separate virtual desktop just for it, you can just leave it in full screen mode and move to and from it with the virtual desktop shifting. That assumes vnc doesn't completely capture every possible keystroke. I have done this with qemu in full screen mode and I was still able to shift to and from it via virtual desktops.

TheWind777 06-29-2015 01:53 PM

Exiting from Fullscreen Mode in VNCViewer
Before you enter Fullscreen mode, if you right-click the blue title bar and select 'Options'...

Click on Inputs and down at the bottom it says 'Menu key:'. Select F8 there. You can also select any other function key.

Then, go back to Display tab and pick Full Screen Mode.

Click OK.

To exit from full screen mode press F8 and uncheck 'Fullscreen'.

CTRL-ALT-SHIFT-F is not one of the choices. Maybe some old version of VNCViewer allowed that. Mine is VNC Viewer 5.2.3 (r8648) 32-bit Jan 28 2015

All times are GMT -5. The time now is 11:02 PM.