Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back > Forums > Linux Forums > Linux - Networking
User Name
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.


  Search this Thread
Old 09-13-2011, 09:17 AM   #1
Registered: Sep 2011
Distribution: Debian testing
Posts: 50

Rep: Reputation: 12
How to exit vncviewer's fullscreen mode? F8 doesn't work.


This problem is kind of strange and i have no idea what causing it.
When i'm connecting to my PC (from a notebook) through vncviewer, i can use F8 to enter fullscreen mode. However when i'm at fullscreen mode F8 doesn't seem to work anymore. I have to either reboot or kill the vncserver to exit.
I'm using xtightvncviewer on Debian with xfce.

Any ideas how to fix this?

Last edited by earthw0rmjim; 09-13-2011 at 09:44 AM.
Old 09-15-2011, 02:13 PM   #2
LQ Newbie
Registered: Apr 2008
Posts: 6

Rep: Reputation: 0
You've probably figured out by now, but mine says, "To exit from full-screen mode, press Ctrl-Alt-Shift-F. Alternately, press Ctrl-Esc Esc and then right-click on the vncviewer taskbar icon to see the menu."
Old 09-15-2011, 04:04 PM   #3
Senior Member
Registered: May 2009
Location: WV, USA
Distribution: Slackware, Ubuntu, Amazon Linux
Posts: 1,827
Blog Entries: 21

Rep: Reputation: 118Reputation: 118
If you cannot get vnc to exit the full screen, you might at least be able to switch virtual desktops to get around it. Using Ctrl+Alt+(one of the arrow keys) is a common way to do that. If you have not used or set up virtual desktops, you should try it. By starting up vnc in a separate virtual desktop just for it, you can just leave it in full screen mode and move to and from it with the virtual desktop shifting. That assumes vnc doesn't completely capture every possible keystroke. I have done this with qemu in full screen mode and I was still able to shift to and from it via virtual desktops.
Old 06-29-2015, 12:53 PM   #4
LQ Newbie
Registered: Jun 2015
Posts: 1

Rep: Reputation: Disabled
Exiting from Fullscreen Mode in VNCViewer

Before you enter Fullscreen mode, if you right-click the blue title bar and select 'Options'...

Click on Inputs and down at the bottom it says 'Menu key:'. Select F8 there. You can also select any other function key.

Then, go back to Display tab and pick Full Screen Mode.

Click OK.

To exit from full screen mode press F8 and uncheck 'Fullscreen'.

CTRL-ALT-SHIFT-F is not one of the choices. Maybe some old version of VNCViewer allowed that. Mine is VNC Viewer 5.2.3 (r8648) 32-bit Jan 28 2015

Last edited by TheWind777; 06-29-2015 at 12:55 PM.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Howto leave vncviewer -fullscreen mode Consystor Linux - Software 3 09-05-2012 10:46 AM
Fullscreen CLI dims out after exit X mkoco Slackware 9 02-18-2008 01:59 AM
After exit the X system bash doesn't work. ghostofsin Slackware 4 01-21-2008 11:18 PM
Mouse doesn't work in fullscreen Dark_Oppressor Linux - Software 2 05-15-2005 01:12 PM
How to switch workspace on machine running vncviewer fullscreen? cmisip Linux - Networking 4 07-29-2003 05:41 PM

All times are GMT -5. The time now is 05:02 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration