LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (http://www.linuxquestions.org/questions/linux-networking-3/)
-   -   How to configure a eth0 device or driver to be loaded at boot (http://www.linuxquestions.org/questions/linux-networking-3/how-to-configure-a-eth0-device-or-driver-to-be-loaded-at-boot-116682/)

montfer 11-16-2003 10:42 AM

How to configure a eth0 device or driver to be loaded at boot
 
Hy everybody !

I really need help, I don't know what to do anymore.

My problem seems very simple but I can't fix ii.

Well my problem is :

I have changed my ethernet card on my PC. When I boot Linux mandrake 9.1 (bamboo) and when I go on Internet it does not work.

So I go on mandrake sysconfig console and I configure the network, the system restarts networkl and then I go on internet just fine.

My problem is that the configuration is not saved when I shutdown my computer, indeed when i boot again I have to reconfigure eth0 again and again and again...ouf...I am fead up !

I tried to understand somethings about init, inittab, rc.d, init.d, modules...etc to solve my problem but I have not find my solution yet.

Please can somebody help ?:confused:

/bin/bash 11-16-2003 06:23 PM

If you have these files please post the contents?

/etc/sysconfig/network
/etc/sysconfig/network-scripts/ifcfg-eth0

Also what is the result of this command?
/sbin/chkconfig --list network

it should be something like this:
Code:

network        0:off  1:off  2:on    3:on    4:on    5:on    6:off
If 3 and 5 are not on then do this:
/sbin/chkconfig --level 35 network on
then
/sbin/service network start

Just a few things to check.

Patrick Bulteel 11-16-2003 09:45 PM

Within the mandrake control panel, you have the ability to configure your network. If you go to the advanced networking options you can select the option to have the network card come up at boot time and to use DHCP or static, etc. Hopefully that'll help.

montfer 11-18-2003 03:09 PM

Me
 
Hy ,

thank you for your help.

The content of etc/sysconfig/network is simple :

HOSTNAME=HOME
NETWORKING=yes

The content of /etc/sysconfig/network-scripts/ifcfg-eth0 is

DEVICE=eth0
BOOTPROTO=dhcp
ONBOOT=yes
NEEDHOSTNAME=yes

the result of the command sbin/chkconfig --list network is
network 0:Arrêt 1:Arrêt 2:Marche 3:Marche 4:Marche 5:Marche 6:Arrêt

besides in the mandrake network & internet configuration form the checkbox start on boot is positioned to yes. I believe that it comes from the reading of the ifcfg-eth0 file.

Nevertheless I still have to reconfigure my internet connection on mandrakeconnect each time I boot.

It also says that the driver of the device is ne2k-pci when I configure the card with drakeconnect.

When I look to the new card specifications I have the followings :

Vendeur: ‎D-Link Inc

Bus: ‎PCI

Identification de Bus: ‎1186:1300:1186:1303

Position sur le bus: ‎0:9:0

Description: ‎DFE 538 TX

Module: ‎8139too

Classe de matériel: ‎NETWORK_ETHERNEt

I read something about modules, it seems that that is what launches the drivers at boot.

My feeling is that something goes wrong when the system tries to launch the module of eth0 at boot because.....I do not know

And I do not know how to analyze farther !









;) ;)

/bin/bash 11-19-2003 07:35 PM

In /etc/modules.conf file you need a line like this:
alias eth0 8139too

montfer 12-29-2003 03:19 AM

thank you /bin/bash. The line in the modules.conf did solve the problem. My Linux starts with the eth0 well connected again.


All times are GMT -5. The time now is 06:47 AM.