LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 08-19-2003, 09:53 AM   #1
seth
LQ Newbie
 
Registered: Oct 2002
Posts: 13

Rep: Reputation: 0
how do i find my gateway address on eth0?


just as the topic says how do I find out what my cable internet company has set my gateway to
thanks a bunch
 
Old 08-19-2003, 10:32 AM   #2
cnjohnson
Member
 
Registered: Nov 2002
Location: Nashville
Distribution: FreeBSD, Linux, OS-X
Posts: 544

Rep: Reputation: 30
As root do this:

netstat -nr

You should see the gateway address.
 
Old 08-19-2003, 10:45 AM   #3
seth
LQ Newbie
 
Registered: Oct 2002
Posts: 13

Original Poster
Rep: Reputation: 0
thank you.
 
Old 08-19-2003, 12:30 PM   #4
seth
LQ Newbie
 
Registered: Oct 2002
Posts: 13

Original Poster
Rep: Reputation: 0
i get this when i do that
Destination Gateway Genmask Flags MSS Window irtt Iface
192.168.10.0 0.0.0.0 255.255.255.0 U 0 0 0 eth1
24.100.238.0 0.0.0.0 255.255.254.0 U 0 0 0 eth0
169.254.0.0 0.0.0.0 255.255.0.0 U 0 0 0 eth1
127.0.0.0 0.0.0.0 255.0.0.0 U 0 0 0 lo
0.0.0.0 24.100.238.1 0.0.0.0 UG 0 0 0 eth0
now my problem is I assumed 24.100.238.1 is the gateway that my cable is using but for some reason it says it can not route to it so I could not run this command.
route add -net 192.168.10.0 netmask 255.255.255.0 gw XXX.XXX.XXX.XXX dev eth1
the xxx being the gateway address.
anyone have any idea?
 
Old 08-19-2003, 12:31 PM   #5
seth
LQ Newbie
 
Registered: Oct 2002
Posts: 13

Original Poster
Rep: Reputation: 0
that table did not turn out well but I have to go to lunch if anyone can figure it out cool it not when I come back I will type out the table properly.
thanks.
 
Old 08-19-2003, 12:41 PM   #6
raylpc
Member
 
Registered: Jun 2003
Location: Canada
Distribution: Red Hat 9
Posts: 94

Rep: Reputation: 15
24.100.238.1
 
Old 08-19-2003, 05:18 PM   #7
seth
LQ Newbie
 
Registered: Oct 2002
Posts: 13

Original Poster
Rep: Reputation: 0
kinda what I though but it didn't go.
 
Old 10-09-2008, 04:50 AM   #8
rlwilen
LQ Newbie
 
Registered: Oct 2008
Posts: 1

Rep: Reputation: 0
Thumbs up

Quote:
Originally Posted by cnjohnson View Post
As root do this:

netstat -nr

You should see the gateway address.
thank you that help a lot thank you
 
Old 09-30-2009, 12:27 PM   #9
++nick++
Member
 
Registered: Dec 2008
Location: Bellevue,WA
Distribution: RHEL 5 , Fedora ,Sabayon,Solaris,Vmware,AWS
Posts: 107

Rep: Reputation: 18
In addition to the above , you could also try,

Code:
route -nee

123.236.216.0   0.0.0.0         255.255.248.0   U     1      0        0 eth0     0     0      0
0.0.0.0         123.236.216.1   0.0.0.0         UG    0      0        0 eth0     0     0  


ip route show

default via 123.236.216.1 dev eth0  proto static
 
Old 03-20-2010, 04:30 PM   #10
dfowensby
Member
 
Registered: Dec 2003
Location: OceanView Virginia, gem of the Southern Shore
Distribution: Oz Unity Diamond IIB [x64 xfce]
Posts: 194
Blog Entries: 1

Rep: Reputation: 30
that ip looks suspiciously like cox cable's windows/mac autoconfig download app address.....
 
Old 03-21-2010, 04:42 AM   #11
devwatchdog
Member
 
Registered: Jan 2010
Posts: 198

Rep: Reputation: 44
I just realized after glancing back at this thread, that our own dear dfowensby has decided to take it upon him/herself to make off-topic replies to old threads. Nice.

I see a gateway address already assigned to a system that appears to have a functional routing table.

Why are you trying to assign another gateway? Unless you're doing advanced routing, there should be no need to do so. The way you have your system configured now, when network activity that cannot be satisfied with the various routes you have assigned, that request is then forwarded to the default gateway.

It appears your system isn't working properly. What is the problem?

If I were to guess, I would think that IP forwarding isn't configured. Check out this site and see if you have it enabled:

http://www.ducea.com/2006/08/01/how-...ding-in-linux/

If that is configured correctly, let us know what the issue is.

Last edited by devwatchdog; 03-21-2010 at 04:48 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How do I set the ip address for eth0, eth1 and the default gateway? abefroman Suse/Novell 5 05-19-2005 05:15 AM
Changed modems: eth0 cant find IP address suggardaddy4242 Linux - Newbie 2 09-09-2004 12:45 PM
What is Gateway address and what is Network address? abefroman Linux - Networking 1 03-17-2004 09:25 PM
finding gateway address on eth0 MHouse Linux - Newbie 9 03-05-2004 07:35 AM
Should i use the eth0 ip address of my internet ip address when applying iptables ForumKid Linux - Security 2 01-03-2002 09:54 AM


All times are GMT -5. The time now is 06:08 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration