LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 08-25-2004, 04:48 PM   #1
The Pom
LQ Newbie
 
Registered: Aug 2004
Distribution: Red Hat 9.0
Posts: 5

Rep: Reputation: 0
Question How do I establish internet networking?


I am a newbie. Today I installed Red Hat 9.0 as a dual boot with XP onto my laptop. I have a single HDD. The install was ok.

My problem is that I cannot connect to the internet through Red Hat. I can with XP. My set up is such that I have an ethernet cable running to a ADSL modem. There is a desktop box on the same network and I can see that ok. I have chosen DHCP but an ip is not assigned. I have tried assigning the same ip I have have for my XP log-in and this too fails.

I would much appreciate assistance in the form of simplified solutions (rather than Linux geek speak), as I am a complete newbie to Linux. I don't [for instance], know how to get the command line for Linux. That's for later - right now I just want to browse the WWW and would appreciate any advice.

BTW, I really have searched the net and various forums for this specific problem but I can't find an exact solution for me. There are lots with advice in 'Linux-speak', but I'm lost with that [at this present time].

Thank you
 
Old 08-25-2004, 05:30 PM   #2
m0rt3r
Member
 
Registered: Mar 2004
Distribution: slackware 10
Posts: 75

Rep: Reputation: 15
I'm not so sure but it seem that we both connect to the Internet the same way, i have an Ethernet card that connects to a dsl modem.
In order to get my connection working i did the following:
1. do
Code:
netconfig
for the first question you can write any name you'd like to give to your computer, for the second question just say localdomain. for the third question choose DHCP, after that just say OK to the following questions.
2. do
Code:
ifconfig -a
if you see something like this then everything is going well:
Quote:
eth0 Link encap:Ethernet HWaddr 00:80:BA:4E:A6:96
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
as long as you see your HWaddr line you'll be ok
3.After that do
Code:
adsl-setup
4.answer the questions according to you situation.
For the first question just enter the user name you use to connect to the internet in Windows (i.e crazy@sbcglobal.net)
4b. for the second question answer either eth0 if that is the ethernet card you use to connect to the internet with. In my case since i only have one ethernet card i use eth0.
4c. for the third question just hit enter
4d. for the fifth question answer server in lower case
4f. it now will ask for the password you use to connect to the internet.
4g. if you got a firewall already say 0 to the following, if not say 1
4h. no just say yes or y
In order to start your connection do
Code:
adsl-start
to stop a connection do
Code:
adsl-stop
start your connection (i.e adsl-start) and after it says connected do
Code:
ifconfig -a
to check if you got an ip, if you see something like this you are in the right track:

Quote:
ppp0 Link encap:Point-to-Point Protocol
inet addr:225.98.456.26 P-t-P:95.959.959.595 Mask:250.250.250.250
UP POINTOPOINT RUNNING NOARP MULTICAST MTU:1492 Metric:1
The numbers you might see will not be the same as mine.
Now try to ping a site to see if it's working
Code:
ping -c 4 yahoo.com
after you ping yahoo if you see something like this then you can now browse the net:

Quote:
PING yahoo.com (216.109.124.72) 56(84) bytes of data.
64 bytes from p1.rc.dcn.yahoo.com (216.109.124.72): icmp_seq=1 ttl=48 time=70.5 ms
64 bytes from p1.rc.dcn.yahoo.com (216.109.124.72): icmp_seq=2 ttl=48 time=72.8 ms
64 bytes from p1.rc.dcn.yahoo.com (216.109.124.72): icmp_seq=3 ttl=47 time=71.8 ms
64 bytes from p1.rc.dcn.yahoo.com (216.109.124.72): icmp_seq=4 ttl=47 time=71.5 ms

--- yahoo.com ping statistics ---
4 packets transmitted, 4 received, 0% packet loss, time 3026ms
rtt min/avg/max/mdev = 70.573/71.710/72.856/0.855 ms
 
Old 08-25-2004, 05:36 PM   #3
m0rt3r
Member
 
Registered: Mar 2004
Distribution: slackware 10
Posts: 75

Rep: Reputation: 15
oh before i forgot you have to do all of that as root.
open a terminal and u
Code:
 su root
then enter the root password and do all the steps stated above.
After that if for some reason you cannot connect to the internet just reboot, then log into your normal user account and start the internet, or
Code:
 su root
enter password and do
Code:
adsl-start
.

If you have kde install to get a terminal click on the square figure with a > sign, or press F4 that will give you a terminal, then do all the steps above. I really hope this helps, i don't use red-hat that is basically why i'm not so sure.
 
Old 08-26-2004, 09:53 AM   #4
The Pom
LQ Newbie
 
Registered: Aug 2004
Distribution: Red Hat 9.0
Posts: 5

Original Poster
Rep: Reputation: 0
Thumbs down

Mort3r - thanx for the reply - however, I'm still stuck.

I don't understand your reply because you say "for the first question, for the second question, for the third question ..." etc and I never listed any questions?

Anyway, it took me ages to find the command line [I told you I was new to this], before I realised the command line was the 'terminal'. Once I'd figured that I did a <su root> as you suggested. That and the password work ok but NO OTHER COMMAND WILL WORK ?

So, if I type anything else you suggest all I get back is command not found - For example :

bash: adsl : command not found

I guess before I can do anything else I should be able to see that modem? This is driving me mad as it takes up all my evening time (trying and retrying and retrying and.....), and all I want to do is surf the net.

Would appreciate any more help please
 
Old 08-26-2004, 11:01 AM   #5
michaelk
Moderator
 
Registered: Aug 2002
Posts: 11,856

Rep: Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738
Have you tried configuring via the GUI wizard?
http://www.redhat.com/docs/manuals/l...de/ch-ppp.html
 
Old 08-26-2004, 01:08 PM   #6
The Pom
LQ Newbie
 
Registered: Aug 2004
Distribution: Red Hat 9.0
Posts: 5

Original Poster
Rep: Reputation: 0
Exclamation Networking

Thanks for the post - yes I had tried the GUI. Made no diff and when I get to the Red Hat activation screen I hit a blank as it cannot find redhat.com See below as to why this may be.

Anyway, I have made some small progress.

Previously I had been logging in as a user [my user name is 'fred']. No joy, as described earlier.

Today I logged in as root and was able to do everything suggested by m0rt3r. Thank you........

HOWEVER - I was not able to ping anything other than my adsl router and my laptop. I seem to get stopped at the router.

So now I understand why you gave me the answers to the various questions m0rt3r - thanks :-)

But, I don't understand two other things :
[1] why I don't seem to have admin rights (root rights as Linux) as user Fred.
[2] why I can't get through the router.

Again - help would be great thank you.
 
Old 08-26-2004, 04:47 PM   #7
The Pom
LQ Newbie
 
Registered: Aug 2004
Distribution: Red Hat 9.0
Posts: 5

Original Poster
Rep: Reputation: 0
Thumbs up Networking

Stop the press - I've cracked it.

I configured the router settings and was able to see the www.

I logged in as root and gave admin rights to my user log-in [Fred].

And all was good.

However, I would still like to be able to modify the boot screen to change DOS to Windows XP. I have found the grub.config file [which is the one I think needs changing], but once open I can't edit it. Can anyone help?

Sorry I know this is now off topic / thread.

Cheers
 
Old 08-27-2004, 04:17 PM   #8
Louie55
Member
 
Registered: Oct 2003
Location: Nebraska
Distribution: SuSE 9.0, Redhat 9.0
Posts: 41

Rep: Reputation: 15
To edit system files like grub.conf, you have to log in as root. Get to the command prompt and type:

Code:
cd /boot/grub
vi grub.conf
Welcome to the UNIX/Linux vi editor! It is the most used command line text editor.

OK, now press the letter "i" on your keyboard. This will put you into insert mode. Now use your arrow keys to put the cursor in front of the word DOS and use the delete key to get rid of it. Now just type Windows XP where DOS was. Now, press the ESC key. Then type:

Code:
:wq
Don't forget the colon in front of wq. The wq stands for write/quit. This saves the changes and exits the vi editor. Now when you restart the computer it should say Windows XP instead of DOS.

Louie
 
Old 08-27-2004, 05:10 PM   #9
The Pom
LQ Newbie
 
Registered: Aug 2004
Distribution: Red Hat 9.0
Posts: 5

Original Poster
Rep: Reputation: 0
Thumbs up Edit grub.conf

Louise55 - You're the man.

Worked exactly as you described - thank you

The Pom
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
how to establish dial up internet connection through linux? ss_vikas Linux - Newbie 23 07-19-2008 02:02 AM
cannot establish adsl internet connection pat@studio Linux - Networking 2 05-11-2005 02:08 PM
425 failed to establish connection for ftp Networking linuxhippy Slackware 4 05-02-2005 03:45 AM
cannot establish a connection to my internet Jjurk Linux - Newbie 7 03-05-2004 04:49 AM
Linux won't establish internet connections blacbastard Linux - Networking 4 07-03-2003 07:05 AM


All times are GMT -5. The time now is 02:10 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration