LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 09-13-2005, 05:03 PM   #1
mokie
LQ Newbie
 
Registered: Sep 2005
Location: USA
Distribution: suse 9.1 professional
Posts: 4

Rep: Reputation: 0
how do I configure suse 9.1 for DSL?


I'm a complete Linux newbie, and am not that comfortable around computers in general, so any help would be greatly appreciated.

I have a Westell USB/Ethernet modem for my DSL, I'm using the ethernet cable, but USB would be okay too.

My ISP uses a dynamic PPoE (whatever that means!) and that's about all the information I have.

I'm not sure how to use YaST for setting up the DSL connection. I've clicked around some, but just don't know what I'm doing at all.

Thanks for the help!
 
Old 09-14-2005, 09:53 AM   #2
rshaw
Senior Member
 
Registered: Apr 2001
Location: Perry, Iowa
Distribution: Mepis , Debian
Posts: 2,694

Rep: Reputation: 45
use the ethernet connection to the modem. you won't need to do anything under the dsl settings in yast. yast should set the netcard for dhcp and that's all there is to it.

Last edited by rshaw; 09-14-2005 at 09:57 AM.
 
Old 09-15-2005, 02:22 PM   #3
mokie
LQ Newbie
 
Registered: Sep 2005
Location: USA
Distribution: suse 9.1 professional
Posts: 4

Original Poster
Rep: Reputation: 0
But YaST doesn't just set up the netcard for dhcp. I think that YaST recognizes the modem as a dial up? I don't know how to fix this.
 
Old 09-16-2005, 01:56 PM   #4
stingray3
LQ Newbie
 
Registered: Sep 2005
Location: Finland, EU
Posts: 3

Rep: Reputation: 0
Same problem in Suse 9.3

I have same problem in Suse 9.3. Yast recognizes my Ethernet card, but it want to create dial-up connection with login names etc. I have cable ADSL connection and there are no login names, it just work like local network area.

I been tired to this kind problems, linux works well in old machines, but not in new ones. I have to use still Windows in my 'main computer'...

Do you have any proposal witch linux version works 100% in Intel Desktop Board D915GAG ?
 
Old 09-19-2005, 07:22 PM   #5
mokie
LQ Newbie
 
Registered: Sep 2005
Location: USA
Distribution: suse 9.1 professional
Posts: 4

Original Poster
Rep: Reputation: 0
I got the dsl working now....thanks to all who tried to help me.

The netcard was setup fine for the ethernet connection. But I needed to have a username and password from my ISP to be able to access the internet. It was a hassle trying to get that though, since I couldn't get a username and password over the phone. I had to go to a friend's house to use his internet in order to set things up. Oh, and it had to be internet explorer to use the online registration! No mozilla or anything like that.
 
Old 09-21-2005, 03:06 PM   #6
stingray3
LQ Newbie
 
Registered: Sep 2005
Location: Finland, EU
Posts: 3

Rep: Reputation: 0
Nice to hear that mokie's problem was solved.

Can somebody help me, because my problem isn't to get login names, I just don't have any login names in my ADSL Internet connection and there are no such at all.
--------------------------------
So ones again:

Yast recognizes my Ethernet card, but it want to create dial-up connection with login names etc. I have cable ADSL connection and there are no login names, it just work like local network area. I have a integrated Ethernet in my board Intel D915GAG.
--------------------------------

Please, any ideas?
 
Old 09-21-2005, 03:47 PM   #7
mokie
LQ Newbie
 
Registered: Sep 2005
Location: USA
Distribution: suse 9.1 professional
Posts: 4

Original Poster
Rep: Reputation: 0
stingray3-

I don't know how it works in the EU, but I always thought that ADSL was just a type of DSL, the kind that's called "asymmetrical" because the download is faster than the upload. You said that you have cable, in which case I think the modem might be your problem not the ethernet connection.

If it is a kind of DSL, you might not need login/password. When I had DSL with my old ISP I didn't need the login/password, just the ethernet connection. But with my new ISP I did need the login/password. That's why I got so frustrated. I thought I was doing everything right, but wasn't!

Sorry I'm not much help.

Hope it works out for you!
 
Old 09-21-2005, 03:58 PM   #8
rshaw
Senior Member
 
Registered: Apr 2001
Location: Perry, Iowa
Distribution: Mepis , Debian
Posts: 2,694

Rep: Reputation: 45
your isp has to identify you somehow, or anyone could hook up and use the service. the user/password is probably stored internally on the modem.
 
Old 09-22-2005, 02:58 PM   #9
stingray3
LQ Newbie
 
Registered: Sep 2005
Location: Finland, EU
Posts: 3

Rep: Reputation: 0
Quote:
Originally posted by rshaw
your isp has to identify you somehow, or anyone could hook up and use the service. the user/password is probably stored internally on the modem.
First, thank you both for your answers.

Sorry, but there are no login names in to modem or etc. You can use any ADSL modem that you want, it not depend which ISP you have. I'm not sure how ADSL connection works in here, but I have own IP address on my connection and it wont change. Windows detect my connection as a local network area. My modem model is ZyXEL Prestige 645 and it use TCP/IP protocol: RFC1483 Bridged Ethernet over ATM.
 
Old 09-22-2005, 03:16 PM   #10
rshaw
Senior Member
 
Registered: Apr 2001
Location: Perry, Iowa
Distribution: Mepis , Debian
Posts: 2,694

Rep: Reputation: 45
ah, static ip. thats changes everything
 
Old 01-20-2006, 09:14 AM   #11
lnebrown
Member
 
Registered: Sep 2004
Location: Seattle
Distribution: Ubuntu
Posts: 51

Rep: Reputation: 15
I just got my dsl working with my ISP Verizon.

I was fortunate enough to get a tech support guy that was willing to work with me even though they are told not to support Linux. Here is a summary of my struggle and solution over the last 24 hours: (by the way, I have a WinXP laptop and a Suse 9.1 Pers. desktop)

1. Tried to get the laptop working with dsl, but the "install software" from Verizon kept blowing up during troubleshooting.

2. Called Verizon install. support, basically found that I could not even ping the dsl modem. Tech. said that some software is probably using the needed port and he said he cannot help, directed me toward my pc mfr.

3. Gave up on the laptop for now, hooked the dsl hardware up to linux, started playing with settings in Yast, got confused that Kinternet seemed to require that I provide a username/password (which i gave a bogus username) since the tech told me that I didn't need that for my xp laptop. I could "dial-in" with Kinternet, but when I opened browser, I got a verizon web page saying that they couldn't verify my username/pwd.

4. Called tech support again, got a helpful guy who said that he could give me a username/password. He said that in the typical installation, every account has an initial username/pwd that is changed as soon as you set up your account at www.verizoncentral.com or .net or whatever. Then that new email account name and password become the username/password you can use to connect. He said I was using a "dialer", which is the 2nd best way to connect. Generally with a windoze pc, the modem lets you on because it has its own username and pwd, so you don't need a "dialer" to connect. It seems that Kinternet is not designed to work like that, so it was fortunate that tech support would give me my initial username/password.

5. then i went back to my laptop and set up a "dialer", using the "new connection" wizard, which lets you use a username/pwd, and all was peachy after that.

My question is, is there anyway to use linux with the dsl so that you don't need to use the "dialer" with a username/pwd?

CLB
 
Old 01-22-2006, 03:41 AM   #12
beetle_boy66
LQ Newbie
 
Registered: Jan 2006
Posts: 10

Rep: Reputation: 0
Quote:
Originally Posted by lnebrown
I just got my dsl working with my ISP Verizon.

My question is, is there anyway to use linux with the dsl so that you don't need to use the "dialer" with a username/pwd?

CLB
I am a Verizon Tech Support agent. Verizon has two types of DSL connections they offer to their customers, PPPoE (Point to Point Protocol Over Ethernet) and DHCP (Dynamic Host Configuration Protocol).

It all depends on what equipment Verizon has at the CO. If you are a PPPoE customer, you need to authenticate (use a username and password) to connect. If you are a DHCP customer, Verizon's servers bind to your MAC address, and don't require authentication. (no username/password)

If you are a PPPoE customer, and you have a Westell WireSpeed or Fujitsu modem, you have to use a "dialer" to provide the username and password. (they are "dumb" modems that don't have any ability to authenticate on their own)
Connecting one of these "dumb" modems to a router is easy; since the modems can't authenticate on their own, all you have to do is set the router up with the username and password, and IT provides the username/password. Using a router to authenticate eliminates the need for the software "dialer".


If you are a PPPoE customer and you have a Westell 2200, 6100, or 327w modem, or a ActionTec modem, those modems can be set up to provide the username and password for you, eliminating the need for a software based "dialer" to do it.
Here's where adding a router gets more difficult. When you put a router behind a modem that authenticates, the responsibility for authentication now falls on the router. You have to "bridge" the modem, basically telling it NOT to authenticate, but to pass the responsibility on down to the router. Then you have to set the router up with the username and password, and IT provides the username/password. (It authenicates instead of the modem)


So:Iif you are a PPPoE customer:
If you have a "dumb" modem like the WireSpeed or Fujitsu and you don't have a router, no, there is no way to eliminate the "dialer".

If you DO have a modem that authenticates, like the 2200,6100,327w, or ActionTec, and you are using a "dialer", the modem has been "bridged". If you "unbridge" the modem, you can set the modem up to provide the username and password, and eliminate your "dialer".

Please Note:
None of this applies to DHCP customers. DHCP doesn't require a username and password!
I
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Configure DSL and Linux network Darrell22 Linux - Networking 1 06-19-2005 10:41 PM
dsl on demand in suse 8.0, and installing dsl paul62 Suse/Novell 2 01-04-2005 09:32 PM
Need To configure my DSL Modem Chopsticks Linux - Networking 3 08-02-2004 12:28 AM
Cannot Configure DSL on Suse 9.0 nj dave Linux - Software 2 11-19-2003 07:33 PM
How do I configure DSL with Mandrake 7.2? rgt31 Linux - Newbie 10 03-22-2001 07:59 PM


All times are GMT -5. The time now is 11:23 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration