LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (http://www.linuxquestions.org/questions/linux-networking-3/)
-   -   Hostnames don't always get recognized (using router) (http://www.linuxquestions.org/questions/linux-networking-3/hostnames-don%27t-always-get-recognized-using-router-448917/)

profoX 05-26-2006 08:10 PM

Hostnames don't always get recognized (using router)
 
I've got a very weird situation.
At my router configuration panel I see 3 hostnames of my 3 pc's.
But sometimes, when I try to make a connection between 2 of the pc's using its hostname, it doesn't always work.

The 3 computers hostnames are:
- pacman (archlinux pc)
- kreafleur (my mom's wireless winxp laptop)
- pcpcpc (my brother's winxp pc)

They get recognized by the router too
(well, most of the time, sometimes instead of "pacman" it will say "unknown", I also don't know why that is happening)

For example:
I use PuTTy on "kreafleur" (wireless winxp laptop) to connect through ssh to "pacman" (archlinux pc) but sometimes it says:

"Host does not exist"

Connecting with the local ip address, however, DOES work.
Does anyone know what could cause this problem?

Personally, I believe the router is just junk...
(US Robotics 8054)

Do you have any suggestions for me to try ?

Thanks!

acid_kewpie 05-28-2006 05:35 AM

just sounds like bad dns records, which you've mentioned nothing about. how is dns working on your network at present?


All times are GMT -5. The time now is 04:07 PM.