LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 09-18-2005, 12:00 PM   #1
bwoodruff
LQ Newbie
 
Registered: Aug 2005
Distribution: Fedora C3, RH9, Ubuntu
Posts: 7

Rep: Reputation: 0
Help with bonding


Hi,

I have setup bonding on two interfaces, but it appears that only one of them is being used by the bond?

bond0 Link encap:Ethernet HWaddr 00:0E:A6:B2:CBA
inet addr:192.168.42.5 Bcast:192.168.42.255 Mask:255.255.255.0
UP BROADCAST RUNNING MASTER MULTICAST MTU:1500 Metric:1
RX packets:731429 errors:0 dropped:0 overruns:0 frame:0
TX packets:434426 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:904766573 (862.8 MiB) TX bytes:110703535 (105.5 MiB)

eth0 Link encap:Ethernet HWaddr 00:0E:A6:B2:CBA
inet addr:192.168.42.5 Bcast:192.168.42.255 Mask:255.255.255.0
UP BROADCAST RUNNING SLAVE MULTICAST MTU:1500 Metric:1
RX packets:731433 errors:0 dropped:0 overruns:0 frame:0
TX packets:434433 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:904766813 (862.8 MiB) TX bytes:110704729 (105.5 MiB)
Interrupt:12 Base address:0xe000

eth1 Link encap:Ethernet HWaddr 00:0E:A6:B2:CBA
inet addr:192.168.42.5 Bcast:192.168.42.255 Mask:255.255.255.0
UP BROADCAST SLAVE MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
Interrupt:5 Base address:0xc000


Note how it doesn't say "RUNNING" under eth1?
And no traffic has gone through it.

What have I done wrong?

Config files:
/etc/modules.conf
alias bond0 bonding
options bond0 miimon=100 mode=balance-rr

/etc/sysconfig/network-scripts/ifcfg-bond0
DEVICE=bond0
BOOTPROTO=none
ONBOOT=yes
IPADDR=192.168.42.5
NETMASK=255.255.255.0
NETWORK=192.168.42.0
BROADCAST=192.168.42.255
GATEWAY=192.168.42.254

Then the two /etc/sysconfig/network-scripts/ifcfg-ethX files look like this
DEVICE=ethX
BOOTPROTO=none
ONBOOT=yes
TYPE=Ethernet
MASTER=bond0
SLAVE=yes

where X is 0 or 1, respectively.



EDIT: Forgot to mention:

[root@zaphod ~]# cat /proc/net/bonding/bond0
Ethernet Channel Bonding Driver: v2.6.1 (October 29, 2004)

Bonding Mode: load balancing (round-robin)
MII Status: up
MII Polling Interval (ms): 0
Up Delay (ms): 0
Down Delay (ms): 0

Slave Interface: eth0
MII Status: up
Link Failure Count: 0
Permanent HW addr: 00:0e:a6:b2:cb:da

Slave Interface: eth1
MII Status: up
Link Failure Count: 0
Permanent HW addr: 00:50:fc:21:a2:20

Last edited by bwoodruff; 09-18-2005 at 12:03 PM.
 
Old 09-19-2005, 06:07 AM   #2
vimal
Red Hat India
 
Registered: Nov 2004
Location: Kerala/Pune,india
Distribution: RedHat, Fedora
Posts: 260

Rep: Reputation: 34
Hi bwoodruff,
The main problem is that you won't have the kernel recompiled with "bonding support". Moreover you can refer the text documentation at this URL, since nothing seems wrong in your configuration. http://www.linuxfromscratch.org/hint...et-bonding.txt
feel free to contact if problems persists.

vimal.....
 
Old 09-19-2005, 06:32 PM   #3
bwoodruff
LQ Newbie
 
Registered: Aug 2005
Distribution: Fedora C3, RH9, Ubuntu
Posts: 7

Original Poster
Rep: Reputation: 0
I have Fedora C3, I was under the impression I wouldn't have to recompile?

In the true hacker spirit, I'd love to do this eventually anyway, but due to a lack of knowledge and a lack of time to gain that knowledge, I really can't do it right now.
 
Old 09-20-2005, 04:07 AM   #4
vimal
Red Hat India
 
Registered: Nov 2004
Location: Kerala/Pune,india
Distribution: RedHat, Fedora
Posts: 260

Rep: Reputation: 34
Hi bwoodruff,
If you want to do it right now( bonding of interfaces), you have to recompile your kernel with bonding support. kernel recomilation may be a bit trouble if you lack the knowledge, but excellent documentations are available in the net.
vimal....
 
Old 11-09-2006, 02:14 PM   #5
sugar2
Member
 
Registered: Feb 2006
Distribution: Debian 40r0
Posts: 103

Rep: Reputation: 15
Usually kernel default configurations has bonding as a loadable module, so we can think you made a "insmod bonding.o" right? if you did it and things still doesnt work... what will do its recompile the kernel with bonding enabled instad of configured as a loadable module...

please let us know what you did and what results you get...

Aldo
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
bonding aylov Linux - Networking 7 09-03-2007 11:24 PM
Help with channel bonding jaraju Linux - Networking 11 05-05-2005 07:38 PM
bonding ADSL jober Linux - Networking 3 12-09-2004 02:26 PM
bonding NIC's mrose1120 Linux - Networking 5 10-04-2004 12:52 PM
Ethernet bonding trycoon Linux - Networking 7 07-23-2002 10:05 AM


All times are GMT -5. The time now is 11:27 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration