LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (http://www.linuxquestions.org/questions/linux-networking-3/)
-   -   Help with bonding (http://www.linuxquestions.org/questions/linux-networking-3/help-with-bonding-364542/)

bwoodruff 09-18-2005 12:00 PM

Help with bonding
 
Hi,

I have setup bonding on two interfaces, but it appears that only one of them is being used by the bond?

bond0 Link encap:Ethernet HWaddr 00:0E:A6:B2:CB:DA
inet addr:192.168.42.5 Bcast:192.168.42.255 Mask:255.255.255.0
UP BROADCAST RUNNING MASTER MULTICAST MTU:1500 Metric:1
RX packets:731429 errors:0 dropped:0 overruns:0 frame:0
TX packets:434426 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:904766573 (862.8 MiB) TX bytes:110703535 (105.5 MiB)

eth0 Link encap:Ethernet HWaddr 00:0E:A6:B2:CB:DA
inet addr:192.168.42.5 Bcast:192.168.42.255 Mask:255.255.255.0
UP BROADCAST RUNNING SLAVE MULTICAST MTU:1500 Metric:1
RX packets:731433 errors:0 dropped:0 overruns:0 frame:0
TX packets:434433 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:904766813 (862.8 MiB) TX bytes:110704729 (105.5 MiB)
Interrupt:12 Base address:0xe000

eth1 Link encap:Ethernet HWaddr 00:0E:A6:B2:CB:DA
inet addr:192.168.42.5 Bcast:192.168.42.255 Mask:255.255.255.0
UP BROADCAST SLAVE MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
Interrupt:5 Base address:0xc000


Note how it doesn't say "RUNNING" under eth1?
And no traffic has gone through it.

What have I done wrong?

Config files:
/etc/modules.conf
alias bond0 bonding
options bond0 miimon=100 mode=balance-rr

/etc/sysconfig/network-scripts/ifcfg-bond0
DEVICE=bond0
BOOTPROTO=none
ONBOOT=yes
IPADDR=192.168.42.5
NETMASK=255.255.255.0
NETWORK=192.168.42.0
BROADCAST=192.168.42.255
GATEWAY=192.168.42.254

Then the two /etc/sysconfig/network-scripts/ifcfg-ethX files look like this
DEVICE=ethX
BOOTPROTO=none
ONBOOT=yes
TYPE=Ethernet
MASTER=bond0
SLAVE=yes

where X is 0 or 1, respectively.



EDIT: Forgot to mention:

[root@zaphod ~]# cat /proc/net/bonding/bond0
Ethernet Channel Bonding Driver: v2.6.1 (October 29, 2004)

Bonding Mode: load balancing (round-robin)
MII Status: up
MII Polling Interval (ms): 0
Up Delay (ms): 0
Down Delay (ms): 0

Slave Interface: eth0
MII Status: up
Link Failure Count: 0
Permanent HW addr: 00:0e:a6:b2:cb:da

Slave Interface: eth1
MII Status: up
Link Failure Count: 0
Permanent HW addr: 00:50:fc:21:a2:20

vimal 09-19-2005 06:07 AM

Hi bwoodruff,
The main problem is that you won't have the kernel recompiled with "bonding support". Moreover you can refer the text documentation at this URL, since nothing seems wrong in your configuration. http://www.linuxfromscratch.org/hint...et-bonding.txt
feel free to contact if problems persists.

vimal.....

bwoodruff 09-19-2005 06:32 PM

I have Fedora C3, I was under the impression I wouldn't have to recompile?

In the true hacker spirit, I'd love to do this eventually anyway, but due to a lack of knowledge and a lack of time to gain that knowledge, I really can't do it right now.

vimal 09-20-2005 04:07 AM

Hi bwoodruff,
If you want to do it right now( bonding of interfaces), you have to recompile your kernel with bonding support. kernel recomilation may be a bit trouble if you lack the knowledge, but excellent documentations are available in the net.
vimal....

sugar2 11-09-2006 02:14 PM

Usually kernel default configurations has bonding as a loadable module, so we can think you made a "insmod bonding.o" right? if you did it and things still doesnt work... what will do its recompile the kernel with bonding enabled instad of configured as a loadable module...

please let us know what you did and what results you get...

Aldo


All times are GMT -5. The time now is 09:30 PM.