LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 11-27-2003, 12:40 PM   #1
Temujin_12
Member
 
Registered: Sep 2003
Location: Washington
Distribution: Kubuntu Dapper
Posts: 99

Rep: Reputation: 15
Unhappy Help! Linux RedHat 9 won't get on Windows network


Ok, after reading for hours about how to fix my problem I've resorted to starting a new thread. Here's my situation.

Network:
2 PCs connected using ethernet
Both are connected to a SMC EtherEZ hub

==Machine 1==
OS: Windows ME
Comp name: irene
Workgroup: MSHOME
IP address: 169.254.0.1
Subnet Mask: 255.255.255.0
Wins config: Disabled
Gateway: none
DNS: Disabled
NetBios: none
Primary Network Logon: Client for MS Networks

==Machine 2==
OS #1: Windows 98
Comp name: CALEB
Workgroup: MSHOME
IP address: obtain Ip address automatically
Subnet Mask: " "
Wins config: Use DHCP for WINS Resolution
Gateway: none
DNS: Disabled
NetBios: none
Primary Network Logon: Client for MS Networks
OS #2: Linux RedHat 9.0

Ok, with these settings Machine 1 and Machine 2 (with OS #1) can communicate just fine. However when I tell Linux to 'Automatically obtain IP address settings with dhcp' it just hangs for a long time and says 'Determining IP information for eth0... failed.' ifconfig shows both eth0 and lo. The DNS settings have 'Hostname: localhost' and 'DNS Search Path: localhost' set and the others are blank. There are also no items in the Hosts tab.

BTW, after Linux boots up the hub light on the slot it is connected to doesn't light up. Does someone know what I can do to get them to communicate?

Last edited by Temujin_12; 11-27-2003 at 12:42 PM.
 
Old 11-27-2003, 12:52 PM   #2
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 64
What kind of ethernet card do you have.

Check the output of "dmesg" to see if your card is detected during boot.
 
Old 11-27-2003, 01:27 PM   #3
Temujin_12
Member
 
Registered: Sep 2003
Location: Washington
Distribution: Kubuntu Dapper
Posts: 99

Original Poster
Rep: Reputation: 15
after running dmesg I found these lines that seem to be related to the network card:
PCI: Found IRQ 10 for device 00:07.0
PCI: Sharing IRQ 10 with 00:0e.0
ohci1394_0: OHCI-1394 1.1 (PCI): IRQ=[10] MMIO=[dd000000-dd0007ff] Max Packet=[2048]
ieee1394: SelfID completion called outside of bus reset!
ieee1394: Host added: Node[00:1023] GUID[00e01800000485b6] [Linux OHCI-1394]
ip_tables: (C) 2000-2002 Netfilter core team
Linux Tulip driver version 0.9.15-pre12 (Aug 9, 2002)
PCI: Found IRQ 10 for device 00:0e.0
PCI: Sharing IRQ 10 with 00:07.0
tulip0: 21041 Media table, default media 0800 (Autosense).
tulip0: 21041 media #0, 10baseT.
tulip0: 21041 media #4, 10baseT-FDX.
tulip0: 21041 media #1, 10base2.
tulip0: 21041 media #2, AUI.
divert: allocating divert_blk for eth0
eth0: Digital CD21041 Tulip rev 17 at 0xd08cd000, 21041 mode, 00:00:C0:F7:C6:E3, IRQ 10
 
Old 11-27-2003, 01:34 PM   #4
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 64
well it seems to detect the card. What about the output of:
mii-tool -v
 
Old 11-27-2003, 01:44 PM   #5
Temujin_12
Member
 
Registered: Sep 2003
Location: Washington
Distribution: Kubuntu Dapper
Posts: 99

Original Poster
Rep: Reputation: 15
eth0: autonegotiation failed, link ok
product info: vendor 00:00:00, model 0 rev 0
basic mode: autonegotiation enabled
basic status: autonegotiation complete, link ok
capabilities: 10baseT-FD 10baseT-HD
advertisiong: 10baseT-FD 10baseT-HD

Last edited by Temujin_12; 11-27-2003 at 01:47 PM.
 
Old 11-27-2003, 01:56 PM   #6
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 64
Considering it says that the link is OK I am surprised that the link light on the hub isn't lit. Is that still the case? Is there a link light on the network card?
 
Old 11-27-2003, 02:01 PM   #7
Temujin_12
Member
 
Registered: Sep 2003
Location: Washington
Distribution: Kubuntu Dapper
Posts: 99

Original Poster
Rep: Reputation: 15
The light on the card is lit (and turns off if i temporarliy remove the cable). But the hub light is still off.
Is there are way i can have it try to find any sort of connection across the network?
 
Old 11-27-2003, 02:10 PM   #8
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 64
You could try pinging another machine on your network or the IP address of the hub if it has one - eg:
ping ip.of.some.machine
 
Old 11-27-2003, 02:13 PM   #9
Temujin_12
Member
 
Registered: Sep 2003
Location: Washington
Distribution: Kubuntu Dapper
Posts: 99

Original Poster
Rep: Reputation: 15
it says 'connect: network unreachable' when i type 'ping 169.254.0.1' (which is machine 1's IP address and it's light is on on the hub)

Last edited by Temujin_12; 11-27-2003 at 02:17 PM.
 
Old 11-27-2003, 02:16 PM   #10
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 64
Can you post the output of:
ifconfig
route -n
 
Old 11-27-2003, 02:29 PM   #11
Temujin_12
Member
 
Registered: Sep 2003
Location: Washington
Distribution: Kubuntu Dapper
Posts: 99

Original Poster
Rep: Reputation: 15
here's route -n (i changed the formatting so you can read it easier):
Destination = 127.0.0.0
Gateway = 0.0.0.0
Genmask = 255.0.0.0
Flags = U
Metric = 0
Ref = 0
Use = 0
Iface = lo

here's ifconfig:
eth0
Link encap:Ethernet HWaddr 00:00:C0:F7:C6:E3
UP BREADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 carrier:34
collisioins:0 txqueuelen:100
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
Interrupt:10 Base address:0xd000

lo
Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:654310 errors:0 dropped:0 overruns:0 frame:0
TX packets:65431 errors:0 dropped:0 overuns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:4535663 (4.3 Mb) TX bytes:4535663 (4.3 Mb)
 
Old 11-28-2003, 12:31 PM   #12
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 64
Is that all that was in "route -n"? if you post it in [CODE] blocks the formatting isn't lost.
 
Old 11-29-2003, 12:04 AM   #13
Temujin_12
Member
 
Registered: Sep 2003
Location: Washington
Distribution: Kubuntu Dapper
Posts: 99

Original Poster
Rep: Reputation: 15
Here's the 'route -n' output again:

Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
127.0.0.0 0.0.0.0 255.0.0.0 U 0 0 0 lo
You have new mail in /var/spool/mail/root
 
Old 11-29-2003, 04:17 AM   #14
satishchowdhary
LQ Newbie
 
Registered: Nov 2003
Location: hyderabad
Posts: 6

Rep: Reputation: 0
disable the auto configuration of ur ethernet and give the manual setting and assign ip address in windows wht ever ur using dont not configure any dns server use the command setup after logged in as a root to configure your ethernet card

hope.....helpful
 
Old 11-29-2003, 05:40 AM   #15
baz2
Member
 
Registered: Nov 2002
Posts: 73

Rep: Reputation: 15
Do what satish says. Here's why.

Your first 'puter has a "bogus" APIPA subnet mask: it should be 255.255.0.0. When you tell your second 'puter in Win98 to obtain an IP address automatically, that's the mask it will get. So your first and second 'puters are not on the same subnet.

As for Linux, I don't think it does APIPA. If there is no DHCP server, it is not going to get an IP address. So you'll have to assign it a static IP address.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Network Cable Unplugged on Windows Caused by Linux Redhat 9.0 nader_hos Linux - Networking 8 07-26-2006 02:24 AM
Redhat 9 on a windows network oookiezooo Linux - Newbie 1 04-13-2005 08:34 AM
Redhat Linux 9 as mail relay for Windows Network mediamvp Linux - Networking 1 02-20-2004 02:57 PM
Redhat 9.0 on a Windows NT Network simon190675 Linux - Networking 1 05-30-2003 07:11 AM
Network redhat with windows |=|PRID|=| Linux - Networking 4 05-18-2003 02:08 AM


All times are GMT -5. The time now is 07:44 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration