LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Closed Thread
 
Search this Thread
Old 04-10-2004, 05:49 PM   #1
explorer
Member
 
Registered: Feb 2003
Posts: 229

Rep: Reputation: 34
hardware drivers loaded


Is there a command that shows all of the installed hardware devices or all of the device drivers that are loaded.?
 
Old 04-10-2004, 08:02 PM   #2
level
Member
 
Registered: Jan 2004
Posts: 82

Rep: Reputation: 15
You can try lsmod
 
Old 04-10-2004, 08:59 PM   #3
explorer
Member
 
Registered: Feb 2003
Posts: 229

Original Poster
Rep: Reputation: 34
I think that's what I needed, not sure...

[root@localhost /]# lsmod
Module Size Used by Not tainted
udf 90464 0 (autoclean)
ppp_deflate 4408 2 (autoclean)
zlib_inflate 21156 0 (autoclean) [ppp_deflate]
zlib_deflate 21144 0 (autoclean) [ppp_deflate]
bsd_comp 5336 0 (autoclean)
binfmt_misc 7020 1
lp 8096 1
parport_pc 25096 1
parport 34176 1 [lp parport_pc]
agpgart 40896 6 (autoclean)
i810_audio 26248 1
soundcore 6276 0 [i810_audio]
ac97_codec 12488 0 [i810_audio]
nfsd 74256 0 (autoclean)
ppp_async 9216 1
ppp_generic 24060 3 [ppp_deflate bsd_comp ppp_async]
slhc 6564 1 [ppp_generic]
af_packet 14952 0 (autoclean)
sr_mod 16920 0 (autoclean)
floppy 55132 0
bcm4400 30432 1 (autoclean)
nls_iso8859-1 3516 3 (autoclean)
ntfs 76812 3 (autoclean)
supermount 15296 2 (autoclean)
ide-cd 33856 0
cdrom 31648 0 [sr_mod ide-cd]
ide-scsi 11280 0
usb-storage 72952 0 (unused)
scsi_mod 103284 2 [sr_mod ide-scsi usb-storage]
scanner 10904 0
printer 8448 0
ehci-hcd 18568 0 (unused)
usb-uhci 24652 0 (unused)
usbcore 72992 1 [usb-storage scanner printer ehci-hcd usb-uhci]
rtc 8060 0 (autoclean)
ext3 59916 3
jbd 38972 3 [ext3]
 
Old 04-11-2004, 06:36 AM   #4
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 64
Please do not post the same thread in more than one forum. Picking the most relevant forum and posting it once there makes it easier for other members to help you and keeps the discussion all in one place.

http://www.linuxquestions.org/rules.php

Please continue here:
http://www.linuxquestions.org/questi...hreadid=168573
 
  


Closed Thread


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ds: no socket drivers loaded shanenin Linux - Software 0 09-12-2004 04:20 PM
nvidia drivers loaded. I think. Flaystus Linux - Newbie 2 02-23-2004 09:34 PM
ds: no socket drivers loaded John Newbie Linux - Networking 3 11-26-2003 09:13 PM
Drivers loaded at bootup jamescov Slackware 6 10-19-2003 08:33 PM
After The NVidia Drivers are loaded... Bevith Linux - Software 8 07-23-2003 07:24 AM


All times are GMT -5. The time now is 12:35 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration