LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 12-05-2008, 07:15 PM   #1
iLikeVanilla
LQ Newbie
 
Registered: Dec 2008
Location: Wichita Falls TX
Distribution: Slackware 12.1
Posts: 3

Rep: Reputation: 0
Getting Broadcom(4318) Wireless to work


I have used the most current b43-fwcutter and installed the firmware, but the system is not picking up any networks.

I'm using Slackware 12.1 Compact Pesario Broadcom 4318 (and yes it is compatible with b43)

All of the threads I have found so far are for Ubuntu and fedeora and when i try to follow the directions i get the command not found error.

device is recognized in wlan0

Thank you.

oh and I'm new to linux, just installed yesterday. I chose Slackware cause i was told it was the most difficult distro.

Last edited by iLikeVanilla; 12-05-2008 at 07:28 PM.
 
Old 12-05-2008, 09:58 PM   #2
lumak
Member
 
Registered: Aug 2008
Location: Phoenix
Distribution: Arch
Posts: 799
Blog Entries: 32

Rep: Reputation: 109Reputation: 109
Welcome to LQ and to slackware!

You may need to use -
Code:
/sbin/ifconfig wlan0 up
then try all the iwconfig and iwlist functions.

At first I was kind of displeased with the way slackware handles wireless but I found out that the majority of my problem was the b43legacy driver. I was missing a lot of functionality that made it virtually impossible for me change wireless networks after boot... If you observe this issue and some functions like changing the power state and 'commit' not working, I would recommend using the ndiswrapper which is capable of using windows XP drivers for your card.

By DEFAULT, the scripts /etc/rc.inet1 and /etc/rc.wireless are set up to log on to any available access point... If they can't obtain an IP from DHCP then they will disable the device with "/sbin/ifconfig wlan0 down". With the interface down, you can't use iwconfig or any of the other iw tools.

That should be enough to get you started. And don't be afraid to question your drivers. The xp drivers for my BCM4306 running under ndiswrapper are MUCH more stable than b43legacy.


As for the 'difficult' part... slackware (at least for me and many other slackware fans) find that the KISS method of slackware makes things far more easier than any other distro. People that say slackware is difficult are those that don't know what they are doing and don't care. They just want it to work withing 3 clicks.

I would define something difficult for computers if it contained needless steps or repetitive steps to do day to day tasks. Once you set up slackware the way you want it, you don't have to mess with it... well except for the wireless portion... if you change locations a lot and only want a set list of access points, it requires a bit more set up and probably custom scripts.
 
Old 12-06-2008, 03:02 AM   #3
iLikeVanilla
LQ Newbie
 
Registered: Dec 2008
Location: Wichita Falls TX
Distribution: Slackware 12.1
Posts: 3

Original Poster
Rep: Reputation: 0
ok so when i type ifconfig

Link encap:Ethernet HWaddr <mac address> (it look like)
UP BROADCAST MULICAST

From these two lines i think its safe to assume is broadcasting

now for the dumb question, am i supposed to connect to the internet through command line or by some GUI program? If whichever way, how?
 
Old 12-06-2008, 03:09 PM   #4
lumak
Member
 
Registered: Aug 2008
Location: Phoenix
Distribution: Arch
Posts: 799
Blog Entries: 32

Rep: Reputation: 109Reputation: 109
Quote:
am i supposed to connect to the internet through command line or by some GUI program?
You don't connect to the internet. You connect to your router and the router connects to the internet. The router (assuming has dhcp turned on) assigns you an IP address. You should let the slackware wirless scripts set all the iwconfig parameters and run a program to obtain an IP from the dhcp server.

You will learn more about the whole process if you use the command line and scripts in /etc/rc.d/ I personally haven't used GUIs to set up my wirless or network.

------------------

You should start with the manual pages for all the tools involved. Also, it helps if you can follow the scripts slackware uses to understand how it is doing everything to get you connected.

man ifconfig
man iwconfig
man iwlist

(also check the manuals for commands listed at the bottom of those pages under SEE ALSO)

Those 3 tools require root permissions for the settings to change. e.g.
Code:
su -c '/sbin/ifconfig wlan0 up'
assuming you have the correct driver/firmware installed; after a reboot, the module will be listed with /sbin/lsmod

Code:
/sbin/lsmod | grep b43
IF your wireless router is properly configured to assign ips AND it is the only one in your area. Slackware will automatically connect to it on boot.

You can force it to connect to only your network by editing /etc/rc.d/rc.inet1.conf (read the comments in the file).

ALSO! linux is not windows! iwconfig does not translate text string WEP keys into hexadecimal (0-9 and A-F) If you really must attempt all this with WEP turned on, make sure you use just hexadecimal. OR if you know what you are doing, you can convert a text string from ascii into hex and place that in the /etc/rc.d/rc.inet1.conf file. Until you get this figured out, I would attempt all this with WEP turned off.

The reason I don't give you step by step is because you said:
Quote:
I chose Slackware cause i was told it was the most difficult distro.
This tells me you want to do it on your own. Keep in mind, wireless was one of the more annoying things for me to get configured on my system. Just keep at it and keep reading everything.

----------------------

What I would start with to just see if everything works.

Assuming your access point is properly configured to assign ips and does not have the wep turned on...

Edit /etc/rc.d/rc.inet1.conf
uncomment the following variables and edit them
Code:
#IFNAME[4]="wlan0"
#IPADDR[4]=""
#NETMASK[4]=""
#USE_DHCP[4]="yes"
#DHCP_HOSTNAME[4]="icculus-wireless"
#...
#WLAN_ESSID[4]=BARRIER05
change the host name to the ip of your router (generally 192.168.0.1)
change the gateway (in the same file) to the ip of your router
change the essid to what you set it to on the router
edit any other parameters you may need.
save it

... sorry but I forgot if the hostname and gateway actually need to be filled in. If you can connect over cable and the eth0 section does not have an ip listed, then you probably don't need it for the wlan0 section.

after doing that.

unplug any ethernet cables from your computer and restart your computer. (a computer restart may not be required BUT as I said, I had issues with the b43legacy drivers not connecting at any time other than boot.)

IF all that works, then you know you have the ability to get connected with your wireless card. I would continue reading about the commands and playing around with scanning and other settings.

If that doesn't work and b43 is being loaded, you may have to use ndiswrapper anyway.

The scripts that slackware uses in /etc/rc.d/ are generally specific to slackware but are far easier to follow than in other distros.
 
Old 12-07-2008, 03:12 AM   #5
iLikeVanilla
LQ Newbie
 
Registered: Dec 2008
Location: Wichita Falls TX
Distribution: Slackware 12.1
Posts: 3

Original Poster
Rep: Reputation: 0
took me a while but i figured it out... also had someone else helping
 
Old 12-08-2008, 11:34 AM   #6
lumak
Member
 
Registered: Aug 2008
Location: Phoenix
Distribution: Arch
Posts: 799
Blog Entries: 32

Rep: Reputation: 109Reputation: 109
Cool Figuring it out is what it's all about
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Broadcom 4318 Wireless laurentduprasboileau Suse/Novell 1 07-25-2007 11:18 PM
has anyone got broadcom 4318 wireless to work? bailey239 Mandriva 3 07-23-2007 08:50 PM
I cannot get my WiFi to work in FC6 [Broadcom 4318] MangoFresh Linux - Wireless Networking 19 03-22-2007 09:49 AM
bcm43xx Broadcom 4318 wireless card Help Me Attacker87 Linux - Wireless Networking 1 01-19-2007 07:00 AM
Having trouble getting broadcom 4318 wirless to work sly100100 Linux - Newbie 7 03-13-2006 01:55 AM


All times are GMT -5. The time now is 08:44 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration