LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 12-17-2004, 12:34 PM   #1
MattParkins
LQ Newbie
 
Registered: Dec 2004
Distribution: Gentoo
Posts: 4

Rep: Reputation: 0
Gentoo: LiveCD auto detects eth0 ok but...


Crazy but true.

I'm installing Gentoo from the LiveCD and I've built & compiled the different stages. When booting from the LiveCD the network stuff is all autodetected and works fine (and downloaded the different stages, etc).

When I boot off of my installed system it attempts but errors with:

*Bringing eth0 up via DHCP [!!]
ERROR: Problems starting needed services
"netmount" was not started.

I'm running a tiny system. A DLink Router/Firewall with a cablemodem plugged in to it, my laptop (from which I'm typing now), and the linux box. The Linux box has a DLink DFE-500TX ethernet card in it - I've selected the DEC 21140 Tulip driver (which seems to be the one that the LiveCD goes for) from the menuconfig and (since I'm running DHCP) have configured /etc/conf.d/net to use DHCP, and of course emerge'd dhcpcd.

Am not sure which other bits of information to include - let me know if I can include anything more - any ideas where the problem is? From this I can't even tell whether it's even the driver or dhcp client?

Thanks

Matt
 
Old 12-17-2004, 02:25 PM   #2
peter_robb
Senior Member
 
Registered: Feb 2002
Location: Szczecin, Poland
Distribution: Gentoo, Debian
Posts: 2,458

Rep: Reputation: 47
Check dmesg to make sure the card is recognised..
and it gets to be called eth0 at boot..

Have you compiled drivers into the kernel or as modules?
Did you use genkernel or do it manually?
Are you using the initrd boot or straight to kernel..?
 
Old 12-20-2004, 03:20 AM   #3
MattParkins
LQ Newbie
 
Registered: Dec 2004
Distribution: Gentoo
Posts: 4

Original Poster
Rep: Reputation: 0
Thanks for your reply. I ran dmesg as you suggested and there's no reference to eth0 ! What kind of craziness is this ! There are a few entries related to IP Protocol, etc, but nothing to do with eth0 - so that's one lead.

In answer to your questions:

The drivers are compiled into the kernel and I did it manually (if I can't get it to work I'll go back and use genkernel), and no I'm not using initrd (my grub.conf makes no mention of it).

Thanks in advance for your help!
 
Old 12-20-2004, 03:49 AM   #4
scuzzman
Senior Member
 
Registered: May 2004
Location: Hilliard, Ohio, USA
Distribution: Slackware, Kubuntu
Posts: 1,851

Rep: Reputation: 47
Might try compiling the drivers as kernel modules...
 
Old 12-20-2004, 06:18 AM   #5
peter_robb
Senior Member
 
Registered: Feb 2002
Location: Szczecin, Poland
Distribution: Gentoo, Debian
Posts: 2,458

Rep: Reputation: 47
Modules aren't necessary... just an option..

If the card doesn't get loaded as eth0, there's a good chance it's the wrong driver compiled in..

Please post the dmesg lines that refer to the ethernet card..
both from the live cd and your kernel pls..
 
Old 12-20-2004, 08:50 AM   #6
MattParkins
LQ Newbie
 
Registered: Dec 2004
Distribution: Gentoo
Posts: 4

Original Poster
Rep: Reputation: 0
Ok, Thanks. The relavant lines from the LiveCD:
[snip]
Linux Tulip Driver version 1.1.13-NAP (May 11, 2002)
PCI: Found IRQ 10 for device 0000:00:11.0
tulip0: EEPROM default media type Autosense
tulip0: Index #0 - Media II (#11) decribed by 21140 MII PHY (1) block.
tulip0: MII transveiver #0 config 0000 status 780d advertising 01e1.
eth0: Digital DS21140 Tulip rev 34 at 0xd8d0c000, 00:80:C8:6F:73:A2, IRQ 10.
[snip fbsplash stuff]
eth0: Setting full-duplex based on MII#0 link partner capability of 05e1.


The kernel version has no mention whatsoever of eth0 at all !

hmmm...
 
Old 12-20-2004, 09:11 AM   #7
MattParkins
LQ Newbie
 
Registered: Dec 2004
Distribution: Gentoo
Posts: 4

Original Poster
Rep: Reputation: 0
How about that. Just changed the driver in menu config from the Tulip one to the generic DEC one and it worked... am pinging ok!

Thanks for all your help anyway!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
CUPS auto-detects and shows remote queues, how to disable? tisource Linux - General 6 12-02-2005 09:37 PM
have livecd of 'Linux Gentoo' how do i get past the "livecd root #" command line? randell6564 Linux - Distributions 11 11-20-2005 12:31 PM
LiveCD with auto SSH/terminal server? Havin_it Linux - Distributions 4 11-01-2005 08:59 AM
eth0 Auto Connect, How to auto start on logon cornish Linux - Networking 2 05-09-2005 12:02 PM
dhcp failure, eth0 gets no ip address on gentoo livecd boot behind hub Kethinov Linux - Networking 1 01-22-2004 01:17 PM


All times are GMT -5. The time now is 03:09 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration