LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 10-02-2005, 10:40 PM   #1
Equin
Member
 
Registered: Oct 2004
Location: Merrimack, NH
Distribution: Ubuntu / Apple
Posts: 46

Rep: Reputation: 15
FTP Timeout


Hey everybody,

I recently got an SDSL connection from G4 Communications for my servers here at home. Everything seems to be working great except for FTP.

I am running VSFTPD on a FC3 based box. I can connect to it just fine from anywhere in the local network. When somebody on the outside tries to connect, it doesn't work. They seem to be able to authenticate just fine, but when the directory listing comes it just times out.

I logged into one of the UNIX servers over at work and logged into my server here at home, it timed out as expected - I then turned off passive mode and the directory listing came without any problem.

I am using 1:1 NAT on my gatway (m0n0wall) - 216.177.19.108, port 20 and 21 TCP (Among the other usuals) are being forwared to 10.0.1.1

In the config for VSFTPD I tried "pasv_enable=NO" - That just gave me permission denied, though, when I tried to list the directory.

I should also note that it is possible to connect to the FTP server when I (Or anybody else) is connected to the m0n0wall's PPTP VPN service

At this point I am sort of stuck - Any help or suggestions would be greatly appreciated


Thanks a bunch!
-Equin

Last edited by Equin; 10-02-2005 at 11:04 PM.
 
Old 10-03-2005, 12:07 AM   #2
sal_paradise42
Member
 
Registered: Jul 2003
Location: Utah
Distribution: Gentoo FreeBSD 5.4
Posts: 150

Rep: Reputation: 16
I belive you need the ftp connection tracking module
Quote:
CONFIG_IP_NF_FTP - This module is required if you want to do connection tracking on FTP connections. Since FTP connections are quite hard to do connection tracking on in normal cases, conntrack needs a so called helper; this option compiles the helper. If you do not add this module you won't be able to FTP through a firewall or gateway properly

run this command
Code:
/sbin/modprobe ip_conntrack_ftp
 
Old 10-03-2005, 12:52 AM   #3
Equin
Member
 
Registered: Oct 2004
Location: Merrimack, NH
Distribution: Ubuntu / Apple
Posts: 46

Original Poster
Rep: Reputation: 15
I just run that command once in the command line? Or is this an option for VSFTPD ?

Thanks
-Eq
 
Old 10-03-2005, 12:55 AM   #4
sal_paradise42
Member
 
Registered: Jul 2003
Location: Utah
Distribution: Gentoo FreeBSD 5.4
Posts: 150

Rep: Reputation: 16
is actually a kernel module, is part of iptables which is the m0n0wall's underlying program.
Yeah just give it a run on the command line and see if it makes a diff. if it doesn't find it, you may need to download it.
 
Old 10-03-2005, 10:32 AM   #5
Equin
Member
 
Registered: Oct 2004
Location: Merrimack, NH
Distribution: Ubuntu / Apple
Posts: 46

Original Poster
Rep: Reputation: 15
Okey - So I am running this command on the m0n0wall?

If so - where do I execute it? I don't think there's any command line on m0n0wall - is there?

-Equin
 
Old 10-05-2005, 04:33 PM   #6
Equin
Member
 
Registered: Oct 2004
Location: Merrimack, NH
Distribution: Ubuntu / Apple
Posts: 46

Original Poster
Rep: Reputation: 15
Still haven't got it to work. Here's the error I get in a command line on my Mac. (OS X 10.4 Tiger)

ftp> open
(to) equis.seanspc.net
Connected to equis.seanspc.net.
220 Equis.seanspc.net - FTP Service. Please play nice
Name (equis.seanspc.net:sean): root
331 Please specify the password.
Password:
230 Login successful.
Remote system type is UNIX.
Using binary mode to transfer files.
ftp> ls
200 PORT command successful. Consider using PASV.
^C
421 Service not available, user interrupt. Connection closed.

Here's the configuration on my server (Part of it, at least):

pasv_enable=YES
pam_service_name=vsftpd
userlist_enable=YES
#enable for standalone mode
listen=YES
tcp_wrappers=YES


Anybody got any ideas?

Thanks a bunch!!!
-Equin
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ftp timeout - VERY FRUSTRATING! cz1179 Linux - General 7 01-31-2005 03:41 PM
ftp timeout problem eric_marsh Debian 4 06-29-2004 10:48 PM
FTP timeout pattar Linux - Software 5 02-21-2003 07:16 AM
how do i prevent ftp connection timeout? doublefailure Linux - General 5 11-23-2002 12:18 AM
wu-ftp/pop timeout lodevy Linux - Networking 4 05-02-2002 06:24 PM


All times are GMT -5. The time now is 02:07 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration