LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 10-11-2006, 01:06 PM   #16
calculemus
LQ Newbie
 
Registered: Sep 2006
Distribution: SuSE
Posts: 17

Original Poster
Rep: Reputation: 0

I chmod'ed the folder with 755. Here is what ls -l shows. The user and group is root. Could that be the reason why I am not able to access is from other computers?

drwxr-xr-x 4 root root 96 2006-10-10 02:52 ./
drwxr-xr-x 23 root root 568 2006-10-11 08:25 ../
drwxr-xr-x 2 root root 48 2006-04-23 03:51 ftp/
drwxr-xr-x 5 root root 120 2006-10-10 02:54 www/

Quote:
Originally Posted by SlackDaemon
I am glad that you stuck with it and didn't give up mid-way.
Thanks for the detailed instructions and support from your side. I really appreciate it.

Last edited by calculemus; 10-11-2006 at 01:07 PM.
 
Old 10-11-2006, 01:41 PM   #17
calculemus
LQ Newbie
 
Registered: Sep 2006
Distribution: SuSE
Posts: 17

Original Poster
Rep: Reputation: 0
//abacus is the name of my comuter now.

For your reference, I have posted below the content of various files.


Here is what the new /etc/xinetd.d/vsftp file looks like:

# default: off
# description:
# The vsftpd FTP server serves FTP connections. It uses
# normal, unencrypted usernames and passwords for authentication.
# vsftpd is designed to be secure.
#
# NOTE: This file contains the configuration for xinetd to start vsftpd.
# the configuration file for vsftp itself is in /etc/vsftpd.conf
#
service ftp
{
socket_type = stream
protocol = tcp
wait = no
user = root
server = /usr/sbin/vsftpd
# server_args =
# log_on_success += DURATION USERID
# log_on_failure += USERID
# nice = 10
disable = yes
}

----------------------------------------------------------------------------------------------------------------------------------------------------------

Here is how /etc/vsftp.conf file looks like:


# Example config file /etc/vsftpd.conf
#
# The default compiled in settings are fairly paranoid. This sample file
# loosens things up a bit, to make the ftp daemon more usable.
# Please see vsftpd.conf.5 for all compiled in defaults.
#
# If you do not change anything here you will have a minimum setup for an
# anonymus FTP server.
#
# READ THIS: This example file is NOT an exhaustive list of vsftpd options.
# Please read the vsftpd.conf.5 manual page to get a full idea of vsftpd's
# capabilities.

# General Settings
#
# Uncomment this to enable any form of FTP write command.
#
#write_enable=YES
#
# Activate directory messages - messages given to remote users when they
# go into a certain directory.
#
dirmessage_enable=YES
#
# It is recommended that you define on your system a unique user which the
# ftp server can use as a totally isolated and unprivileged user.
#
#nopriv_user=ftpsecure
#
# You may fully customise the login banner string:
#
#ftpd_banner="Welcome to FOOBAR FTP service."
#
# You may activate the "-R" option to the builtin ls. This is disabled by
# default to avoid remote users being able to cause excessive I/O on large
# sites. However, some broken FTP clients such as "ncftp" and "mirror" assume
# the presence of the "-R" option, so there is a strong case for enabling it.
#
#ls_recurse_enable=YES
#
# You may specify a file of disallowed anonymous e-mail addresses. Apparently
# useful for combatting certain DoS attacks.
#
#deny_email_enable=YES
#
# (default follows)
#
#banned_email_file=/etc/vsftpd.banned_emails
#
# If enabled, all user and group information in
# directory listings will be displayed as "ftp".
#
#hide_ids=YES

# Local FTP user Settings
#
# Uncomment this to allow local users to log in.
#
#local_enable=YES
#
# Default umask for local users is 077. You may wish to change this to 022,
# if your users expect that (022 is used by most other ftpd's)
#
#local_umask=022
#
# Uncomment to put local users in a chroot() jail in their home directory
# after login.
#
#chroot_local_user=YES
#
# You may specify an explicit list of local users to chroot() to their home
# directory. If chroot_local_user is YES, then this list becomes a list of
# users to NOT chroot().
#
#chroot_list_enable=YES
#
# (default follows)
#
#chroot_list_file=/etc/vsftpd.chroot_list
#
# The maximum data transfer rate permitted, in bytes per second, for
# local authenticated users. The default is 0 (unlimited).
#
#local_max_rate=7200


# Anonymus FTP user Settings
#
# Allow anonymous FTP?
#
anonymous_enable=YES
#
# Anonymous users will only be allowed to download files which are
# world readable.
#
anon_world_readable_only=YES
#
# Uncomment this to allow the anonymous FTP user to upload files. This only
# has an effect if the above global write enable is activated. Also, you will
# obviously need to create a directory writable by the FTP user.
#
#anon_upload_enable=YES
#
# Default umask for anonymus users is 077. You may wish to change this to 022,
# if your users expect that (022 is used by most other ftpd's)
#
#anon_umask=022
#
# Uncomment this if you want the anonymous FTP user to be able to create
# new directories.
#
#anon_mkdir_write_enable=YES
#
# Uncomment this to enable anonymus FTP users to perform other write operations
# like deletion and renaming.
#
#anon_other_write_enable=YES
#
# If you want, you can arrange for uploaded anonymous files to be owned by
# a different user. Note! Using "root" for uploaded files is not
# recommended!
#
#chown_uploads=YES
#chown_username=whoever
#
# The maximum data transfer rate permitted, in bytes per second, for anonymous
# authenticated users. The default is 0 (unlimited).
#
#anon_max_rate=7200


# Log Settings
#
# Log to the syslog daemon instead of using an logfile.
#
syslog_enable=YES
#
# Uncomment this to log all FTP requests and responses.
#
#log_ftp_protocol=YES
#
# Activate logging of uploads/downloads.
#
#xferlog_enable=YES
#
# You may override where the log file goes if you like. The default is shown
# below.
#
#vsftpd_log_file=/var/log/vsftpd.log
#
# If you want, you can have your log file in standard ftpd xferlog format.
# Note: This disables the normal logging unless you enable dual_log_enable below.
#
#xferlog_std_format=YES
#
# You may override where the log file goes if you like. The default is shown
# below.
#
#xferlog_file=/var/log/xferlog
#
# Enable this to have booth logfiles. Standard xferlog and vsftpd's own style log.
#
#dual_log_enable=YES
#
# Uncomment this to enable session status information in the system process listing.
#
#setproctitle_enable=YES

# Transfer Settings
#
# Make sure PORT transfer connections originate from port 20 (ftp-data).
#
connect_from_port_20=YES
#
# You may change the default value for timing out an idle session.
#
#idle_session_timeout=600
#
# You may change the default value for timing out a data connection.
#
#data_connection_timeout=120
#
# Enable this and the server will recognise asynchronous ABOR requests. Not
# recommended for security (the code is non-trivial). Not enabling it,
# however, may confuse older FTP clients.
#
#async_abor_enable=YES
#
# By default the server will pretend to allow ASCII mode but in fact ignore
# the request. Turn on the below options to have the server actually do ASCII
# mangling on files when in ASCII mode.
# Beware that turning on ascii_download_enable enables malicious remote parties
# to consume your I/O resources, by issuing the command "SIZE /big/file" in
# ASCII mode.
# These ASCII options are split into upload and download because you may wish
# to enable ASCII uploads (to prevent uploaded scripts etc. from breaking),
# without the DoS risk of SIZE and ASCII downloads. ASCII mangling should be
# on the client anyway..
#
#ascii_upload_enable=YES
#ascii_download_enable=YES
#
# Set to NO if you want to disallow the PASV method of obtaining a data
# connection.
#
#pasv_enable=NO

# PAM setting. Do NOT change this unless you know what you do!
#
pam_service_name=vsftpd

# Set listen=YES if you want vsftpd to run standalone
#
listen=YES

# Set to ssl_enable=YES if you want to enable SSL
ssl_enable=NO

---------------------------------------------------------------------------------------------------------------------------------------------------

My /etc/hosts file:


127.0.0.1 localhost

# special IPv6 addresses
::1 localhost ipv6-localhost ipv6-loopback

fe00::0 ipv6-localnet

ff00::0 ipv6-mcastprefix
ff02::1 ipv6-allnodes
ff02::2 ipv6-allrouters
ff02::3 ipv6-allhosts
127.0.0.2 abacus.abacus abacus

-----------------------------------------------------------------------------------------------------------------------------------------------------

Here is the content of /etc/hosts.deny

# /etc/hosts.deny
# See 'man tcpd' and 'man 5 hosts_access' as well as /etc/hosts.allow
# for a detailed description.

http-rman : ALL EXCEPT LOCAL


I commented out the previous line which says http-rman ... and restarted vsftp,xinetd.

The following was the message that I received when I typed in /etc/init.d/xinetd restart

Shutting down xinetd: done
Starting INET services. (xinetd) failed

-Calculemus


---------------------------------------------------------------------------------------------------------------------------------------------------------------

Content of my /etc/host.conf file:

#
# /etc/host.conf - resolver configuration file
#
# Please read the manual page host.conf(5) for more information.
#
#
# The following option is only used by binaries linked against
# libc4 or libc5. This line should be in sync with the "hosts"
# option in /etc/nsswitch.conf.
#
order hosts, bind
#
# The following options are used by the resolver library:
#
multi on

--------------------------------------------------------------------------------------------------------------------------------

The following is the permission for /etc/vsftpd.conf file:

-rw------- 1 root root 6147 2006-04-23 05:43 vsftpd.conf

Last edited by calculemus; 10-11-2006 at 01:47 PM.
 
Old 10-19-2006, 10:15 AM   #18
zmileta
LQ Newbie
 
Registered: Jun 2006
Posts: 9

Rep: Reputation: 0
Im trying to connect to vsftpd in freebsd from windows. I can only login using regular ftp. when I try to use dreamweaver with SFTPD I get an error, login and password incorrect. Is there any configuration I need to make in order to get it working?

I appreciate your help
 
Old 10-22-2006, 02:56 AM   #19
SlackDaemon
Member
 
Registered: Mar 2006
Distribution: RedHat, Slackware, Experimenting with FreeBSD
Posts: 222

Rep: Reputation: 30
Quote:
Originally Posted by calculemus
I chmod'ed the folder with 755. Here is what ls -l shows. The user and group is root. Could that be the reason why I am not able to access is from other computers?

drwxr-xr-x 4 root root 96 2006-10-10 02:52 ./
drwxr-xr-x 23 root root 568 2006-10-11 08:25 ../
drwxr-xr-x 2 root root 48 2006-04-23 03:51 ftp/
drwxr-xr-x 5 root root 120 2006-10-10 02:54 www/
Did you check if you have SElinux enabled?

The getenforce command will tell you if its enabled
setenforce 0 will temporarily shut it off.

Try logging into FTP with an anonymous user or local user instead of root.
 
Old 10-26-2006, 12:35 AM   #20
calculemus
LQ Newbie
 
Registered: Sep 2006
Distribution: SuSE
Posts: 17

Original Poster
Rep: Reputation: 0
# getenforce
bash: getenforce: command not found
# setenforce 0
bash: setenforce: command not found

Is it possible that SuSE uses some other version of selinux?
 
Old 10-28-2006, 10:35 PM   #21
SlackDaemon
Member
 
Registered: Mar 2006
Distribution: RedHat, Slackware, Experimenting with FreeBSD
Posts: 222

Rep: Reputation: 30
Did you run those two commands as the root user?

What happened when you tried to login to FTP with another username?
 
Old 11-03-2006, 10:06 PM   #22
calculemus
LQ Newbie
 
Registered: Sep 2006
Distribution: SuSE
Posts: 17

Original Poster
Rep: Reputation: 0
@SlackDaemon

Yes, I did run the two commands as the root user. It still did not accept those commands.

The problem was still there, it said access denied no matter whichever user I tried to log in as. I even tried to login anonymously but did not work either.

Maybe I should restart the entire procedure of setting up server from the beginning. Is there a nice and easy to install FTP server that you would recommend.

Thank you.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
vsftp - Can access FTP within office network BUT cant access via Internet! kokfei77 Red Hat 2 03-07-2012 07:24 PM
ftp server - Pure ftp - logs in OK but no files visible tp11235 Linux - Networking 2 08-30-2005 05:11 AM
How do I set my FTP server to accept passive FTP? imsam Linux - Newbie 3 12-12-2004 06:22 AM
VSFTP server set up pradi_net Linux - General 3 05-05-2004 04:49 AM
ftp server - how do I set it up? chapzilla Linux - Newbie 3 06-28-2003 07:22 PM


All times are GMT -5. The time now is 01:09 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration