LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices



Reply
 
Search this Thread
Old 11-04-2009, 09:33 AM   #1
forum_user
LQ Newbie
 
Registered: Nov 2009
Posts: 2

Rep: Reputation: 0
Smile ftp failure - IPv4 listening


Hi all,

Trying to ftp a Suse linux machine , I got the following error
Connecting to: 199.42.54.111 port: 21.
500 OOPS: could not bind listening IPv4 socket

inside /etc/vsftpd.conf, i checked the following:


listen=YES
listen_port=21
#listen_ipv6=YES


I tried to start the daemon vsftpd , I got the error

clerity-demo:~ # /etc/xinetd.d/vsftpd restart
service: no such service ftp
/etc/xinetd.d/vsftpd: line 8: socket_type: command not found
/etc/xinetd.d/vsftpd: line 9: wait: `=': not a pid or valid job spec
/etc/xinetd.d/vsftpd: line 9: wait: `no': not a pid or valid job spec
/etc/xinetd.d/vsftpd: line 10: user: command not found
/etc/xinetd.d/vsftpd: line 11: server: command not found
nice: =: No such file or directory
disable: Operation failed: client-error-not-found


I don't understand the reason of this command failure
Here is the content of /etc/xinetd.d/vsftpd, I modified it at all:

clerity-demo:~ # cat /etc/xinetd.d/vsftpd
# default: on
# description:s
# The vsftpd FTP server serves FTP connections. It uses
# normal, unencrypted usernames and passwords for authentication.
# vsftpd is designed to be secure.
service ftp
{
socket_type = stream
wait = no
user = root
server = /usr/local/sbin/vsftpd
# server_args =
# log_on_success += DURATION USERID
# log_on_failure += USERID
nice = 10
disable = no
}


Please advise ..
Yours,

Eman
 
Old 11-04-2009, 09:56 AM   #2
ammorais
Member
 
Registered: Nov 2009
Location: Lisbon, Portugal
Distribution: Gentoo, CentOs, Ubuntu, Debian
Posts: 182

Rep: Reputation: 49
If you are trying to initiate vsftpd trough xinetd you have to change listen=YES to listen=NO on vsftpd.conf.

Also if you are trying to use vsftpd trough xinetd then "/etc/xinetd.d/vsftpd restart" does not make sense. Restart the xinetd service instead.

Also add this line to /etc/xinetd.d/vsftpd

Code:
service ftp
{
socket_type = stream
wait = no
user = root
server = /usr/local/sbin/vsftpd
# server_args =
# log_on_success += DURATION USERID
# log_on_failure += USERID
nice = 10
disable = no

## Add this line 
server_args     = /etc/vsftpd.conf #The location of vsftpd.conf
}
On the other hand If you wan to configure vsftpd without xinetd. simple change the "disable = no" to "disable = yes" on /etc/xinetd.d/vsftpd and restart the vsftpd service.
PS: in the last scenario also restart the xinetd service.

Last edited by ammorais; 11-04-2009 at 10:06 AM.
 
Old 11-06-2009, 07:50 AM   #3
forum_user
LQ Newbie
 
Registered: Nov 2009
Posts: 2

Original Poster
Rep: Reputation: 0
Thanks a lot for your Reply
both ftp and sftp are working well now

But it workrd with and without adding the line
server_args = /etc/vsftpd.conf #The location of vsftpd.conf

was is added just to ensure reading the vsftpd.conf file
Your reply was vey useful to me anyway

Thanks again

Eman
 
Old 11-06-2009, 11:25 AM   #4
ammorais
Member
 
Registered: Nov 2009
Location: Lisbon, Portugal
Distribution: Gentoo, CentOs, Ubuntu, Debian
Posts: 182

Rep: Reputation: 49
Code:
was is added just to ensure reading the vsftpd.conf file
Yes. It was added just to make sure. Some times the packages are compiled with different options from distro to distro.

I'm glad It worked.
 
  


Reply

Tags
vsftpd, xinetd


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
vsftpd error: 500 00PS could not bind listening IPV4 socket...... thetotzky04 Linux - Newbie 1 05-01-2009 05:13 PM
500 OOPS: could not bind listening IPv4 socket error raevian Slackware 1 11-27-2007 02:53 AM
FTP 500 OOPS: could not bind listening IPv4 socket blipp Linux - Networking 11 07-06-2007 12:14 PM
cannot start vsftpd: 500 OOPS: could not bind listening IPv4 socket mr_scary Linux - Networking 2 01-26-2007 12:51 AM
vsftpd on RH4 - starting it gives 500 OOPS: could not bind listening IPv4 socket chucker8 Linux - Software 1 07-14-2006 03:39 PM


All times are GMT -5. The time now is 02:27 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration