LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 07-05-2007, 03:19 PM   #1
blipp
LQ Newbie
 
Registered: Jul 2007
Posts: 7

Rep: Reputation: 0
FTP 500 OOPS: could not bind listening IPv4 socket


Running SUSE 10.2 on laptop as NFS. Running 2.6.10 kernel on development board. Have ethernet connection between them and can ping both ways. I want to FTP from reference board to the host to transfer new applications for testing. It tells me I'm connected then immediately gives the the error I listed in the subject line. I've checked similar posts, but they have not helped me. I am not familiar with Linux networking, so any help will be useful.
 
Old 07-06-2007, 01:08 AM   #2
rylan76
Senior Member
 
Registered: Apr 2004
Location: Potchefstroom, South Africa
Distribution: Fedora 17 - 3.3.4-5.fc17.x86_64
Posts: 1,475

Rep: Reputation: 87
You might have some other process or app that is already using the FTP port(s)?

Why are you using FTP? Any particular reason?

I once worked in a similar setup and we used Samba to connect our desktops to the development machine (all Linux) that was hosting the web server were we wanted to place PHP web apps into to test them from our desktops...
 
Old 07-06-2007, 09:26 AM   #3
blipp
LQ Newbie
 
Registered: Jul 2007
Posts: 7

Original Poster
Rep: Reputation: 0
I have no particular reason for using FTP other than I thought it would be easy and expedient. Here is what rpcinfo -p tells me:

linux-4xdz:/usr/local/arm/kernel/linux-2.6.10 # rpcinfo -p
program vers proto port
100000 2 tcp 111 portmapper
100000 2 udp 111 portmapper
100005 1 udp 860 mountd
100005 1 tcp 861 mountd
100005 2 udp 860 mountd
100005 2 tcp 861 mountd
100005 3 udp 860 mountd
100005 3 tcp 861 mountd
100003 2 udp 2049 nfs
100003 3 udp 2049 nfs
100003 4 udp 2049 nfs
100003 2 tcp 2049 nfs
100003 3 tcp 2049 nfs
100003 4 tcp 2049 nfs
100024 1 udp 1024 status
100021 1 udp 1024 nlockmgr
100021 3 udp 1024 nlockmgr
100021 4 udp 1024 nlockmgr
100024 1 tcp 7851 status
100021 1 tcp 7851 nlockmgr
100021 3 tcp 7851 nlockmgr
100021 4 tcp 7851 nlockmgr
linux-4xdz:/usr/local/arm/kernel/linux-2.6.10 #
 
Old 07-06-2007, 09:44 AM   #4
nx5000
Senior Member
 
Registered: Sep 2005
Location: Out
Posts: 3,307

Rep: Reputation: 52
ftp doesnt rely on rpc so rpcinfo won't help in this case?

"Could not bind listening IPV4 socket" means that one machine (I guess the server) can not open a listening socket on that adress/port.

You should use the ftp command line client and activate debug
$ftp
ftp>debug

then
open host <servername>

And check what you are asking the ftp server to do.
It could also be a NAT/firewall between doing strange things.
 
Old 07-06-2007, 10:13 AM   #5
blipp
LQ Newbie
 
Registered: Jul 2007
Posts: 7

Original Poster
Rep: Reputation: 0
Turning on debug did not reveal anything else. I turned off the firewall on the host and it did not help.

/ # ftp
ftp> debug
Debugging on (debug=1).
ftp> open 192.168.3.120
Connected to 192.168.3.120.
500 OOPS: could not bind listening IPv4 socket
ftp>

Is there a better option than FTP that I should try?
 
Old 07-06-2007, 10:22 AM   #6
nx5000
Senior Member
 
Registered: Sep 2005
Location: Out
Posts: 3,307

Rep: Reputation: 52
Well, ftp is quite standard and easy. NFS is also good. http server for one way only

That's quite surprising, it happens before it asks you the user/password. At this step, it only involves a normal socket.

Still not sure where the message comes from.. hum..

Is your ftp server started with (x)inetd?
 
Old 07-06-2007, 10:34 AM   #7
blipp
LQ Newbie
 
Registered: Jul 2007
Posts: 7

Original Poster
Rep: Reputation: 0
How do I determine that?
 
Old 07-06-2007, 10:43 AM   #8
nx5000
Senior Member
 
Registered: Sep 2005
Location: Out
Posts: 3,307

Rep: Reputation: 52
Look in /etc/inetd.conf to see if theres a line with ftp.
 
Old 07-06-2007, 10:44 AM   #9
blipp
LQ Newbie
 
Registered: Jul 2007
Posts: 7

Original Poster
Rep: Reputation: 0
Here is the inetd.conf file from the target board.

/etc # cat inetd.conf
# /etc/inetd.conf: see inetd(8) for further informations.
#
# Internet server configuration database
#
#
# Lines starting with "#:LABEL:" or "#<off>#" should not
# be changed unless you know what you are doing!
#
# If you want to disable an entry so it isn't touched during
# package updates just comment it out with a single '#' character.
#
# Packages should modify this file by using update-inetd(8)
#
# <service_name> <sock_type> <proto> <flags> <user> <server_path> <args>
#
#:INTERNAL: Internal services
#echo stream tcp nowait root internal
#echo dgram udp wait root internal
#chargen stream tcp nowait root internal
#chargen dgram udp wait root internal
discard stream tcp nowait root internal
discard dgram udp wait root internal
daytime stream tcp nowait root internal
#daytime dgram udp wait root internal
time stream tcp nowait root internal
#time dgram udp wait root internal

#:STANDARD: These are standard services.
#<ftp-off>#ftp stream tcp nowait root /usr/sbin/tcpd /usr/sbin/proftpd
#ftp stream tcp nowait root /usr/sbin/tcpd /usr/sbin/wu-ftpd -l
telnet stream tcp nowait root /usr/sbin/tcpd /usr/sbin/in.telnetd

#:BSD: Shell, login, exec and talk are BSD protocols.

#:MAIL: Mail, news and uucp services.
#disabled#smtp stream tcp nowait mail /usr/sbin/exim exim -bs

#:INFO: Info services
#ident stream tcp wait identd /usr/sbin/identd identd

#:BOOT: Tftp service is provided primarily for booting. Most sites
# run this only on machines acting as "boot servers."

#:RPC: RPC based services

#:HAM-RADIO: amateur-radio services

#:OTHER: Other services
#netbios-ssn stream tcp nowait root /usr/sbin/tcpd /usr/sbin/smbd
/etc #
 
Old 07-06-2007, 10:48 AM   #10
blipp
LQ Newbie
 
Registered: Jul 2007
Posts: 7

Original Poster
Rep: Reputation: 0
/etc/xinetd.conf on the host machine (open SUSE) does not have an ftp line.
 
Old 07-06-2007, 10:54 AM   #11
nx5000
Senior Member
 
Registered: Sep 2005
Location: Out
Posts: 3,307

Rep: Reputation: 52
I've never used so much inetd so I'm not sure I understand what happens

Looking at this file it seems somebody played with it? You?

#<ftp-off>#ftp stream tcp nowait root /usr/sbin/tcpd /usr/sbin/proftpd
#ftp stream tcp nowait root /usr/sbin/tcpd /usr/sbin/wu-ftpd -l

check that either /usr/sbin/proftpd or /usr/sbin/wu-ftpd exist and uncomment the one.
then killall -HUP inetd to restart inetd
or reboot the server or restart inetd

did you check that the server doesnt have an xinetd? (replacement for inetd). The ftp client will NOT use (x)inetd so don't bother to look at it on the ftpclient

Sorry I have to leave, hope somebody will help you
 
Old 07-06-2007, 11:14 AM   #12
blipp
LQ Newbie
 
Registered: Jul 2007
Posts: 7

Original Poster
Rep: Reputation: 0
Neither of these exist, so I don't think it will do any good to uncomment them.

usr/sbin/proftpd
usr/sbin/wu-ftpd -l
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ftp 500 OOPS: cannot change directory yhus Linux - Networking 24 03-24-2013 09:41 PM
FTP users get: 500 OOPS: reading non-root config file tstrong12 Linux - Networking 10 07-21-2008 02:34 AM
cannot start vsftpd: 500 OOPS: could not bind listening IPv4 socket mr_scary Linux - Networking 2 01-25-2007 11:51 PM
vsftpd on RH4 - starting it gives 500 OOPS: could not bind listening IPv4 socket chucker8 Linux - Software 1 07-14-2006 02:39 PM
Could not bind listening socket chabotrobert Linux - Networking 1 10-29-2003 12:36 PM


All times are GMT -5. The time now is 10:58 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration