LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 04-07-2006, 12:27 AM   #1
yhus
Member
 
Registered: May 2004
Posts: 74

Rep: Reputation: 15
ftp 500 OOPS: cannot change directory


Hello,

I try to ftp from my RH9.0 to a linux device which is running vsftpd, but there was an error of "500 OOPS: cannot change directory ...". Then I have go to the device using a serial cable to change access mode from drwx---- to 777 in both /home and /home/use login directory, then it allow me to login. Appreciate any help on how to fix this problem.

Thank you.

Jim
 
Old 04-07-2006, 01:58 PM   #2
X-Ray
LQ Newbie
 
Registered: Dec 2005
Posts: 5

Rep: Reputation: 0
Linux is a future :-)

my frend users home directory should be /var/www/userfolder.


you can change it in the /etc/passwd file. look!
in the /etc/passwd file there is usrname /home/username
simply edit usrname /var/www/username. then you will be able to change directory. I have redhat 9.0 too. everything works well but sendmail is a problem for me.. I will wait yor success
 
Old 04-07-2006, 02:28 PM   #3
gmcmaster
Member
 
Registered: Feb 2003
Location: Poole, Dorset, England
Distribution: Fedora Core 5
Posts: 80

Rep: Reputation: 15
Quote:
Originally Posted by X-Ray
my frend users home directory should be /var/www/userfolder.


you can change it in the /etc/passwd file. look!
in the /etc/passwd file there is usrname /home/username
simply edit usrname /var/www/username. then you will be able to change directory. I have redhat 9.0 too. everything works well but sendmail is a problem for me.. I will wait yor success

Erm no they shouldn't.
 
Old 04-26-2006, 08:36 AM   #4
zahadumy
Member
 
Registered: May 2005
Location: Cluj, Romania
Distribution: Fedora Core 6
Posts: 226

Rep: Reputation: 31
I have the same problem here, I've googled for it but didn't find anything. Did you solve this?
 
Old 05-24-2006, 05:15 AM   #5
Dugroin
LQ Newbie
 
Registered: May 2006
Posts: 1

Rep: Reputation: 1
SELinux issue...

Hi Guys,

I had the same problem, and I found out that disabling SELinux solved the problem (watch out for any security issue that might bring)...
To disable SELinux, edit /etc/sysconfig/selinux and put it to 'disabled' (again, make sure you don't lower too much the security of your box)...

Now, I'll try to see how to keep SELinux enabled (enforced, that is) and still allow the FTP server to work properly ;-) !

Dugroin.
 
Old 09-11-2006, 01:49 PM   #6
ineptual
LQ Newbie
 
Registered: Sep 2006
Posts: 1

Rep: Reputation: 0
Quote:
Originally Posted by Dugroin
Hi Guys,

I had the same problem, and I found out that disabling SELinux solved the problem (watch out for any security issue that might bring)...
To disable SELinux, edit /etc/sysconfig/selinux and put it to 'disabled' (again, make sure you don't lower too much the security of your box)...

Now, I'll try to see how to keep SELinux enabled (enforced, that is) and still allow the FTP server to work properly ;-) !

Dugroin.

did you ever figure out how to use ftp in this manner with having to disable SELinux?
 
Old 09-19-2006, 03:53 PM   #7
UMTopSpinC7
LQ Newbie
 
Registered: Sep 2006
Location: Miami, FL
Distribution: Fedora Core
Posts: 2

Rep: Reputation: 0
in fedora core 5 i believe this can be fixed by going to Security Level and Firewall then the SELinux tab. Then click modify SELinux Policy, ftp and make sure "Allow ftp to read/write in the user home directories" is checked.

Or, just use

/usr/sbin/setsebool -P ftp_home_dir 1

That worked for me.
 
Old 10-02-2006, 12:05 AM   #8
xungan
LQ Newbie
 
Registered: Jul 2003
Location: Boston, MA
Distribution: Fedora Core 2 and RH9
Posts: 2

Rep: Reputation: 0
Thanks to all who posted in this Thread, saved me having to search down an answer from other sites and modifying the SELinux policy worked for me. Now to learn more about SELinux
 
Old 12-22-2006, 09:55 PM   #9
kreamer
LQ Newbie
 
Registered: Jan 2006
Posts: 1

Rep: Reputation: 0
Just wanted to tell you thank you for you'r helpfull solusion...

FEDORA 5 WITH SELinux.
 
Old 01-17-2007, 11:49 AM   #10
duanedyar
LQ Newbie
 
Registered: Jan 2007
Posts: 1

Rep: Reputation: 0
Thx, this does work.

This got it for me also.

Thx.

Duane
 
Old 02-12-2007, 11:38 PM   #11
mark_bj
LQ Newbie
 
Registered: Jan 2006
Posts: 2

Rep: Reputation: 0
My case similar as you, but not exactly , bcos nothing i can found in user home directly ... meaning, NO .bash_logout, .bash_profile, .bashrc, and .zshrc

i have no choice just delete and receate user account to fix it.
hope this information can help you.

 
Old 02-15-2007, 03:54 PM   #12
inescapeableus
Member
 
Registered: Feb 2004
Location: Canada
Distribution: GNU/Linux Debian (Etch)
Posts: 319

Rep: Reputation: 30
Hello everybody,

I am not sure if this may help you out or not, but I was experiencing the same issue with Debian. As it would turn out the issue was related to a Kernel option that was disabled. Please let me know if you have had any other successes with other methods.

Regards.
 
Old 04-16-2007, 09:13 AM   #13
haxpor
Member
 
Registered: Dec 2006
Distribution: Ubuntu 9.10
Posts: 86

Rep: Reputation: 15
Yes, this helped me too.
Thanks alot.
 
Old 05-14-2007, 03:31 PM   #14
Realsigno
LQ Newbie
 
Registered: May 2007
Distribution: Fedora Core 6
Posts: 1

Rep: Reputation: 0
Thank you so much

Fixed my problem. Really needed the server to backup my phone system, saved me from ton of work.
 
Old 10-18-2007, 03:51 PM   #15
newrad90
LQ Newbie
 
Registered: Feb 2007
Posts: 1

Rep: Reputation: 0
I'm using Fedora 7, problem was fixed with the suggestion of
su -
/usr/sbin/setsebool -P ftp_home_dir 1

thanks for the help. Linux forums are a lifesaver.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
500 OOPS: vsftpd: must be started as root userbr Linux - Networking 3 06-27-2011 01:44 AM
500 OOPS: unrecognised variable in config file c0c0deuz Linux - Networking 10 04-05-2007 06:09 PM
500 OOpS error w/ vsftpd 5amYan *BSD 5 11-08-2006 06:59 PM
VSFTP: 500 OOPS: unrecognised variable in config file snapper64 Linux - Software 4 07-01-2005 05:16 PM
500 OOPS: child died pandora Linux - Networking 1 02-10-2003 12:21 PM


All times are GMT -5. The time now is 03:45 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration