LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (http://www.linuxquestions.org/questions/linux-networking-3/)
-   -   Free VMWareServer Network Selection Question (http://www.linuxquestions.org/questions/linux-networking-3/free-vmwareserver-network-selection-question-558802/)

Linux31 06-03-2007 08:46 AM

Free VMWareServer Network Selection Question
 
I'm setting up the free VMWare server on an AMD64 3800+/Asus MB running CentOS 5.0 with a working static IP address.

The setup runs very smoothly but I need some guidance on selecting the type(s) of networking during the configuration process. The articles that I've found on Google seem to do a good job of telling you HOW but I still don't have a clue whether I want host-only, NAT, bridged, or some combination.

My situation is that I want to set up two astronomy programs in the virtual Win2000 machine. They need internet access so that they can connect to the Minor Planet Center to get updated position information for comets and asteroids. Also, I need Samba for exchanging files and accessing the printers which are on other physical machines.

Can anyone tell me which type of networking I need to choose when I run the VMWAre installation?

Thanks for any help you can provide.

Lenard 06-03-2007 10:03 AM

I just use the vmnet8 (NAT) choice myself, got internet and samba access to the systems desired. I did set a static IP for the virtual Windows system to be in my network IP address range (192.168.XXX.XXX) with the gateway IP address set to my wireless router's IP address.

For printing I do have a print-server that works well for Linux or any other OS virtual or not:

http://www.trendnet.com/en/products/TE100-P1P.htm


But one should use the networking choice that works best for your needs.

Linux31 06-03-2007 12:18 PM

Great. I think I know how to proceed now. Thanks for the help.

Linux31 06-05-2007 04:58 PM

UPDATE

I got the free VMWare server installed and the tools and it is still choking on the networking. I let it set up a NAT with 192.168.1.0 for the VMNET8.

I then went into the WIN2000 (the guest OS) and set up a static IP with that address but WIN won't accept it with a subnet mask of 255.255.255.0. I set up this same information on my Linksys router as a static IP routing and it accepted it with no problems.

I should note that the router insists on being 192.168.1.1 and won't start the addressing before 192.168.1.2 so I can't change the block of acceptable addresses. I've set the router's address as the default gateway as I did on all of the other machines which now have a working static IP.

The Windows guest is sending packets but its not receiving any. Any suggestions?

Thanks for any help you can provide.

Lenard 06-05-2007 08:30 PM

Any unused address between 192.168.1.2 and 192.168.1.254 should work. If I remember correctly a Linksys router's default DHCP address range is 192.168.1.2 to 192.168.1.100, try setting a static IP address above the .100 range.

Linux31 06-06-2007 07:54 AM

Thanks for the feedback. I think I have that done with an address range of 192.168.1.2-7 (the router is 1).

I think I've found the problem(s). I went looking for the config file and here it is and I can see a problem right off.

192.168.1.2 is already assigned to another physical machine on the hub as a static IP. When VMWare installed it said that vmnet8 was on subnet 192.168.1.0. I would expect the gateway to be the router and NAT is enabled on the router. Shouldin't I change the .2 references to .1?

Also, small quibble, it uses the default timeout as 60 min. even though I know I set it to 15.

I'm wondering about all of the other commented out entries. Should they be enabled with an address within my established range like 192.168.1.7? 192.168.1.128 would be outside of my range anyway even if not commented out.

What do you think?

Thanks again for the help.


===============


# Linux NAT configuration file
[host]
# NAT gateway address
ip = 192.168.1.2
netmask = 255.255.255.0
# or ip = 192.168.1.2/24

# enable configuration; disabled by default for security reasons
#configport = 33445

# VMnet device if not specified on command line
device = /dev/vmnet8

# Allow PORT/EPRT FTP commands (they need incoming TCP stream...)
activeFTP = 1

# Allows the source to have any OUI. Turn this one if you change the OUI
# in the MAC address of your virtual machines.
#allowAnyOUI = 1

[udp]
# Timeout in seconds, 0 = no timeout, default = 60; real value might
# be up to 100% longer
timeout = 60

[incomingtcp]
# Use these with care - anyone can enter into your VM through these...

# FTP (both active and passive FTP is always enabled)
# ftp localhost 8887
#8887 = 192.168.1.128:21

# WEB (make sure that if you are using named webhosting, names point to
# your host, not to guest... And if you are forwarding port other
# than 80 make sure that your server copes with mismatched port
# number in Host: header)
# lynx http://localhost:8888
#8888 = 192.168.1.128:80

# SSH
# ssh -p 8889 root@localhost
#8889 = 192.168.1.128:22

[incomingudp]
# UDP port forwarding example
#6000 = 192.168.1.128:6001

Linux31 06-07-2007 06:24 AM

Some success. I made the change to the default gateway in the NAT config file and now the Linux host and the Win2000 guest can see each other and exchange files.

HOWEVER

The Win2000 guest cannot access the Internet. Since it's static IP is well within the block of addresses I set up, I thought it might be a CentOS 5.0 firewall issue so I opened the VMWare port (984) in the Gnome firewall applet but no good. I turned off SeLinux during the CentOS install so that shouldn't be the issue.

Should I make http a trusted service in the Gnome firewall applet or uncomment the http line in the NAT config file and change the IP address it uses?

Any suggestions?

Thanks for any help you can provide.


All times are GMT -5. The time now is 05:39 PM.