LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (http://www.linuxquestions.org/questions/linux-networking-3/)
-   -   filezilla server (http://www.linuxquestions.org/questions/linux-networking-3/filezilla-server-4175442352/)

sniper8752 12-20-2012 02:42 PM

filezilla server
 
I have a Desktop with filezilla server installed. I am trying to access it from my laptop, but am not able to. I am thinking it has to do with the IP address/networking portion.

Kustom42 12-20-2012 02:51 PM

Please provide more information, what operating system, how is your network configured. Is this a LAN or WAN connection? What hardware are you using for routing? etc..

sniper8752 12-20-2012 03:09 PM

it's a lan. the desktop runs xp. I think the problem is that the server needs to have an external address, or when the router gets a request for something from the server, it redirects it to the proper place. i am simply using NIC cards and a router.

Kustom42 12-20-2012 03:28 PM

Seems like you may have a bit of a learning curve in front of you. I will include some help below to setup the FTP server but if you are simply wanting to share files I would suggest just using the windows file sharing functionality. http://support.microsoft.com/kb/304040


Since you are trying to connect within your LAN, you do not need an external, or WAN, IP to statically connect to. You will need to setup the port forwarding and, to make it easier on yourself, statically assign an internal IP for your desktop.

So you would need to login to your router and assign an IP to your desktop, go to your desktop and put it the IP you set on the router, you may need to reboot. http://portforward.com/networking/static-xp.htm

Once you have a static IP assigned to your local machine, you will need to setup port forwarding to allow the connections from your laptop to your desktop. The steps here are going to vary based upon your router model. The portforward.com site should have the reference docs you need once you identify your router make/model. Or just do a quick google search for "routermake model port forwarding".

If you need some more help along the way just ask.

jefro 12-20-2012 08:17 PM

I'd start at the filezilla computer. Put a blank file in your ftp directory so you can test this. Try command line ftp localhost or use a browser if it is supported. Then try the local ip address. It should work on the host computer. If not then diag settings, firewall and permissions.

When it works then you go to remote computer and test it. Same issues. Permissions like file, user still need to be looked at.

sniper8752 12-20-2012 09:29 PM

3 Attachment(s)
Quote:

Originally Posted by Kustom42 (Post 4853906)
Seems like you may have a bit of a learning curve in front of you. I will include some help below to setup the FTP server but if you are simply wanting to share files I would suggest just using the windows file sharing functionality. http://support.microsoft.com/kb/304040


Since you are trying to connect within your LAN, you do not need an external, or WAN, IP to statically connect to. You will need to setup the port forwarding and, to make it easier on yourself, statically assign an internal IP for your desktop.

So you would need to login to your router and assign an IP to your desktop, go to your desktop and put it the IP you set on the router, you may need to reboot. http://portforward.com/networking/static-xp.htm

Once you have a static IP assigned to your local machine, you will need to setup port forwarding to allow the connections from your laptop to your desktop. The steps here are going to vary based upon your router model. The portforward.com site should have the reference docs you need once you identify your router make/model. Or just do a quick google search for "routermake model port forwarding".

If you need some more help along the way just ask.

here is what I did.

what am I doing wrong yet?

Kustom42 12-21-2012 03:19 PM

You need to login to your router and forward the TCP port, this is not a standard port used by everyone and will be turned off by default. Find the model/make of your router and do a search on portforward or post here and I can find a link to the documentation you need.

sniper8752 12-21-2012 08:24 PM

isn't that what I did in the second image?

sniper8752 12-30-2012 06:06 PM

hello? lol.

Kustom42 01-07-2013 10:03 PM

Sorry for the late response, surprised nobody else jumped in here.

Well let's figure out where you're at.

Have you confirmed that you have a static IP assigned within the network for the system and can do you have ping connectivity to it?

The image you provided looks like a port forward but its hard to tell with just the snippet, there may be something else that is missing.

sniper8752 01-09-2013 03:52 PM

I run an ipconfig on the computer, and dhcp is disabled.

i am able to ping the dekstop from my laptop.

is there something else that I can take a picture of to provide more detail about my port forwarding settings?


All times are GMT -5. The time now is 02:29 PM.