LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 10-21-2011, 01:09 AM   #1
hedron
Member
 
Registered: Jul 2009
Location: NYC
Distribution: Slackware, Bluewhite
Posts: 222

Rep: Reputation: 22
File transfer is constantly interrupted - "There is a problem accessing Z:\blah\blah


OK, so everytime I try to copy files from my windows box to my slack box I get this error:
Code:
There is a problem accessing Z:\blah\blah

Make sure you are connected to the network and try again
I get the following options: try again, skip and cancel

I connect directly to the slackbox with a crossover cable. I have no router and use static ips.

The odd thing is that if I press skip then the file transfer/copy will continue, but the first file from each directory will not be copied and it takes abnormally long.

The only thing google has come up with is that it has something to do with auto-negotiation. I tried switching both adapters to 1000mbps and full duplex, with the driver properties in windows and ethtool in linux, but nothing I tried worked. I tried ethtool -s eth0 speed 1000 duplex full and there was no output.

Here's the output of ethtool eth0: (If it's any use)
Code:
Settings for eth0:
        Supported ports: [ MII ]
        Supported link modes:   10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
                                1000baseT/Full
        Supports auto-negotiation: Yes
        Advertised link modes:  10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
                                1000baseT/Full
        Advertised pause frame use: No
        Advertised auto-negotiation: Yes
        Speed: 1000Mb/s
        Duplex: Full
        Port: MII
        PHYAD: 8
        Transceiver: external
        Auto-negotiation: on
        Supports Wake-on: g
        Wake-on: d
        Link detected: yes
 
Old 10-21-2011, 07:51 PM   #2
countach74
Member
 
Registered: Feb 2011
Distribution: Ubuntu 10.04, Debian Squeeze
Posts: 46

Rep: Reputation: 7
I'm assuming it's a Samba share? If so, I too have had this problem or one similar.
 
Old 10-21-2011, 11:31 PM   #3
hedron
Member
 
Registered: Jul 2009
Location: NYC
Distribution: Slackware, Bluewhite
Posts: 222

Original Poster
Rep: Reputation: 22
Quote:
Originally Posted by countach74 View Post
I'm assuming it's a Samba share? If so, I too have had this problem or one similar.
Are your PCs directly connected via a crossover cable? Or connected via a router/switch/access point/bridge/whatever?

You wouldn't by any chance have a Samsung printer? And are using the drivers downloaded from their website?

Oh, and yes, it's a samba share.

Last edited by hedron; 10-21-2011 at 11:33 PM.
 
Old 10-22-2011, 01:26 AM   #4
countach74
Member
 
Registered: Feb 2011
Distribution: Ubuntu 10.04, Debian Squeeze
Posts: 46

Rep: Reputation: 7
I am using a switch. No crossover cable. No printer.
 
1 members found this post helpful.
Old 10-23-2011, 02:18 AM   #5
hedron
Member
 
Registered: Jul 2009
Location: NYC
Distribution: Slackware, Bluewhite
Posts: 222

Original Poster
Rep: Reputation: 22
Do you use ext3 or ext4 or what? I've used ext3 in the past and haven't had this issue, but now I am using ext4.

I also tried the samba option "strict allocate" both on and off with no success. It sounded promising, but this thread would never have been if it was.
 
Old 10-23-2011, 03:07 AM   #6
countach74
Member
 
Registered: Feb 2011
Distribution: Ubuntu 10.04, Debian Squeeze
Posts: 46

Rep: Reputation: 7
I doubt it's filesystem related. I use ext4. I've stopped worrying about it: I strictly use sshfs and nfs now for network file shares.
 
Old 10-26-2011, 12:16 PM   #7
hedron
Member
 
Registered: Jul 2009
Location: NYC
Distribution: Slackware, Bluewhite
Posts: 222

Original Poster
Rep: Reputation: 22
Well, I setup NFS, while it does work it's just way too slow to be useful.

So, it's a problem with Samba or Windows not liking UNC. I don't know if there's a specific setting in smb.conf that addresses this problem. I can only assume that's a negative.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
where can i locate the config file containing DAEMONS=(blah blah blah) ? sneakyimp Linux - Newbie 5 02-16-2011 09:08 PM
When can access("blah", R_OK) succeed and open("blah", O_RDONLY) fail? cyent Programming 3 08-03-2010 09:01 PM
LXer: SCO boss to customers: 'Blah. Blah. Blah' LXer Syndicated Linux News 0 02-06-2009 10:10 AM
Expanding file names in a script? ../blah -> /home/blah Bebo Linux - General 24 03-29-2004 05:39 PM
newbie issues....kernel panic: blah blah blah Rio Nishida Slackware 16 11-29-2002 12:08 AM


All times are GMT -5. The time now is 08:07 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration