LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (http://www.linuxquestions.org/questions/linux-networking-3/)
-   -   File transfer is constantly interrupted - "There is a problem accessing Z:\blah\blah (http://www.linuxquestions.org/questions/linux-networking-3/file-transfer-is-constantly-interrupted-there-is-a-problem-accessing-z-%5Cblah%5Cblah-909278/)

hedron 10-21-2011 02:09 AM

File transfer is constantly interrupted - "There is a problem accessing Z:\blah\blah
 
OK, so everytime I try to copy files from my windows box to my slack box I get this error:
Code:

There is a problem accessing Z:\blah\blah

Make sure you are connected to the network and try again

I get the following options: try again, skip and cancel

I connect directly to the slackbox with a crossover cable. I have no router and use static ips.

The odd thing is that if I press skip then the file transfer/copy will continue, but the first file from each directory will not be copied and it takes abnormally long.

The only thing google has come up with is that it has something to do with auto-negotiation. I tried switching both adapters to 1000mbps and full duplex, with the driver properties in windows and ethtool in linux, but nothing I tried worked. I tried ethtool -s eth0 speed 1000 duplex full and there was no output.

Here's the output of ethtool eth0: (If it's any use)
Code:

Settings for eth0:
        Supported ports: [ MII ]
        Supported link modes:  10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
                                1000baseT/Full
        Supports auto-negotiation: Yes
        Advertised link modes:  10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
                                1000baseT/Full
        Advertised pause frame use: No
        Advertised auto-negotiation: Yes
        Speed: 1000Mb/s
        Duplex: Full
        Port: MII
        PHYAD: 8
        Transceiver: external
        Auto-negotiation: on
        Supports Wake-on: g
        Wake-on: d
        Link detected: yes


countach74 10-21-2011 08:51 PM

I'm assuming it's a Samba share? If so, I too have had this problem or one similar.

hedron 10-22-2011 12:31 AM

Quote:

Originally Posted by countach74 (Post 4504842)
I'm assuming it's a Samba share? If so, I too have had this problem or one similar.

Are your PCs directly connected via a crossover cable? Or connected via a router/switch/access point/bridge/whatever?

You wouldn't by any chance have a Samsung printer? And are using the drivers downloaded from their website?

Oh, and yes, it's a samba share.

countach74 10-22-2011 02:26 AM

I am using a switch. No crossover cable. No printer.

hedron 10-23-2011 03:18 AM

Do you use ext3 or ext4 or what? I've used ext3 in the past and haven't had this issue, but now I am using ext4.

I also tried the samba option "strict allocate" both on and off with no success. It sounded promising, but this thread would never have been if it was.

countach74 10-23-2011 04:07 AM

I doubt it's filesystem related. I use ext4. I've stopped worrying about it: I strictly use sshfs and nfs now for network file shares.

hedron 10-26-2011 01:16 PM

Well, I setup NFS, while it does work it's just way too slow to be useful.

So, it's a problem with Samba or Windows not liking UNC. I don't know if there's a specific setting in smb.conf that addresses this problem. I can only assume that's a negative.


All times are GMT -5. The time now is 11:36 AM.