LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (http://www.linuxquestions.org/questions/linux-networking-3/)
-   -   file sharing by using samba (http://www.linuxquestions.org/questions/linux-networking-3/file-sharing-by-using-samba-208270/)

caesarkim 07-22-2004 08:32 AM

file sharing by using samba
 
I have two computers. win 2k server is installed in one computer and red hat linux 9 is installed in another computer.

I installed samba 3.04 on linux computer to share files. I am using webmin to configure samba and other stuff. I can see server name(linux) in "Computers near me" section on win 2k server, but when i try to access it, it says "\\frodo is not accessible. The network path was not found". i double-checked if samba is running. it's running ok.

can anybody tell me how to do it?

chop 07-22-2004 08:46 AM

Can you access the linux-shares with \\ip.address via start->run ?
Do you have an entry for netbios in smb.conf?

caesarkim 07-22-2004 08:55 AM

file sharing
 
thank you for reply.

no, i can access with ip address.

and i have an entry for netbios in smb.conf like this

netbios name=frodo
netbios aliases=frodo
path=/tmp/download

chop 07-22-2004 09:42 AM

Could you post your smb.conf ?
Do you have a samba-user added?

Try adding a wins server to the windows-machine, with the ip of your linuxmachine.

Code:

my smb.conf

[global]
  workgroup        = Home
  server string    = Cute fileserver
  security          = user
  hosts allow      = 192.168.100.1 192.168.100.3
  log file          = /var/log/samba/log.%I
  passdb backend    = tdbsam
  socket options    = TCP_NODELAY SO_RCVBUF=8192 IPTOS_LOWDELAY SO_RCVBUF=8192 SO_SNDBUF=8192
  os level          = 32
  domain master    = no
  preferred master  = no
  wins support      = yes
  wins server      = 192.168.100.2
  wins proxy        = yes
  netbios name      = Aoi
  dns proxy        = yes
  case sensitive    = no

  encrypt passwords = yes

# Shares

[homes]
  public          = no
  browseable      = no
  read only        = no

[shared]
  path            = /stor/
  public          = yes
  writable        = no
  read only        = yes
  browsable        = yes
  valid users      = view

[upload]
  path            = /stor/5/upload
  public          = no
  writable        = yes
  read only        = yes
  browsable        = yes
  valid users      = upload
  write list      = upload


silence 07-22-2004 09:49 AM

Assuming that your name resolution is working and \\someip works...

I think what is happening is that there are no shares configured. The W2K isn't able to parse our \\frodo properly. Samba won't have any C$ or shares so there won't be anything for it to connect to and since \\frodo isn't a complete UNC path so it errors

Edit your smb.conf file and make sure you have some kinda share there Here is a really fast (but insecure example) Put it toward the end of the smb.conf file. Log in as root. If it works, remove this stuff and do it right.

[public]
path = /home
public = yes
only guest = yes
writable = yes
printable = no


All times are GMT -5. The time now is 11:19 PM.