LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
LinkBack Search this Thread
Old 07-03-2004, 01:18 PM   #1
nyxx
LQ Newbie
 
Registered: Jul 2004
Location: Virginia
Distribution: Slackware 10
Posts: 8

Rep: Reputation: 0
Fedora Networking Help


Hello Linux Friends,

As of today I am a newbie to the linux world, as I received a gift for a recent birthday of a book packaged with Fedora Core 1 However the book covers basics and not really troubleshooting.

I have had the excess parts from upgrades to build the system for a while and have been interested in learning to use linux. Thus you will find some hardware items less than current.

I have installed the Fedora Core 1 linux and packages that came with the guide and got as far as networking, I am on a network with 2 XP HE computers connected to a linksys BEFSR41 now on the XP boxes it's plug N surf..

I need help setting up fedora. The on board networking is detected its a VT(several numbers) Rhine II or to XP a VIA T10/100 Ethernet port, and it is shown in the network setup as eth0 it will not auto detect dhcp, it fails during boot and if I insert an ip i.e 192.168.102 and 255.255.255.0 and refresh It will show active and I can connect to the router setup, via 192.168.1.1 but not the internet.

I am working within gnome under the user account and yes have and know the root password, I know not square one what to do, and would appreciate a very newbie ish hand held walkthrough.

System info is as such:

Soyo KT333 dragon Plus Mobo
Onboard Intel Ethernet T10/100
Onboard CMedia Sound
AMD 1G Processor
512M DDR Ram
ATI Radeon 7000VE 64M AGP
Maxtor 13G HDD
Creative 52X CDROM

Networking Router
Linksys BEFSR41 v2 w/the latest firmaware installed.

Internet Information
Verizon DSL PPOE
Dynamic IP's change connection is maintained by the router.
The router is setup as a dhcop server for upto 3 Machines.

Thanks In Advance,

Nyxx
Future Penguista

p.s To US residents have a good 4th weekend.
 
Old 07-03-2004, 01:48 PM   #2
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 64
Welcome to LQ.

When you say that you cannot connect to the internet - is it just dns names that are causing the problem?
ping -c1 www.linuxquestions.org
ping -c1 64.179.4.149

Also check that your defautl route is set to "192.168.1.1":
route -n

if you are unsure about this then post the output of the above commands.
 
Old 07-03-2004, 02:33 PM   #3
nyxx
LQ Newbie
 
Registered: Jul 2004
Location: Virginia
Distribution: Slackware 10
Posts: 8

Original Poster
Rep: Reputation: 0
David,

Thanks for the rapid reply, it is when I try to goto any named external address i.e www.linuxquestions.org etc..

From within Gnome under the User account not root, where would I enter those commands? The terminal?

------------------
ping -c1 www.linuxquestions.org
ping -c1 64.179.4.149

Also check that your defautl route is set to "192.168.1.1":
route -n

if you are unsure about this then post the output of the above commands.
------------

Thanks

nyxx
 
Old 07-03-2004, 02:38 PM   #4
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 64
It shouldn't matter if you are root or not but if you aren't you may need:
/sbin/route -n

You can run it from any bash prompt. Just open gnome-terminal
 
Old 07-03-2004, 02:55 PM   #5
nyxx
LQ Newbie
 
Registered: Jul 2004
Location: Virginia
Distribution: Slackware 10
Posts: 8

Original Poster
Rep: Reputation: 0
David,

When I tried to run it from terminal prior to your 2nd post the commands did not work so I logged in under root and entered them in the terminal.

A ping -c1 64.179.4.149 Resulted in Network is Unreachable.

Route -n results are

Destination---Gateway---Genmask-------Flags---Metric---Ref---Use---Iface
192.168.1.0---0.0.0.0---255.255.255.0-----u-----0-------0-------0----eth0
169.254.0.0---0.0.0.0---255.255.0.0-------u-----0-------0-------0----eth0
127.0.0.0-----0.0.0.0---255.0.0.0----------u-----0-------0-------0---10


Thanks,
Nyxx

Last edited by nyxx; 07-03-2004 at 03:00 PM.
 
Old 07-03-2004, 03:02 PM   #6
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 64
You seem to have no default route (the route that packets take when there are no more specific matching rules). In Fedora I think you can set this by running:
netconfig

For your network it will most likely be 192.168.1.1

After you have set the gateway, run:
service network restart

You should then be able to at least ping external IP addresses - if you still have problems with resolving DNS names then put your ISPs DNS servers in /etc/resolv.conf - the format is:
nameserver ip.of.primary.dns
nameserver ip.of.secondary.dns
 
Old 07-03-2004, 03:36 PM   #7
nyxx
LQ Newbie
 
Registered: Jul 2004
Location: Virginia
Distribution: Slackware 10
Posts: 8

Original Poster
Rep: Reputation: 0
David,

When I tried to run netconfig in the root terminal there are 4 entries ipadress netmask default gateway and primary nameserver. I enter 192.168.1.102 as the ip address b/c my other 2 pc's are assigned 192.168.100, and 101 by dhcp. anyway it generated the netmask 255.255.255.0 default gateway 192.168.1.254 and primary nameserver 192.168.1.1

A ping -c1 64.179.4.149

Resulted in 1 Packet transmitted 0 received +1 errors 100% packet loss time 0ms pipe2

Route -n results are

Destination---Gateway---------Genmask-------Flags---Metric---Ref---Use---Iface
192.168.1.0---0.0.0.0---------255.255.255.0-----u-----0-------0-------0----eth0
169.254.0.0---0.0.0.0---------255.255.0.0-------u-----0-------0-------0----eth0
127.0.0.0-----0.0.0.0---------255.0.0.0----------u-----0-------0-------0---10
0.0.0.0-------192.168.1.254---0.0.0.0------------ug----0------0------0----eth0

Thanks,
Nyxx
 
Old 07-03-2004, 03:41 PM   #8
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 64
I thought your rotuer was 192.168.1.1? What is 192.168.1.254?

Try setting the gateway to 192.168.1.1
 
Old 07-03-2004, 03:51 PM   #9
nyxx
LQ Newbie
 
Registered: Jul 2004
Location: Virginia
Distribution: Slackware 10
Posts: 8

Original Poster
Rep: Reputation: 0
David,

That did the trick, My thanks to you. Have a good weekend.

Nyxx
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Fedora 3 networking commands?? bond00 Linux - Networking 3 11-29-2004 07:37 AM
Networking WinXP and Fedora Rabe Linux - Newbie 7 10-10-2004 02:49 PM
fedora 2 and networking with W$ mannoulla Linux - Software 1 07-08-2004 12:27 PM
Fedora-Win95 Networking karl_herrick Linux - Networking 1 05-03-2004 01:34 PM
Fedora Networking jeopardyracing Linux - Networking 1 02-09-2004 05:20 AM


All times are GMT -5. The time now is 11:15 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration