LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 12-26-2003, 05:13 PM   #1
takaki
LQ Newbie
 
Registered: Dec 2003
Location: NH, USA
Distribution: Debian Sarge 3.1
Posts: 5

Rep: Reputation: 0
Unhappy Fedora Core on Satellite Pro 4300 hangs up when its starting w/ LAN card inserted.


Problem
----------
I installed Fedora Core Release 1 (Yarrow) on my Laptop PC(Toshiba Satellite Pro 4300). It seems it is working ok except that the Laptop hangs up when I srart/restart the laptop with a LAN card inserted. I used two LAN cards (3com Megahertz 10/100 Lan PC card model 3ccfe574BT & Linksys EtherFast 10/100 PC card model PCMPC100), but either card does not work. When the laptop stops, if I eject the LAN card, it starts to move again and completes its starting process. After the Laptop has started, I can insert the LAN cards any time into the slot and it works perfectly fine. The hang-up happens only when I start/restart the laptop with the LAN card inserted.

System Summary
---------------------
Kernel Version: 2.4.22-1.2135.nptl
OS: Fedora Core Release 1 (Yarrow)
PC: Toshiba Satellite Pro 4300
Lan Card: 1) 3com Megahertz 10/100 Lan PC card model 3ccfe574BT
2) Linksys EtherFast 10/100 PC card model PCMPC100

System Log
------------------
Below is the system log until laptop hangs up. Not from the very beginning, but from after cardmgr recoginizes the 3 com LAN card. I think the network connection is established, but after that the laptop hangs up for some reason:

Dec 26 12:41:10 localhost pcmcia: cardmgr.
Dec 26 12:41:11 localhost cardmgr[1461]: starting, version is 3.1.31
Dec 26 12:41:11 localhost rc: Starting pcmcia: succeeded
Dec 26 12:41:11 localhost cardmgr[1461]: watching 2 sockets
Dec 26 12:41:11 localhost cardmgr[1461]: Card Services release does not match
Dec 26 12:41:11 localhost kernel: cs: IO port probe 0x0c00-0x0cff: clean.
Dec 26 12:41:11 localhost kernel: cs: IO port probe 0x0100-0x04ff: excluding 0x378-0x37f 0x4d0-0x4d7
Dec 26 12:41:11 localhost kernel: cs: IO port probe 0x0a00-0x0aff: clean.
Dec 26 12:41:11 localhost kernel: cs: memory probe 0xa0000000-0xa0ffffff: clean.
Dec 26 12:41:11 localhost cardmgr[1461]: socket 0: 3Com 572/574 Fast Ethernet
Dec 26 12:41:11 localhost cardmgr[1461]: executing: 'modprobe 3c574_cs'
Dec 26 12:41:12 localhost netfs: Mounting other filesystems: succeeded
Dec 26 12:41:12 localhost kernel: eth0: Megahertz 574B at io 0x300, irq 5, hw_addr 00:01:03:AA:69:90.
Dec 26 12:41:12 localhost kernel: ASIC rev 1, 64K FIFO split 1:1 Rx:Tx, autoselect MII interface.
Dec 26 12:41:12 localhost cardmgr[1461]: executing: './network start eth0'
Dec 26 12:41:13 localhost apmd[1512]: Version 3.0.2 (APM BIOS 1.2, Linux driver 1.16)
Dec 26 12:41:13 localhost apmd: apmd startup succeeded
Dec 26 12:41:13 localhost kernel: ip_tables: (C) 2000-2002 Netfilter core team
Dec 26 12:41:14 localhost autofs: automount startup succeeded
Dec 26 12:41:14 localhost smartd[1587]: smartd version 5.21 Copyright (C) 2002-3 Bruce Allen
Dec 26 12:41:14 localhost smartd[1587]: Home page is # I erace the URL since this BBS does not allow me to post with the page address.
Dec 26 12:41:14 localhost smartd[1587]: Opened configuration file /etc/smartd.conf
Dec 26 12:41:14 localhost apmd[1512]: Battery: * * * (100% 1:57)
Dec 26 12:41:14 localhost smartd[1587]: Configuration file /etc/smartd.conf parsed.
Dec 26 12:41:14 localhost smartd[1587]: Device: /dev/hda, opened
Dec 26 12:41:14 localhost smartd[1587]: Device: /dev/hda, not found in smartd database.
Dec 26 12:41:15 localhost smartd[1587]: Device: /dev/hda, is SMART capable. Adding to "monitor" list.
Dec 26 12:41:15 localhost smartd[1587]: Monitoring 1 ATA and 0 SCSI devices
Dec 26 12:41:15 localhost smartd[1611]: smartd has fork()ed into background mode. New PID=1611.
Dec 26 12:41:15 localhost smartd: smartd startup succeeded
Dec 26 12:41:15 localhost kernel: eth0: found link beat
Dec 26 12:41:15 localhost kernel: eth0: autonegotiation complete: 100baseT-FD selected
Dec 26 12:41:16 localhost dhclient: DHCPREQUEST on eth0 to 255.255.255.255 port 67
Dec 26 12:41:17 localhost dhclient: DHCPACK from 192.168.1.1
Dec 26 12:41:17 localhost dhclient: bound to 192.168.1.102 -- renewal in 41668 seconds.
Dec 26 12:41:19 localhost kernel: parport0: PC-style at 0x378 (0x778) [PCSPP,TRISTATE]
Dec 26 12:41:19 localhost kernel: parport0: irq 7 detected
Dec 26 12:41:19 localhost kernel: lp0: using parport0 (polling).
Dec 26 12:41:19 localhost kernel: lp0: console ready
Dec 26 12:41:19 localhost modprobe: modprobe: Can't locate module char-major-188
Dec 26 12:41:20 localhost last message repeated 15 times
Dec 26 12:41:20 localhost cups: cupsd startup succeeded
Dec 26 12:41:21 localhost sshd: succeeded
Dec 26 12:41:21 localhost xinetd: xinetd startup succeeded
Dec 26 12:41:22 localhost apmd[1512]: Now using AC Power
Dec 26 12:41:24 localhost xinetd[1726]: xinetd Version 2.3.12 started with libwrap loadavg options compiled in.
Dec 26 12:41:24 localhost xinetd[1726]: Started working: 1 available service
Dec 26 12:41:24 localhost sendmail: sendmail startup succeeded
Dec 26 12:41:24 localhost sendmail: sm-client startup succeeded
Dec 26 12:41:25 localhost gpm: gpm startup succeeded
Dec 26 12:41:27 localhost canna: succeeded
Dec 26 12:41:28 localhost crond: crond startup succeeded
Dec 26 12:41:30 localhost xfs: xfs startup succeeded
Dec 26 12:41:30 localhost anacron: anacron startup succeeded
Dec 26 12:41:30 localhost atd: atd startup succeeded
Dec 26 12:41:31 localhost xfs: ignoring font path element /usr/X11R6/lib/X11/fonts/cyrillic (unreadable)
Dec 26 12:41:32 localhost messagebus: messagebus startup succeeded
Dec 26 12:41:33 localhost init: open(/dev/pts/0): No such file or directory
Dec 26 12:41:33 localhost last message repeated 2 times
Dec 26 12:42:00 localhost gdm(pam_unix)[1915]: session opened for user root by (uid=0)
Dec 26 12:42:02 localhost gconfd (root-1996): starting (version 2.4.0), pid 1996 user 'root'
Dec 26 12:42:02 localhost gconfd (root-1996): Resolved address "xml:readonly:/etc/gconf/gconf.xml.mandatory" to a read-only config source at position 0
Dec 26 12:42:02 localhost gconfd (root-1996): Resolved address "xml:readwrite:/root/.gconf" to a writable config source at position 1
Dec 26 12:42:02 localhost gconfd (root-1996): Resolved address "xml:readonly:/etc/gconf/gconf.xml.defaults" to a read-only config source at position 2
Dec 26 12:42:14 localhost xinetd[2011]: warning: can't get client address: Transport endpoint is not connected
Dec 26 12:42:23 localhost kernel: hdc: attached ide-cdrom driver.
Dec 26 12:42:23 localhost kernel: hdc: ATAPI 24X DVD-ROM drive, 128kB Cache, UDMA(33)
Dec 26 12:42:23 localhost kernel: Uniform CD-ROM driver Revision: 3.12
Dec 26 12:42:31 localhost kernel: cdrom: This disc doesn't have any tracks I recognize!

#So, the laptop hangs up here. After I eject the LAN card (and put the card right back in), the laptop starts again. Below is the system log after I eject the LAN card:

Dec 26 12:50:15 localhost kernel: eth0: interrupt(s) dropped!
Dec 26 12:50:16 localhost cardmgr[1461]: executing: './network stop eth0'
Dec 26 12:50:33 localhost cardmgr[1461]: executing: 'modprobe -r 3c574_cs'
Dec 26 12:50:35 localhost cardmgr[1461]: socket 0: 3Com 572/574 Fast Ethernet
Dec 26 12:50:35 localhost cardmgr[1461]: executing: 'modprobe 3c574_cs'
Dec 26 12:50:36 localhost kernel: eth0: Megahertz 574B at io 0x300, irq 5, hw_addr 00:01:03:AA:69:90.
Dec 26 12:50:36 localhost kernel: ASIC rev 1, 64K FIFO split 1:1 Rx:Tx, autoselect MII interface.
Dec 26 12:50:36 localhost cardmgr[1461]: executing: './network start eth0'
Dec 26 12:50:41 localhost kernel: ip_tables: (C) 2000-2002 Netfilter core team
Dec 26 12:50:43 localhost kernel: eth0: found link beat
Dec 26 12:50:43 localhost kernel: eth0: autonegotiation complete: 100baseT-FD selected
Dec 26 12:50:49 localhost dhclient: DHCPREQUEST on eth0 to 255.255.255.255 port 67
Dec 26 12:50:51 localhost dhclient: DHCPACK from 192.168.1.1
Dec 26 12:50:52 localhost dhclient: bound to 192.168.1.102 -- renewal in 43089 seconds.
Dec 26 12:51:36 localhost kernel: PCI: Found IRQ 11 for device 00:0c.0
Dec 26 12:51:36 localhost kernel: PCI: Sharing IRQ 11 with 00:0b.1
Dec 26 12:51:36 localhost kernel: ymfpci: YMF744 at 0xefff8000 IRQ 11
Dec 26 12:51:36 localhost kernel: ac97_codec: AC97 Audio codec, id: AKM2 (Asahi Kasei AK4543)
Dec 26 12:51:37 localhost modprobe: modprobe: Can't locate module sound-service-0-0


Sorry for the long message, but I appreciate it if anyone can help me to solve this problem.

Sincerely yours,

tak
 
Old 03-28-2004, 06:55 AM   #2
gcams
LQ Newbie
 
Registered: Mar 2004
Posts: 1

Rep: Reputation: 0
Hi takaki

I had the same problem and found I solve the issue by removing the the "alias eth0 etc" lines from the modules.conf file. It struck me that the scripts were trying to modprobe the wrong modules or something along those lines. I never did get to the bottom of the lockups but removing those 'alias eth0' statements from my modules.conf definitely corrected the lockup problems for me.

Regards,
Graham
 
Old 03-29-2004, 11:02 PM   #3
takaki
LQ Newbie
 
Registered: Dec 2003
Location: NH, USA
Distribution: Debian Sarge 3.1
Posts: 5

Original Poster
Rep: Reputation: 0
Hi Graham,

Thank you for your reply. I totally forgot about this problem. This problem happened only when I installed Gnome/KDE for desktop environment, and I found that if I use twm for adesktop environment, the lockups will not happen. But, I will try what you suggested.

Sincerely,

Tak
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Toshiba Satellite 4300 Pro T_T problemo robot2051 Linux - Laptop and Netbook 0 08-08-2005 01:30 PM
Toshiba Satellite PRO 4300 Modem drivers.. madh52 Linux - Laptop and Netbook 4 12-28-2004 05:28 AM
Fedora Core 3 hangs, freezes on "Starting sshd" ayrton Fedora 2 12-09-2004 10:11 PM
Fedora startup hangs while starting PCMCIA card services redsack Fedora 2 01-19-2004 02:47 PM
System hangs when PCMCIA SCSI card inserted simjii Mandriva 0 12-01-2003 01:14 AM


All times are GMT -5. The time now is 11:47 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration