LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 04-07-2006, 10:33 AM   #1
gmcmaster
Member
 
Registered: Feb 2003
Location: Poole, Dorset, England
Distribution: Fedora Core 5
Posts: 80

Rep: Reputation: 15
Fedora Core 5 - Network Dies When KDE Starts


Hi there, I've just installed FC5 on my server and all is well... Well not really. My Network Interface works without a hitch right up until you hit enter on the login screen and KDE starts and, the kernel produces the following error:

Code:
irq 16: nobody cared (try booting with the "irqpoll" option)
 [<c0137acf>] __report_bad_irq+0x2b/0x69     [<c0137c8c>] note_interrupt+0x17f/0x1ab
 [<c01375ea>] handle_IRQ_event+0x23/0x4c     [<c01376ad>] __do_IRQ+0x9a/0xcd
 [<c0105552>] do_IRQ+0x5c/0x77     =======================
 [<c0103b4a>] common_interrupt+0x1a/0x20
handlers:
[<df880966>] (rtl8139_interrupt+0x0/0x3e3 [8139too])
Disabling IRQ #16
And the Network interface stops responding to pings, etc. If I change to a Terminal and do a

telinit 3
/etc/init.d/network restart
telinit 5

It works fine again until I go to start KDE. Useful! I hope someone can share a pearl of wisdom. I have tried booting using "irqpoll" but the Kernel Dumps.

Cheers

Graham
 
Old 04-07-2006, 12:35 PM   #2
Darin
Senior Member
 
Registered: Jan 2003
Location: Portland, OR USA
Distribution: Slackware, SLAX, Gentoo, RH/Fedora
Posts: 1,024

Rep: Reputation: 45
cat /proc/interrupts

If I had to take a stab in the dark I'd guess some other hardware like the soundcard shares an interrupt and doesn't mess with the network until KDE goes to play some sounds.
 
Old 04-07-2006, 01:02 PM   #3
gmcmaster
Member
 
Registered: Feb 2003
Location: Poole, Dorset, England
Distribution: Fedora Core 5
Posts: 80

Original Poster
Rep: Reputation: 15
Good try, but no its the only device on IRQ 16
 
Old 04-07-2006, 03:49 PM   #4
gmcmaster
Member
 
Registered: Feb 2003
Location: Poole, Dorset, England
Distribution: Fedora Core 5
Posts: 80

Original Poster
Rep: Reputation: 15
Anyone else any ideas?
 
Old 04-07-2006, 04:38 PM   #5
gmcmaster
Member
 
Registered: Feb 2003
Location: Poole, Dorset, England
Distribution: Fedora Core 5
Posts: 80

Original Poster
Rep: Reputation: 15
Thanks for the help It's now working. I moved the Network Card to a different PCI Slot (the only other one on the Motherboard) It didnt look like an IRQ conflict but it looks like it was, or another resource.

Posting this from Firefox under KDE on Fedora Core 5

Thanks once again
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
OpenSSH starts and dies TimP AIX 3 10-27-2006 09:01 PM
bridge starts on boot but dies on logoff? doublez Linux - Networking 0 09-23-2005 12:35 PM
eth0 dies on Fedora Core 4 dinolinux Linux - Networking 3 06-26-2005 10:51 AM
SMC2802W refusing to work with Fedora Core 3 and prism54 and card never starts? Mad Processor Linux - Wireless Networking 0 02-22-2005 05:11 PM
eth0 starts before pcmcia on fedora core 1 bryan1138 Linux - Laptop and Netbook 3 02-19-2004 07:45 PM


All times are GMT -5. The time now is 05:03 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration