LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (http://www.linuxquestions.org/questions/linux-networking-3/)
-   -   Fedora 8 problem - kernel: Bad page state in process 'kswapd0' (http://www.linuxquestions.org/questions/linux-networking-3/fedora-8-problem-kernel-bad-page-state-in-process-kswapd0-624565/)

pvandeus 02-28-2008 04:22 PM

Fedora 8 problem - kernel: Bad page state in process 'kswapd0'
 
When I transfer large files to this machine I get the following errors.
If I'm lucky, the transfer will complete successfully, then I have to reboot.
This is Fedora 8 fully up to date as of Feb 28th on a newly built system that has
these components: IP35 Pro MB, Intel Core 2 Q6600 and a MSI NX8600GT-TD512EZ GeForce 8600GT 512MB 128-bit GDDR2 PCI Express x16 video card.
There are 2 Western Digital 500GB 7200 RPM 8MB Cache SATA-300 Hard Drives,

I buried this in a related post, but it was probably the wrong place to put it.
see that post at the end of this thread: http://www.linuxquestions.org/questi...sabled-621614/

=======
Message from syslogd@ncasi2 at Feb 27 16:18:13 ...
kernel: Bad page state in process 'kswapd0'

Message from syslogd@ncasi2 at Feb 27 16:18:13 ...
kernel: page:c292a1c0 flags:0x80000008 mapping:00000000 mapcount:-8388608 count:0 (Not tainted)

Message from syslogd@ncasi2 at Feb 27 16:18:13 ...
kernel: Trying to fix it up, but a reboot is needed

Message from syslogd@ncasi2 at Feb 27 16:18:13 ...
kernel: Backtrace:
=====
any suggestions are appreciated.

pvandeus 02-29-2008 08:56 AM

Use NIC instead of onboard ethernet to fix
 
I installed an ethernet pci card and the problem went away.
Apparently the driver for the onboard ethernet on the IP35 PRO needs work.
Incidentally, the IP35 PRO ethernet is Realtek and the driver that was applied is r8169, just in case someone who can fix that sort of thing reads this.


All times are GMT -5. The time now is 01:40 PM.