LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices



Reply
 
Search this Thread
Old 02-18-2012, 01:38 PM   #1
kev717
Member
 
Registered: May 2008
Distribution: Arch, Sabayon, Fedora, Ubuntu
Posts: 72

Rep: Reputation: 16
Exclamation Fedora 16 NFS share stopped working unexpectedly.


Today I mounted my NFS server as usual (I usually do so every few months) and it worked with relatively few problems (had to restart the nfs-server service). After about a half hour, the NFS server screen went black, the keyboard froze for a few seconds and then the computer rebooted. Since then, my notebook (the thing connecting to the server) has been unable to connect to my NFS server (even after rebooting). It just keeps timing out. Both computers are Fedora 16.

So far I have tried editing my /etc/exports, disabling the firewall on both machines, and modifying my mount options but my notebook will no longer connect to my NFS server. Is there any way I can fix this?

My /etc/exports:
Quote:
#directory allowed IP (options)
#/home/Public 192.168.2.1(rw,sync)

/home/jinx/Public2 192.168.2.1/255.255.255.0(ro,no_root_squash)

/home/jinx/Public 192.168.2.1/255.255.255.0(ro,no_root_squash)
My usual mount command:
Code:
mount -t nfs <server IP>:/home/user/Public /media/Public
Currently my NFS settings are such that I don't require a password to access the files on the network share. I will post log files if required.
This has worked for me for 9 months thus far.

I originally posted this under "Linux - Server" but decided it is probably better to post it here. Any moderators feel free to remove the one in "Linux - Server".
 
Old 02-18-2012, 02:36 PM   #2
T3RM1NVT0R
Senior Member
 
Registered: Dec 2010
Location: Internet
Distribution: Linux Mint, Ubuntu, SLES, CentOS
Posts: 1,790

Rep: Reputation: 324Reputation: 324Reputation: 324Reputation: 324
@ Reply

Hi kev717,

Let us start from beginning. Check the following things:

1. Connectivity between both client and server machines. You can use ping for that.
2. NFS service status on the server. Command you can use:
Code:
service nfs status
3. Telnet the server on port 2049. From the client machine run the following command:
Code:
telnet <server name or ip address> 2049
If you get connection refused then there is some problem with nfs service on the server. If you get a prompt to enter escape charater then nfs service is running on the server and is listening on port 2049. I am assuming that you have not changed the default nfs port on the server.

You said that you have tried editing /etc/export. The one that you have pasted is the edited one or the orginal one? Did you make any recent changes to any of these machines?

It will be great if you could run the mount -t nfs command again and paste the output of the following:

Code:
tail /var/log/messages
 
Old 02-18-2012, 04:07 PM   #3
kev717
Member
 
Registered: May 2008
Distribution: Arch, Sabayon, Fedora, Ubuntu
Posts: 72

Original Poster
Rep: Reputation: 16
1. Yes, the ping is successful (I get around 1.00 ms).
2. Output from running "service nfs-server status"
Quote:
Redirecting to /bin/systemctl status nfs-server.service
nfs-server.service - NFS Server
Loaded: loaded (/lib/systemd/system/nfs-server.service; enabled)
Active: active (running) since Sat, 18 Feb 2012 15:38:03 -0500; 4min 10s ago
Main PID: 1053 (rpc.rquotad)
CGroup: name=systemd:/system/nfs-server.service
├ 1053 /usr/sbin/rpc.rquotad
└ 1068 /usr/sbin/rpc.mountd
3. telnet to the server: I got connection refused. I did not modify any of the default ports. The pasted /etc/export is the edited version, normally the options are (rw,sync). I have reverted the files back to their normal status. I have updated these machines since I last successfully used NFS, however today when I tried to connect them it initially worked so I'm not sure if the updates did something or if something else is going on.

Output from tail /var/log/messages on client machine:
Quote:
Feb 18 15:58:19 zareason ntpd[870]: 0.0.0.0 c612 02 freq_set kernel -28.554 PPM
Feb 18 15:58:19 zareason ntpd[870]: 0.0.0.0 c615 05 clock_sync
Feb 18 16:00:08 zareason dbus[885]: [system] Activating service name='net.reactivated.Fprint' (using servicehelper)
Feb 18 16:00:08 zareason dbus-daemon[885]: dbus[885]: [system] Activating service name='net.reactivated.Fprint' (using servicehelper)
Feb 18 16:00:08 zareason dbus-daemon[885]: Launching FprintObject
Feb 18 16:00:08 zareason dbus[885]: [system] Successfully activated service 'net.reactivated.Fprint'
Feb 18 16:00:08 zareason dbus-daemon[885]: dbus[885]: [system] Successfully activated service 'net.reactivated.Fprint'
Feb 18 16:00:08 zareason dbus-daemon[885]: ** Message: D-Bus service launched with name: net.reactivated.Fprint
Feb 18 16:00:08 zareason dbus-daemon[885]: ** Message: entering main loop
Feb 18 16:00:38 zareason dbus-daemon[885]: ** Message: No devices in use, exit
Output from dmesg | tail on client machine:
Quote:
[ 42.511727] wlan0: moving STA 00:17:3f:02:cb:a8 to state 3
[ 44.027482] type=1400 audit(1329597581.664:4): avc: denied { unlink } for pid=871 comm="NetworkManager" name="resolv.conf" dev=dm-1 ino=2363294 scontext=system_u:system_r:NetworkManager_t:s0 tcontext=unconfined_ubject_r:etc_t:s0 tclass=file
[ 52.562123] wlan0: no IPv6 routers present
[ 138.624468] fuse init (API version 7.17)
[ 138.651934] SELinux: initialized (dev fusectl, type fusectl), uses genfs_contexts
[ 138.693866] SELinux: initialized (dev fuse, type fuse), uses genfs_contexts
[ 145.309082] lp: driver loaded but no devices found
[ 145.356687] ppdev: user-space parallel port driver
[ 314.115305] FS-Cache: Loaded
[ 314.157331] FS-Cache: Netfs 'nfs' registered for caching
Also, I just sent a file between the machines using scp.
 
Old 02-18-2012, 04:26 PM   #4
T3RM1NVT0R
Senior Member
 
Registered: Dec 2010
Location: Internet
Distribution: Linux Mint, Ubuntu, SLES, CentOS
Posts: 1,790

Rep: Reputation: 324Reputation: 324Reputation: 324Reputation: 324
@ Reply

As you said that when you try to telnet nfs server on port 2049 you get connection refused that means that there is something that is blocking the connection.

You said that you already tried disabling the firewall. How did you disable it? I mean did you use system-config-firewall to disable it?

Do you know which updates got installed today?
 
Old 02-18-2012, 04:51 PM   #5
kev717
Member
 
Registered: May 2008
Distribution: Arch, Sabayon, Fedora, Ubuntu
Posts: 72

Original Poster
Rep: Reputation: 16
I don't know which updates were installed today, but it stopped working before I installed any updates today. I tried disabling firewall through system-config-firewall. The client computer never had firewall enabled. There is also a firewall between the main network and the outside internet which I have tried disabling.
 
Old 02-18-2012, 05:14 PM   #6
T3RM1NVT0R
Senior Member
 
Registered: Dec 2010
Location: Internet
Distribution: Linux Mint, Ubuntu, SLES, CentOS
Posts: 1,790

Rep: Reputation: 324Reputation: 324Reputation: 324Reputation: 324
@ Reply

Could you please explain me your network setup because it definitely appears that there is something that is blocking the traffic to that server.

As we know that the service is running on the server then there has to be something that is blocking the trafic. Otherwise your telnet output should be something like:

Code:
telnet server 2049
Trying xxx.xxx.xxx.xxx...
Connected to server.
Escape character is '^]'.
instead of connection refused.
 
Old 02-18-2012, 06:48 PM   #7
kev717
Member
 
Registered: May 2008
Distribution: Arch, Sabayon, Fedora, Ubuntu
Posts: 72

Original Poster
Rep: Reputation: 16
Coming in from the cable modem, I have a router with a firewall on it. This firewall only affects incoming packets from the modem. From there, my internet is distributed to my computers, the main server in one room and my notebook on the wireless.

The notebook has no firewall on it at all and the main computer (the nfs server) has a firewall via system-config-firewall which I have tried disabling. The firewall on the NFS server has both 2049 tcp and udp ports open.

The nfs server is able to telnet to the notebook, however the reverse is not true.

The nfs server is also unable to connect to itself (I tried mounting an nfs share on the machine that nfs server that was serving it), and the connection still timed out. I am thinking there is probably something misconfigured on my server, but I'm not sure what it could be.
 
Old 02-18-2012, 06:55 PM   #8
kev717
Member
 
Registered: May 2008
Distribution: Arch, Sabayon, Fedora, Ubuntu
Posts: 72

Original Poster
Rep: Reputation: 16
Found it!

For some reason, the rpc.nfsd was failing to start. If I execute it manually it starts working again.

Thanks for your help

--
kev717.
 
Old 02-18-2012, 06:58 PM   #9
T3RM1NVT0R
Senior Member
 
Registered: Dec 2010
Location: Internet
Distribution: Linux Mint, Ubuntu, SLES, CentOS
Posts: 1,790

Rep: Reputation: 324Reputation: 324Reputation: 324Reputation: 324
@ Reply

If system is not able to telnet itself on port 2049 and if you are not able to mount nfs share on the system itself then the issue is with service itself.

Is it possible to reboot this system? If yes, then reboot it.

Commands that we can try are:

Code:
systemctl restart nfs-server.service
Once you run this command check /var/log/messages if you find any errors there. If yes, then paste them here.

Edit: Just saw your post that you found the solution. From the output you pasted earlier it was looking like it was working fine. But it happens sometime :-). Please mark the thread as solved.

Last edited by T3RM1NVT0R; 02-18-2012 at 07:00 PM.
 
  


Reply

Tags
file sharing, network, nfs, server


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
NFS Server randomly stopped working: Fedora 16. kev717 Linux - Server 1 02-18-2012 04:51 PM
wi-fi stopped working after nfs installation netimen Linux - Networking 2 10-01-2009 05:40 AM
My NFS client stopped working stefane321 Linux - Networking 2 06-02-2008 12:33 PM
NFS stopped working John_Zbesko Linux - Server 1 09-18-2007 10:30 AM
NFS share not working ahmedb72 Red Hat 3 02-22-2006 03:38 AM


All times are GMT -5. The time now is 09:53 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration