LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (http://www.linuxquestions.org/questions/linux-networking-3/)
-   -   Fedora 13 NIC not active at boot (http://www.linuxquestions.org/questions/linux-networking-3/fedora-13-nic-not-active-at-boot-814337/)

chawcheskew 06-15-2010 03:26 PM

Fedora 13 NIC not active at boot
 
Most of my experience configuring network settings has been through various GUI tools available in GNOME and KDE. I have some older hardware that will not run KDE or GNOME and I am trying to configure the NIC. I have installed Webmin to try to configure the interface, and it does fine for setting a static address or DHCP address, but the interface (eth0) is not active at boot. As soon as I run ifup eth0, it will use the assigned IP or pull DHCP based on settings, but I can't seem to get it to automatically activate at boot. And yes, /etc/sysconfig/network-scripts/ifcfg-eth0 does have ONBOOT=yes set.

I need two things...

1 - are there any good cli tools, ncurses or such like netcfg I can install to manage the interface (I have tried the network manager cli tools, maybe I just don't get it, but that isn't working so good for me)

2 - any suggestions on how to make the interface activate at boot.

anomie 06-15-2010 05:49 PM

I don't use it, but you might give system-config-network-tui a look.

IIRC, it stores network interface info in /etc/sysconfig/networking/ (which overrides /etc/sysconfig/network-scripts/).

chawcheskew 06-18-2010 11:41 AM

Thanks for the tool, I tried it, and it does fine configuring the interface, however I don't see an option to make the network card active at boot...

I have gone into the configuration files and set the option ONBOOT=yes, but I still have to run "ifup eth0" every time I restart. Here are the configs I have, any suggestions?

/etc/sysconfig/networking/devices/ifcfg-eth0


# Intel Corporation 82540EM Gigabit Ethernet Controller
DEVICE=eth0
HWADDR=00:0c:f1:9c:5d:32
ONBOOT=yes
IPADDR=192.168.200.37
BOOTPROTO=none
NETMASK=255.255.255.0
DNS2=8.8.8.8
TYPE=Ethernet
GATEWAY=192.168.200.1
DNS1=192.168.200.1
IPV6INIT=no
USERCTL=no

/etc/sysconfig/networking/profiles/default/ifcfg-eth0
# Intel Corporation 82540EM Gigabit Ethernet Controller
DEVICE=eth0
HWADDR=00:0c:f1:9c:5d:32
ONBOOT=yes
IPADDR=192.168.200.37
BOOTPROTO=none
NETMASK=255.255.255.0
DNS2=8.8.8.8
TYPE=Ethernet
GATEWAY=192.168.200.1
DNS1=192.168.200.1
IPV6INIT=no
USERCTL=no

(the same)

chawcheskew 06-18-2010 11:51 AM

Ok, the problem is solved, thanks anomie for your help. Here is the other missing piece.

http://www.tek-tips.com/viewthread.cfm?qid=1506351&page=1

(I hope it's not frowned on to point to other forum posts)

So essentially the networking service wasn't enabled in runlevel 3? Whats up with that Fedora?


All times are GMT -5. The time now is 04:27 AM.