LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 03-16-2009, 12:46 PM   #1
glarizza
LQ Newbie
 
Registered: Mar 2009
Distribution: Fedora 10
Posts: 2

Rep: Reputation: 0
Fedora 10 - Enable Wireless at Login Screen for LDAP Authentication


Hi All,
I've got Fedora 10 up and running on a Samsung NC-10, and have "yum update"-ed to make sure I have the current versions of everything. I've run authconfig-gtk and setup a connection to our LDAP server, and have setup an NFS mount in /etc/fstab to the homedrive directory. Everything's working splendidly - as long as you use the Ethernet connection.

I cannot get the wireless connection up and running at the login screen. I can get it working AFTER you login, and can run "getent passwd" when the wireless (wlan0) is enabled and the Ethernet connection is disconnected - it displays a list of all my LDAP users. If I log out, however, change to another console screen/shell, and run the command - it dies (when the wireless is enabled and ethernet is disconnected).

I've read up a bit, and I believe it may be because NetworkManager isn't getting an IP Address from the login screen. I've turned off all security to the wireless network, and am broadcasting the SSID. From the shell, I can run iwconfig and see that I'm connected to my Network. Running "dhclient wlan0", however, hangs...it just sits there. Checking out dmesg, I see a couple of messages:

wlan0: associated
wlan0 (WE) : Wireless Event too big (294)
wlan0: disassociating by local choice (reason=3)

Has anyone seen this or fixed it? Thanks!

EDIT: I had two Access Points that were both broadcasting the same SSID - this was the SSID to which I was attempting to connect. I changed on of their SSIDs so that there are two unique SSIDs and attempted to reconnect. I'm still having the issue with the "DISASSOCIATING BY LOCAL CHOICE (REASON=3)" error, but the Wireless Event error has been removed. I'm also still having the problem of connecting and getting an IP while I'm at the login window.
-Gary

Last edited by glarizza; 03-17-2009 at 06:46 AM. Reason: Added new information.
 
Old 03-31-2009, 07:31 AM   #2
martin.dragt@gmail.com
LQ Newbie
 
Registered: Mar 2009
Posts: 1

Rep: Reputation: 0
same problem here: no wireless connection at login

Hi,

I've got the same here: no wireless connection at login time, thus not able to login with useraccounts that have their home folders on an nfs location.

Hope someone can help
Martin
 
Old 03-31-2009, 07:44 AM   #3
glarizza
LQ Newbie
 
Registered: Mar 2009
Distribution: Fedora 10
Posts: 2

Original Poster
Rep: Reputation: 0
The solution is to stop NetworkManager from managing the wireless connection, and to use either WPA Supplicant or iwconfig to handle the wireless connection. Here's what I documented:


WPA SUPPLICANT
If you're using an AP with WPA enabled, you'll need to use wpa_supplicant. Google it to get your bearing on how its setup, but essentially you need to edit /etc/wpa_supplicant/wpa_supplicant.conf and add a Network block - such as:

network={
ssid="Gary"
proto=WPA
key_mgmt=WPA-PSK
psk="passwordhere"
}

Once you have your wpa_supplicant.conf setup to your liking, you have to run these two commands at startup (if your wireless connection is wlan0, if it's eth0 or eth1 - substitute that moniker):

wpa_supplicant -c /etc/wpa_supplicant/wpa_supplicant.conf -D wext -dd -i wlan0 -B
dhclient wlan0

You can drop these commands in /etc/rc.local or create your own startup service in etc/init.d/ Beware that your NFS mount in /etc/fstab will try to mount before your wireless is setup (if you put the commands in /etc/rc.local) - as such you may have to add a "mount -a" as a final command (to mount the NFS share in /etc/fstab).


OPEN WIRELESS NETWORK

If you have an open wireless network, you need to use iwconfig to connect to your access point. Those commands are:

iwconfig wlan0 essid nameofwirelessnetwork
ifup wlan0

This also implies that your wireless connection is "wlan0" and not "eth0" or "eth1". All I do is tell it to attach to the AP. You can do a "iwconfig wlan0" without any arguments to see if it's connected to your access point. Check the iwconfig man pages for more info. Like I said, you can also put these commands in /etc/rc.local - but you'll have to put the mount -a afterward to get the NFS mount to work.

This is NOT the most eloquent solution (Network Manager would be if it would WORK before the login screen), but it will get you started...

-Gary


OPEN WIRELESS ACCESS POINT
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to enable SSH + LDAP authentication on Cygwin? compileme Linux - Server 2 11-26-2008 10:31 PM
PHP Login through LDAP Authentication?? ajeetraina Programming 2 05-12-2008 07:07 AM
wireless authentication prior to ldap logon njpruess Linux - Wireless Networking 3 11-30-2007 09:29 AM
LDAP Authentication - no Gnome login possible azrael808 Linux - Software 3 01-11-2007 05:43 AM
how to enable root login on console when LDAP server is down ldapsky Linux - Networking 0 05-06-2006 07:27 PM


All times are GMT -5. The time now is 07:17 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration