LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 03-09-2005, 11:56 AM   #1
a_cmmn
LQ Newbie
 
Registered: Mar 2005
Posts: 4

Rep: Reputation: 0
FC3 fails in bringing up or down interface eth0, network unreachable


Hi,

I installed Fedora Core 3 and can only get the DHCP working through the SystemRescue CD. After I boot from the rescue CD, I can ping the ip on my LAN. The problem I have is that if I try to run Fedora from dual boot, it never gets the network working. I get errors like "Bringing up interface eth0: kernel panic - not syncing: Haling". Similar errors if it trying to bring down eth0. Also if try ping, I get network unreachable. Can anyone tell me please what makes things work using the Rescue CD versus the dual boot normal login? Also is there a way to start X from the root prompt that I get after I boot using the Systemrescue CD? I am new to this. I have windows XP, Dell machine, aDSL with pppoE using username and password.

Please help....Thank you very much,

Alex
 
Old 03-10-2005, 11:45 AM   #2
a_cmmn
LQ Newbie
 
Registered: Mar 2005
Posts: 4

Original Poster
Rep: Reputation: 0
Question

Hi,

regarding the problem i stated below...here is some clarifiaction ....please help...any ideas?

I installed Fedora FC3 and got the SystemRescue CD from www.sysresccd.org. The problem I have is: when I boot from the rescue CD, connection to DHCP is done nicely both in bringing up and down interface. When I boot by normal hard disk dual boot, I doesn't connect to network and gives me errors like "Bringing up interface eth0: kernel panic - not syncing: Halting" and "network unreachable".

If I try to use adsl-setup then adsl-start I get the kernel panic error again.

I also tried:

bash network status: gives me Configured devices: lo eth0 ppp0, and Currently active devices: blank.

bash network start: gives kernel panic when brining up interface eth0.


This is for home LAN, 1 PC with dual boot windows XP or Linux and the other PC with XP only. aDSL is Linksys router , pppoE.

thank you...
alex
 
Old 03-10-2005, 01:17 PM   #3
winsnomore
Member
 
Registered: May 2004
Location: USA
Distribution: #1 PCLinuxOS -- for laughs -> Ubuntu, Suse, Mepis
Posts: 315

Rep: Reputation: 31
I am not 100% sure about this .. but "adsl-start" etc. is probably not needed.
your ADSL router provides a simple ethernet interface with.
Difference between ADSL and cable modems typically is on the "wan" side .. ADSL runs PPPOE on that link and Cable modems
run just plain ethernet. and this difference comes into play when you put a PC->router->ADSL vs. PC->router->CM
however if you have PC->ADSL or PC-CM . ... the PC interface is identical.

Secondly it has nothing to do with dual boot .. when you boot linux .. you boot linux whether from a single os or from a dual or triple .. it doesn't matte.

Try "Not" using the "adsl" start scripts ..

as root .. try
"ifconfig eth0"... see what it says .. I am not sure if FC3 provides "ifup/ifdown" scripts .

But you can do the same thing ifconfig ..

i.e. ifconfig eth0 up .. or ifconfig eth0 down .. etc.

Hope this helps.
 
Old 03-10-2005, 01:51 PM   #4
a_cmmn
LQ Newbie
 
Registered: Mar 2005
Posts: 4

Original Poster
Rep: Reputation: 0
Hi Winsnomore,

thanks for your reply. I tried ifup and got the following:

# ifconfig eth0 up
kernel panic - not syncing: Halting

do you think that when I ran adsl-setup that it might have messed up some files? where can i find the file that tries to start the network?

thanks
 
Old 03-10-2005, 04:10 PM   #5
a_cmmn
LQ Newbie
 
Registered: Mar 2005
Posts: 4

Original Poster
Rep: Reputation: 0
I found out that it gives the kernel panic error when it executes the command:

ip link set dev eth0 up

which is in file etc/sysconfig/network-scripts/network-functions

in the function check_link_down.


Any ideas please?

thank you.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Bringing up interface eth0 Delaying eth0 initialization. [ FA bansal_ashok Linux - Networking 4 05-27-2005 10:09 AM
FC3 hangs at bringing up interface eth0 Equisilus Fedora 4 11-14-2004 04:29 PM
bringing up interface eth0 [FAILED] 0ver12ide Linux - Newbie 3 06-27-2004 02:31 PM
Bringing up interface eth0: failed Commish66 Mandriva 11 02-17-2004 07:15 PM
Bringing up interface eth0: determining ip information for eth0... failed ralphethomas Linux - Networking 0 01-24-2004 05:33 PM


All times are GMT -5. The time now is 08:20 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration