LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 02-12-2012, 09:54 AM   #1
threaderslash
Member
 
Registered: Dec 2008
Location: HongKong
Distribution: Fedora/Centos/RedHat
Posts: 115

Rep: Reputation: 15
Lightbulb FC16: wlan hardware blocked


I have my laptop dell xps with the wireless disabled. Before upgrading the FC16, it was working.

Here is what was done to put it working:

Check what the wireless network driver
Code:
# lspci -v

    03:00.0 Network controller: Intel Corporation Centrino Wireless-N 1030 (rev 34)
	Subsystem: Intel Corporation Centrino Wireless-N 1030 BGN
	Flags: bus master, fast devsel, latency 0, IRQ 51
	Memory at d7400000 (64-bit, non-prefetchable) [size=8K]
	Capabilities: [c8] Power Management version 3
	Capabilities: [d0] MSI: Enable+ Count=1/1 Maskable- 64bit+
	Capabilities: [e0] Express Endpoint, MSI 00
	Capabilities: [100] Advanced Error Reporting
	Capabilities: [140] Device Serial Number 4c-80-93-ff-ff-0d-c6-b8
	Kernel driver in use: iwlwifi
	Kernel modules: iwlwifi
install it:

Code:
yum install iwl6000g2b-firmware
yum install akmod-wl
yum install kmod-wl -y
install kurtdriver:
Code:
yum install gcc kernel-headers kernel-devel 
yum update kernel
tar -xzvf rtl8192se_linux_2.6.0017.0507.2010.tar.gz
check that the driver is where it should be:
Code:
# find / -name rtl8192se
/lib/modules/3.2.2-1.fc16.x86_64/backports/drivers/net/wireless/rtlwifi/rtl8192se
/usr/src/kernels/3.2.3-2.fc16.x86_64/drivers/net/wireless/rtlwifi/rtl8192se

I tried to restart the network:

Code:
modprobe iwlagn
service NetworkManager restart
I went to the Network Settings > Wireless : Unavailable.

It does not matter what I do, it show hardware disabled. Here is what I got:

Code:
# rfkill unblock all
# rfkill unblock wlan
# rfkill list

0: phy0: Wireless LAN
	Soft blocked: no
	Hard blocked: yes
1: dell-wifi: Wireless LAN
	Soft blocked: yes
	Hard blocked: yes
2: dell-bluetooth: Bluetooth
	Soft blocked: yes
	Hard blocked: yes
Any thoughts?

All comments are welcome and highly appreciated.
 
Old 02-13-2012, 03:38 PM   #2
peeyushpd
LQ Newbie
 
Registered: Feb 2012
Posts: 20

Rep: Reputation: Disabled
See if it is helpful

http://ubuntuforums.org/showthread.php?t=1781350
 
Old 02-14-2012, 03:04 AM   #3
threaderslash
Member
 
Registered: Dec 2008
Location: HongKong
Distribution: Fedora/Centos/RedHat
Posts: 115

Original Poster
Rep: Reputation: 15
Lightbulb

I just read the link. Thanks.

Here is what I did... iwlwifi is my driver for wlan.

Code:
# yum install lshw

# lshw -C network
configuration: broadcast=yes driver=iwlwifi driverversion=3.2.5-3.fc16.x86_64 firmware=18.168.6.1 latency=0 link=no multicast=yes wireless=IEEE 802.11bgn

# modinfo iwlwifi
filename:       /lib/modules/3.2.5-3.fc16.x86_64/backports/drivers/net/wireless/iwlwifi/iwlwifi.ko
parm:           swcrypto:using crypto in software (default 0 [hardware]) (int)
parm:           queues_num:number of hw queues. (int)
parm:           11n_disable:disable 11n functionality, bitmap: 1: full, 2: agg TX, 4: agg RX (uint)
parm:           amsdu_size_8K:enable 8K amsdu size (int)
parm:           fw_restart:restart firmware in case of error (int)
parm:           ucode_alternative:specify ucode alternative to use from ucode file (int)
parm:           antenna_coupling:specify antenna coupling in dB (defualt: 0 dB) (int)
parm:           bt_ch_inhibition:Enable BT channel inhibition (default: enable) (bool)
parm:           plcp_check:Check plcp health (default: 1 [enabled]) (bool)
parm:           ack_check:Check ack health (default: 0 [disabled]) (bool)
parm:           wd_disable:Disable stuck queue watchdog timer 0=system default, 1=disable, 2=enable (default: 0) (int)
parm:           bt_coex_active:enable wifi/bt co-exist (default: enable) (bool)
parm:           led_mode:0=system default, 1=On(RF On)/Off(RF Off), 2=blinking (default: 0) (int)
parm:           power_save:enable WiFi power management (default: disable) (bool)
parm:           power_level:default power save level (range from 1 - 5, default: 1) (int)
parm:           auto_agg:enable agg w/o check traffic load (default: enable) (bool)
parm:           no_sleep_autoadjust:don't automatically adjust sleep level according to maximum network latency (default: true) (bool)

# modprobe iwlwifi swcrypto
# modprobe iwlwifi 11n_disable
# modprobe iwlwifi ack_check
I looked at /etc/modprobe.d and there is no file custom-wireless.conf. Then I run:

Code:
# lshw
        *-communication UNCLAIMED
             description: Communication controller
             product: 6 Series/C200 Series Chipset Family MEI Controller #1
             vendor: Intel Corporation
             physical id: 16
             bus info: pci@0000:00:16.0
             capabilities: pm msi bus_master cap_list
             configuration: latency=0
             resources: memory:d7505000-d750500f

           *-network DISABLED
                description: Wireless interface
                product: Centrino Wireless-N 1030
                vendor: Intel Corporation
                physical id: 0
                bus info: pci@0000:03:00.0
                logical name: wlan0
                capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
                configuration: broadcast=yes driver=iwlwifi driverversion=3.2.5-3.fc16.x86_64 firmware=18.168.6.1 latency=0 link=no multicast=yes wireless=IEEE 802.11bgn
                resources: irq:50 memory:d7400000-d7401fff
Then I looked in the directory and edited the content of the file:

Code:
#!/etc/sysconfig/wpa_supplicant
# Use the flag "-i" before each of your interfaces, like so:
#  INTERFACES="-ieth1 -iwlan0"
#INTERFACES=""
INTERFACES="-iwlan0"

# Use the flag "-D" before each driver, like so:
#  DRIVERS="-Dwext"
#DRIVERS=""
DRIVERS="-Diwlwifi"

# Other arguments
#   -u   Enable the D-Bus interface (required for use with NetworkManager)
#   -f   Log to /var/log/wpa_supplicant.log
#   -P   Write pid file to /var/run/wpa_supplicant.pid
#        required to return proper codes by init scripts (e.g. double "start" action)
#        -B to daemonize that has to be used together with -P is already in wpa_supplicant.init.d
OTHER_ARGS="-u -f /var/log/wpa_supplicant.log -P /var/run/wpa_supplicant.pid"
So, I also install wireless_tools.
http://siso.sourceforge.net/wireless-linux.html
http://siso.sourceforge.net/toolchai...-wirelesstools

Code:
# yum install kernel-devel
# yum install ndiswrapper
# yum install wireless*
intall? wireless-tools-devel: yes
# yum install *supplicant*
intall? 
 wpa_supplicant-gui         x86_64         1:0.7.3-11.fc16           fedora         247 k
 xsupplicant                x86_64         2.2.0-3.fc15              fedora         512 k
 xsupplicant-devel          x86_64         2.2.0-3.fc15              fedora         238 k
 xsupplicant-ui             x86_64         2.2.0-3.fc15              fedora         1.9 M
: yes
And have setup the file:

Code:
# nano /etc/wpa_supplicant/wpa_supplicant.conf
ctrl_interface=/usr/sbin/wpa_supplicant
ctrl_interface_group=wheel

eapol_version=1
ap_scan=1
fast_reauth=1

network={
	ssid="my_network"
        proto=WPA
        key_mgmt=WPA-PSK
        pairwise=TKIP
        group=TKIP
        psk="secret_password"
}
Reboot, and nothing yet. And it is still blocked:

Code:
# rfkill list
0: dell-wifi: Wireless LAN
	Soft blocked: yes
	Hard blocked: yes
1: dell-bluetooth: Bluetooth
	Soft blocked: yes
	Hard blocked: yes
2: phy0: Wireless LAN
	Soft blocked: no
	Hard blocked: yes
Any suggestions? All comments is deeply appreciated.

Last edited by threaderslash; 02-14-2012 at 08:12 AM.
 
Old 03-12-2012, 07:53 PM   #4
amaltemara
LQ Newbie
 
Registered: Feb 2007
Posts: 4

Rep: Reputation: 0
Check the hardware

Hardware blocked means the wireless card is physically switched off. Often laptops have a switch on the side or front that turns off the wireless. It's also possible the switch on your laptop is broken.

Try booting with the most recent fedora or ubuntu live cd, and see if you can use your wireless then. If you can't, then it's probably a hardware problem, and you need to turn the switch on, or get it repaired.

If you can get on the wireless with the live cd, then you know it's your OS, and you need to keep troubleshooting.
 
Old 03-12-2012, 07:54 PM   #5
amaltemara
LQ Newbie
 
Registered: Feb 2007
Posts: 4

Rep: Reputation: 0
Check the BIOS as well

Sometimes you can switch off 'integrated peripherals' in the BIOS. Check the bios for a setting to enable your WIFI adapter.
 
Old 07-18-2012, 10:30 AM   #6
threaderslash
Member
 
Registered: Dec 2008
Location: HongKong
Distribution: Fedora/Centos/RedHat
Posts: 115

Original Poster
Rep: Reputation: 15
Lightbulb

I found the solution:

Code:
sudo modprobe iwlagn power_level=5
sudo modprobe btusb reset=1
sudo rfkill unblock all
source: http://askubuntu.com/questions/10131...1-10-xps-l702x

Thank you all!
 
  


Reply

Tags
blocked, wlan0


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
FC16 rebooting Yoshimitsuspeed Fedora 12 12-27-2011 09:12 PM
[SOLVED] fakenes not installing on fc16 frieza Linux - Games 3 12-10-2011 11:55 PM
[SOLVED] FC14 to FC16 disaster tethysgods Linux - Newbie 11 12-07-2011 01:50 PM
Eenable the wlan by hardware aalv Linux - Wireless Networking 9 12-07-2005 02:06 AM
WLAN Hardware ??? B McHack Linux - Hardware 0 07-19-2003 05:40 PM


All times are GMT -5. The time now is 07:24 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration