LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (http://www.linuxquestions.org/questions/linux-networking-3/)
-   -   Failed to remove VLAN interface. (http://www.linuxquestions.org/questions/linux-networking-3/failed-to-remove-vlan-interface-788382/)

kanth001 02-11-2010 12:43 AM

Failed to remove VLAN interface.
 
Hi...

My Linux machine’s all Ethernet ports are connected to Cisco 2960SCG switch. Linux machine is having two Ethernet cards. First one is using "e1000" Ethernet driver and the second one is with "nxge" Ethernet driver.

Problem is; I am successful while trying to delete VLAN interfaces over motherboard PCI Ethernet card, but if i try the same on other PCI card the following messages are coming,and soon system getting hanged.

Message from syslogd@ at Wed Feb 10 17:48:11 2010 ...
localhost kernel: unregister_netdevice: waiting for eth5.390 to become free. Usage count = 4


Bofore using nxge based Ethernet card I used e1000 based only, for that also I had same problem.


Please correct me if I am wrong by checking following info.

[root@localhost ~]# ifconfig eth5.390
eth5.390 Link encap:Ethernet HWaddr 00:21:28:21:DB:D1
inet addr:192.168.155.4 Bcast:192.168.155.255 Mask:255.255.255.0
inet6 addr: fe80::221:28ff:fe21:dbd1/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:191 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 b) TX bytes:52151 (50.9 KiB)

[root@localhost ~]#

[root@localhost ~]# uname -a
Linux localhost.localdomain 2.6.18-53.el5 #1 SMP Wed Oct 10 16:34:19 EDT 2007 x86_64 x86_64 x86_64 GNU/Linux
[root@localhost ~]#

[root@localhost ~]# ethtool eth0
Settings for eth0:
Supported ports: [ TP ]
Supported link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
1000baseT/Full
Supports auto-negotiation: Yes
Advertised link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
1000baseT/Full
Advertised auto-negotiation: Yes
Speed: 1000Mb/s
Duplex: Full
Port: Twisted Pair
PHYAD: 0
Transceiver: internal
Auto-negotiation: on
Supports Wake-on: umbg
Wake-on: g
Current message level: 0x00000007 (7)
Link detected: yes
[root@localhost ~]#

[root@localhost ~]# ethtool eth5
Settings for eth5:
Supported ports: [ TP MII ]
Supported link modes: 10baseT/Full
100baseT/Full
1000baseT/Full
Supports auto-negotiation: Yes
Advertised link modes: 10baseT/Full
100baseT/Full
1000baseT/Full
Advertised auto-negotiation: Yes
Speed: 1000Mb/s
Duplex: Full
Port: MII
PHYAD: 12
Transceiver: internal
Auto-negotiation: on
Current message level: 0x000000ff (255)
Link detected: yes
[root@localhost ~]#

kanth001 03-01-2010 03:01 AM

Can any one help?


All times are GMT -5. The time now is 01:20 AM.