LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 05-12-2009, 02:25 AM   #1
summersgone
LQ Newbie
 
Registered: Dec 2006
Posts: 29

Rep: Reputation: 15
Question failed to execute command : ifconfig <interface> create


Hi guys,
I've just followed this tutorial :
http://blogs.23.nu/disLEXia/2004/08/antville-4485/

And when i executed the command 'ifconfig disc0 create' under centOS 5.2 , it returned with :
create : No address associated with name

What's wrong with it ? how do i create interface under centOS ?

Thank you ..
 
Old 05-12-2009, 03:42 AM   #2
rylan76
Senior Member
 
Registered: Apr 2004
Location: Potchefstroom, South Africa
Distribution: Fedora 17 - 3.3.4-5.fc17.x86_64
Posts: 1,477

Rep: Reputation: 87
Quote:
Originally Posted by summersgone View Post
Hi guys,
I've just followed this tutorial :
http://blogs.23.nu/disLEXia/2004/08/antville-4485/

And when i executed the command 'ifconfig disc0 create' under centOS 5.2 , it returned with :
create : No address associated with name

What's wrong with it ? how do i create interface under centOS ?

Thank you ..
Hmm - disc0 is an interface name, and your system is unable to provide that interface.

This most likely means that a specific driver for your LAN chip / card is not loaded, or is set to come up as a differently named interface.

Have you tried substituting "disc0" with "eth0" or "eth1"?

I. e. on my FC10 system, I can do this:

Code:
/sbin/ifconfig eth0 169.254.255.20 netmask 255.255.255.0 broadcast 169.254.255.255 up
which means "on the eth0 interface, set the IP adress to 169.254.255.20, the netmask to 255.255.255.0, the broadcast to 169.254.255.255, and activate (up) the interfce"

Note that the eth0 is an ethernet device - which is provided by a "kernel module" (LAN card driver) that I have loaded. Usually, if you do not pass the driver / kernel module it a startup parameter, or it is automatically loaded by your startup scripts, your ethernet device will be eth0 - if there are other ethernet cards, they are usually enumerated in order - i. e. eth0, eth1, etc.

From what you posted, you do not have "disc0" device available in your system. The tut you posted seems pretty extensive, maybe this is a software loopback or something created seperately as a step before the one you tried?

No idea... but the gist is that it appears that your system does not have a "disc0" networking device... or it does, but you need to provide an address?

What does

Code:
ifconfig disc0 192.168.0.11 up
do?

Or a mixture of the above (with disc0 substituted for eth0) relative to my

Code:
/sbin/ifconfig eth0 169.254.255.20 netmask 255.255.255.0 broadcast 169.254.255.255 up
?

I. e.

Code:
/sbin/ifconfig disc0 192.168.0.11 netmask 255.255.255.0 broadcast 192.254.255.255 up
or

Code:
/sbin/ifconfig disc0 192.168.0.11 up
??
 
Old 05-12-2009, 03:55 AM   #3
summersgone
LQ Newbie
 
Registered: Dec 2006
Posts: 29

Original Poster
Rep: Reputation: 15
it didn't work. Btw , I forgot to tell you that I'm running the host (centOS 5.2) under User Mode Linux. And i need to create a new interface inside the host.

Thank you
 
Old 05-12-2009, 04:59 AM   #4
chitambira
Member
 
Registered: Oct 2008
Location: Fife
Distribution: RHEL, Centos
Posts: 373
Blog Entries: 1

Rep: Reputation: 49
Quote:
ifconfig disc0 create
This is NOT a linux command (man ifconfig) rather a BSD command. So it will not work with Centos.
You can achieve what you want by using aliased interfaces (eth0:1) or by creating virtual interfaces.
Might also want to consider VIPA.
 
Old 05-12-2009, 10:38 AM   #5
summersgone
LQ Newbie
 
Registered: Dec 2006
Posts: 29

Original Poster
Rep: Reputation: 15
I have successfully created eth1:0 on my centOS using this command:

Quote:
ifconfig eth1:0 192.168.1.135 up
and now how can I redirect traffic to the interface just like in the tutorial?(http://blogs.23.nu/disLEXia/2004/08/antville-4485/) :

Quote:
route add -host a.b.c.130 -interface disc0
I run that command and it said it has no -interface parameter in it. Does anybody know how to fix this problem ?
Thanks a lot before..
 
Old 05-12-2009, 10:46 AM   #6
chitambira
Member
 
Registered: Oct 2008
Location: Fife
Distribution: RHEL, Centos
Posts: 373
Blog Entries: 1

Rep: Reputation: 49
Linux uses dev instead of -interface. You would better be reading man pages.
You do:
Quote:
route add -host 192.168.1.130 dev eth1:0
 
Old 05-12-2009, 12:04 PM   #7
summersgone
LQ Newbie
 
Registered: Dec 2006
Posts: 29

Original Poster
Rep: Reputation: 15
Thank you.. now it works
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to extract the interface number from ifconfig -a pooppp Linux - Networking 4 08-04-2008 05:54 AM
connecting /sbin/ifconfig to bash command ifconfig flammable2 Fedora 4 11-12-2005 08:58 AM
second ethernet interface will not configure using ifconfig akay Linux - Hardware 0 12-14-2004 07:45 PM
Bash command $? failed to execute. Linh Programming 7 05-14-2004 12:11 PM
Can't execute ifconfig at command line jhsuan Linux - Newbie 3 08-30-2002 09:57 PM


All times are GMT -5. The time now is 11:46 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration