LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (http://www.linuxquestions.org/questions/linux-networking-3/)
-   -   Ethernet crossover, avahi and 169.254.* (http://www.linuxquestions.org/questions/linux-networking-3/ethernet-crossover-avahi-and-169-254-%2A-819673/)

wichiff 07-13-2010 04:50 PM

Ethernet crossover, avahi and 169.254.*
 
Hello,

in Ubuntu Karmic I was happily connecting my ubuntu laptop to another machine linked to it with a crossover Ethernet cable. I could connect in wicd, then on startup the connection would be established automatically, allowing me to ping ubuntu.local, ssh into it and so on. Both machines were assigned 169.254.* addresses automatically.

After the upgrade to Ubuntu Lucid, this automatic behavior is lost !
However when one starts
Code:

avahi-autoipd eth0
manually, Bob's your uncle it seems -- and
Code:

eth0:avahi
shows up in the output of ifconfig.

What kind of network configuration should be tweaked to get back to the automatic behavior ?

rdgreenlaw 07-15-2010 06:45 AM

Create startup/shutdown command named ethcrossover in /etc/init.d
(You may change the name but make sure you fix it's references in each of the following code sections)

Quote:

#!/bin/sh
# Startup for Ethernet Crossover Project
# Filename: ethcrossover

case "$1" in
'start')
avahi-autoipd eth0
;;
'stop')
# not sure what goes here to shut it down
# probably not necessary to do so unless you
# routinely change from networking to non-networking runlevel
# without shutting down your system
;;
*)
echo "Usage: $0 { start | stop }"
;;
esac
exit 0
Change the script to executable

Quote:

chmod 766 /eth/init.d/ethcrossover
For each runlevel you want it automatically started in make a link to the file
The file names are sorted alphabetically to determine what to do. Your file must come after
any scripts that need to be run before it, and before any that must follow it.

For example, if you were to run a procedure that requires the ethernet bridge to run called sendfile then sendfile would have to follow ethcrossover. The ethcrossover script needs to start after networking starts!

The scripts to be started or stopped are located in /etc/rc?.d where ? is the runlevel of the system. It would be safe to place this script in each runlevel except runlevel 6. Runlevel 6 shuts down everything and is called before a restart or shutdown of the system.

Execute these commands to automate the startup

Quote:

ln -s /eth/init.d/ethcrossover /eth/rc2.d/S99ethcrossover
ln -s /eth/init.d/ethcrossover /eth/rc3.d/S99ethcrossover
ln -s /eth/init.d/ethcrossover /eth/rc4.d/S99ethcrossover
ln -s /eth/init.d/ethcrossover /eth/rc5.d/S99ethcrossover
If you need to shut it down before system shutdown add the following
(forces shutdown before apache services shutdown)

Be sure to determine what needs to happen for successful shutdown and fix the script first.

Quote:

ln -s /eth/init.d/ethcrossover /eth/rc3.d/K08ethcrossover
ln -s /eth/init.d/ethcrossover /eth/rc3.d/K08ethcrossover
This should get you running automatically again.

wichiff 07-17-2010 07:57 AM

added avahi-autoipd in startup scripts
 
This did not do the trick, I don't know why.

If wicd is removed and network-manager reinstalled, with 'link-local' in IPv4 settings, then things work as intended.

It would be nice to make it work with wicd though.

rdgreenlaw 07-17-2010 08:09 AM

Sorry I wasn't able to help. Unfortunately there are a few application that don't work under WiCD that work with network-manager. Another app that doesn't work correctly without network-manager is empathy. I tried removing network-manager because it was having difficulty establishing a wireless connection without prompting for the network key if it looses the connection. WiCD did not have the problem, but empathy won't run under WiCD. It doesn't see the network and shuts down instead of connecting to the internet.

wichiff 07-17-2010 11:56 AM

Quote:

Originally Posted by rdgreenlaw (Post 4036281)
Sorry I wasn't able to help. Unfortunately there are a few application that don't work under WiCD that work with network-manager. Another app that doesn't work correctly without network-manager is empathy. I tried removing network-manager because it was having difficulty establishing a wireless connection without prompting for the network key if it looses the connection. WiCD did not have the problem, but empathy won't run under WiCD. It doesn't see the network and shuts down instead of connecting to the internet.

Thanks for all the information.

In my case, this crossover ethernet connection with wicd instead of NM was running fine in Ubuntu Karmic. Since I upgraded to Lucid it's broken.

As to the wireless connection: trouble started when I upgraded from 8.10 to 9.04 if i remember correctly.


All times are GMT -5. The time now is 02:04 AM.