LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 07-19-2004, 12:34 PM   #1
sha77
LQ Newbie
 
Registered: Jul 2004
Posts: 10

Rep: Reputation: 0
ethernet card is not detected?


Hi,

I'm new and I couldn't find any previous threads that help.

I just installed linux redhat 9 and I cannot connect to the internet. I have an onboard ethernet card Intel(R) PRO/1000 CT on ABIT IC7-G MAX II motherboard.

When I configured the network connection, this card did not seem to be listed in the list of the adapters. How can I know whether this card is automatically detected by linux? How to get the card to be listed there and how to install the driver?

Thanks
 
Old 07-19-2004, 12:55 PM   #2
nafsnipe685
LQ Newbie
 
Registered: Jan 2004
Location: Texas, USA
Distribution: Slackware 9
Posts: 19

Rep: Reputation: 0
are you using dhcp, which gives you a default gateway to give a path to the internet, or are you using dialup, i need more info.
 
Old 07-19-2004, 01:28 PM   #3
sha77
LQ Newbie
 
Registered: Jul 2004
Posts: 10

Original Poster
Rep: Reputation: 0
Hi,

I'm using static IP instead of DHCP. I type in my own IP address, gateway and so on.

Any ideas on how to get linux to detect my ethernet card?

Thanks.
 
Old 07-19-2004, 01:35 PM   #4
bruj3w
Member
 
Registered: Mar 2004
Location: england
Distribution: slackware
Posts: 164

Rep: Reputation: 30
im assuming kudzu is not detecting it at boot? try google'ing for the module that correponds to your nic, then lsmod <modulename>.

you may find that its not supported.

good luck.
 
Old 07-19-2004, 01:48 PM   #5
Pete M
Member
 
Registered: Aug 2003
Location: UK
Distribution: Redhat 9 FC 3 SUSE 9.2 SUSE 9.3 Gentoo 2005.0 Debian Sid
Posts: 657

Rep: Reputation: 30
sha77

If you have a standard Redhat install with default Kernel you will need a driver for your onboard ethernet card

Available from Intel Here

At the bottom of the page it lists 'Intel® PRO/1000 CT Network Connection'

You are looking for 'e1000-5.2.52.tar.gz' unpack the driver and read the Readme for install instructions

Pete
 
Old 07-20-2004, 12:01 AM   #6
sha77
LQ Newbie
 
Registered: Jul 2004
Posts: 10

Original Poster
Rep: Reputation: 0
Hi,

I unzipped the e1000-5.2.52 as what you said.

hmm.... where do I type all those commands stated in the README file? Do I type at the terminal(right click -> new terminal)?

Then, I encountered error when I type "make install". The error was:
"Makefile: 66 : ***Linux kernel source not found. Stop."

What does this mean? Any suggestions on how should I proceed with the driver installation?

Thanks.
 
Old 07-20-2004, 02:36 AM   #7
Pete M
Member
 
Registered: Aug 2003
Location: UK
Distribution: Redhat 9 FC 3 SUSE 9.2 SUSE 9.3 Gentoo 2005.0 Debian Sid
Posts: 657

Rep: Reputation: 30
sha77

It means exactly what it says, you don't have the Kernel source installed

Go to

System Settings -> Add/remove/applications -> Development -> Kernel Development -> Standard Packages -> kernel-source

Put the appropriate CD in the drive when prompted

Pete
 
Old 07-20-2004, 03:33 AM   #8
sha77
LQ Newbie
 
Registered: Jul 2004
Posts: 10

Original Poster
Rep: Reputation: 0
Hi,

Sorry, I'm a newbie. I'm still not able to install it.

After installing the kernel source like what Pete M said, I tried to install the driver again and I got the following error msg:

Fatal: can't create e1000_main.o: Permission denied
make:***(e1000_main.o) Error 2

Do I have to build the binary RPM in order to avoid such error message?

Thanks.
 
Old 07-20-2004, 11:47 AM   #9
Pete M
Member
 
Registered: Aug 2003
Location: UK
Distribution: Redhat 9 FC 3 SUSE 9.2 SUSE 9.3 Gentoo 2005.0 Debian Sid
Posts: 657

Rep: Reputation: 30
sha77

To make the driver you will have to be root, that's why you get 'Permission denied' on the command line type su then your root password

Sorry I forgot to mention this

Try again let me know how you get on

Pete
 
Old 07-20-2004, 01:09 PM   #10
sha77
LQ Newbie
 
Registered: Jul 2004
Posts: 10

Original Poster
Rep: Reputation: 0
First of all, I would like to thank you Pete for helping me through this thing. I still need more help in the future considering my experience in linux is still limited.

So, back to the topic.

This time I logged in as administrator and it worked half way...some improvements.

After I typed "make install", the process went well without any error. Then, the next part is "insmod e1000 <parameter>=<value>". What should I do over here? I've tried reading the whole manual but I didnt seem to understand it.

Thanks alot.
 
Old 07-20-2004, 01:30 PM   #11
WMD
Member
 
Registered: Jul 2004
Location: Florida
Distribution: Slackware, Debian
Posts: 484

Rep: Reputation: 30
I could've sworn that an Intel Pro/1000 driver came with the default kernels....

But anyway, you should be using modprobe, not insmod. Type modprobe e1000_main. That should load the driver.

Still, I'm almost certain that you could've done modprobe e1000 without downloading anything new.
 
Old 07-20-2004, 03:01 PM   #12
Pete M
Member
 
Registered: Aug 2003
Location: UK
Distribution: Redhat 9 FC 3 SUSE 9.2 SUSE 9.3 Gentoo 2005.0 Debian Sid
Posts: 657

Rep: Reputation: 30
WMD

Linux Compatibility Test Redhat 9

Take a look Here
Quote:
Network Interface Intel Pro/1000 CT
Quote:
Network Test Network card did not auto probe and detect properly. It had to be selected manually after updating drivers from Intel's website. Driver as selected is '10/100 Adapter Base Driver'.
sha77

As root try

sbin/insmod e1000.o
or
sbin/modprobe e1000.o

This will give you default parameters which should be OK

Pete
 
Old 07-20-2004, 05:49 PM   #13
sha77
LQ Newbie
 
Registered: Jul 2004
Posts: 10

Original Poster
Rep: Reputation: 0
Hi,

I'm totally lost.

as a root from the terminal window:

[root@localhost, root] # sbin/insmod e1000.o <- didnt work
[root@localhost root] # sbin/modprobe e1000.o <- didnt work

[root@localhost root] # modprobe e1000 <- didnt work
[root@localhost root] # modprobe e1000_main <- didnt work

Then I tried all above from the src file from the installed e1000-5.2.52.
[root@localhost, src] : (I typed everything above and nothing happened)

Where exactly should I type all thos commands? From root or the from the file that I installed?

I did some research on the internet but couldnt find anything that help.

Any ideas?

Thanks.
Sharence
 
Old 07-20-2004, 10:52 PM   #14
chop
LQ Newbie
 
Registered: Jun 2004
Location: norway
Distribution: tsl 2.1
Posts: 18

Rep: Reputation: 0
What does 'lspci' say?
Maybe you've disabled integrated LAN?
 
Old 07-21-2004, 02:31 AM   #15
Pete M
Member
 
Registered: Aug 2003
Location: UK
Distribution: Redhat 9 FC 3 SUSE 9.2 SUSE 9.3 Gentoo 2005.0 Debian Sid
Posts: 657

Rep: Reputation: 30
sha77

Hi again

First off check that the e1000 module has actually been made and put in the correct place, should be

/lib/modules/2.4.20-8/kernel/drivers/net/e1000/e1000.o
or
/lib/modules/2.4.20-8/kernel/drivers/net/e1000.o

2.4.20-8 this will be your kernel version if you have a default Redhat install then I assume you will only have one kernel in /lib/modules and it's probably this one

If e1000.o is in there then try this on the command line as root

sbin/insmod /lib/modules/2.4.20-8/kernel/drivers/net/e1000/e1000.o
or
sbin/insmod /lib/modules/2.4.20-8/kernel/drivers/net/e1000.o

Use the full path to the module depending where you found it

Also you need to get back to the root folder

[root@localhost]

To do this once you have entered su then password issue the command
cd /

this should get you from

[root@localhost root]
to
[root@localhost]

In fact before you do the above from the root folder just try

[root@localhost]# sbin/insmod e1000
or
[root@localhost]# sbin/insmod e1000.o
or
[root@localhost]# sbin/modprobe e1000
or
[root@localhost]# sbin/modprobe e1000.o

On my Redhat install I always have to use sbin in front of commands should'nt have to but that's the way mine is

Good luck

Pete
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Ethernet card suddenly no longer detected ! redhatman Linux - Newbie 9 10-03-2004 11:39 AM
ethernet card not detected kernel 2.6.7 rajeshkahara Linux - Hardware 1 08-26-2004 10:19 PM
ethernet card (sis) not detected baterya Linux - Hardware 2 07-09-2004 04:27 AM
Ethernet Card detected in one kernel is not detected in the other?? ashishuttarwar Linux - Hardware 14 06-15-2004 10:06 PM
Ethernet card on laptop: I installed my D-Link ethernet card into Redhat 9, not detec brighamr Linux - Hardware 0 05-18-2004 12:33 AM


All times are GMT -5. The time now is 01:55 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration