LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 02-10-2004, 11:46 PM   #1
Buckaroo
LQ Newbie
 
Registered: Feb 2004
Posts: 1

Rep: Reputation: 0
eth0 won't recognize link upon bootup


Hi, having a very strange problem with Fedora.

This system was originally running RH7.3 and I did not have these problems, I decided to wipe and install Fedora and now this very weird problem occurs:

I have two NICs installed, eth0 and eth1.

Upon bootup, eth0 will not recognize link. The nic itself indicates link on its external LED. NO amount of restarting network will get this interface up. I have to physically unplug the network cable and then plug back in for it to work.

I have tried all the standard testing for cabling or hardware problems. I have swapped cables, I have swapped nics, I changed the order of the nics physicaly on the Mainboard. Always, it is eth0 that will not recognize link, no matter which network card is used. I can even take the network cable from the eth0 and use in eth1 and move eth1's network cable to eth0 and eth0 still refuses to work, and eth1 is just fine.

So I'm thinking this is a bug of some sort in Fedora. Has anybody had this same or similar problem and have a solution?
 
Old 02-11-2004, 12:25 AM   #2
atticboy1
LQ Newbie
 
Registered: Jan 2004
Posts: 13

Rep: Reputation: 0
I am having the exact same problem in RHEL 3, and I have never seen this before.
 
Old 02-11-2004, 07:48 AM   #3
vectordrake
Senior Member
 
Registered: Nov 2003
Location: NB,Canada
Distribution: Something alpha or beta, binary or source...
Posts: 2,280
Blog Entries: 4

Rep: Reputation: 47
http://www.linuxquestions.org/questi...367#post751367 That is my solution for the same problem with Mandy10 (2.6 kernel). Try putting your eth module in the /etc/modules file if you run 2.4 or what I did if you run 2.6
 
Old 02-11-2004, 10:11 AM   #4
atticboy1
LQ Newbie
 
Registered: Jan 2004
Posts: 13

Rep: Reputation: 0
I've looked for the modprobe config file, must be something different in redhat.

[root@duly etc]# find / -name *modprobe*
/proc/sys/kernel/modprobe
/etc/log.d/conf/services/modprobe.conf
/etc/log.d/scripts/services/modprobe
/usr/share/man/man8/modprobe.8.gz
/sbin/modprobe
[root@duly etc]#
 
Old 02-11-2004, 10:31 AM   #5
atticboy1
LQ Newbie
 
Registered: Jan 2004
Posts: 13

Rep: Reputation: 0
There is a file called /etc/modules.conf
Mine has nothing in it except for:
alias eth0 e100
 
Old 02-11-2004, 10:52 AM   #6
picasso2
LQ Newbie
 
Registered: Feb 2004
Posts: 10

Rep: Reputation: 0
Could use post the file /etc/modules.conf and /etc/sysconfig/network-scripts/ifcfg-eth0.

Alex
 
Old 02-11-2004, 11:37 AM   #7
atticboy1
LQ Newbie
 
Registered: Jan 2004
Posts: 13

Rep: Reputation: 0
This is my /etc/sysconfig/network-scripts/ifcfg-eth0

DEVICE=eth0
ONBOOT=yes
BOOTPROTO=none
IPADDR=192.168.1.8
NETMASK=255.255.255.0
GATEWAY=192.168.1.2
TYPE=Ethernet
USERCTL=no
PEERDNS=no
NETWORK=192.168.1.0
BROADCAST=192.168.1.255

As mentioned, there is nothing in my modules.conf file except for:
alias eth0 e100
 
Old 02-11-2004, 11:46 AM   #8
picasso2
LQ Newbie
 
Registered: Feb 2004
Posts: 10

Rep: Reputation: 0
Hi,

Just do me a favour, post /etc/sysconfig/network and the log messages in /var/log/messages from the module e100.

Alex
 
Old 02-11-2004, 11:53 AM   #9
atticboy1
LQ Newbie
 
Registered: Jan 2004
Posts: 13

Rep: Reputation: 0
This is my /etc/sysconfig/network:
NETWORKING=yes
HOSTNAME=duly

Here are my messages related to eth0 during a reboot:
Feb 10 23:35:44 duly kernel: e100: eth0 NIC Link is Down
Feb 10 23:36:00 duly kernel: e100: eth0 NIC Link is Up 100 Mbps Full duplex
Feb 10 23:39:48 duly kernel: e100: eth0: Intel(R) PRO/100 Network Connection
Feb 10 23:39:48 duly kernel: e100: eth0: Intel(R) PRO/100 Network Connection
Feb 10 23:39:48 duly kernel: e100: eth0 NIC Link is Up 100 Mbps Full duplex
Feb 10 23:40:26 duly kernel: e100: eth0 NIC Link is Down
Feb 10 23:40:34 duly kernel: e100: eth0 NIC Link is Up 100 Mbps Full duplex
 
Old 02-11-2004, 11:56 AM   #10
atticboy1
LQ Newbie
 
Registered: Jan 2004
Posts: 13

Rep: Reputation: 0
maybe I will just disable the second onboard nic in the bios, and rebuild the kernel. I could later let kudzu pick it up.
 
Old 02-11-2004, 12:04 PM   #11
picasso2
LQ Newbie
 
Registered: Feb 2004
Posts: 10

Rep: Reputation: 0
Hi,

It looks like the module has a problem with the hardware. These are onboard nics. I got the same problem with broadcom gigabit onboard nics.

Set the speed in your module.conf, maybe this helps.
option e100 e100_speed_duplex=4,4


DESCRIPTION:
e100_speed_duplex
Valid Range: 0-4 (1=10half;2=10full;3=100half;4=100full)
Default Value: 0
The default value of 0 sets the adapter to auto-negotiate. Other values
set the adapter to forced speed and duplex.
Example usage: insmod e100.o e100_speed_duplex=4,4 (for two adapters)


Alex
 
Old 02-11-2004, 01:14 PM   #12
atticboy1
LQ Newbie
 
Registered: Jan 2004
Posts: 13

Rep: Reputation: 0
So I would make my modules.conf file look like this:

alias eth0 e100
option e100 e100_speed_duplex=4,4

Just two lines and you think that will do it?
 
Old 02-11-2004, 02:06 PM   #13
atticboy1
LQ Newbie
 
Registered: Jan 2004
Posts: 13

Rep: Reputation: 0
I added that to my modules.conf and rebooted. It didn't work.
 
Old 02-11-2004, 10:19 PM   #14
vectordrake
Senior Member
 
Registered: Nov 2003
Location: NB,Canada
Distribution: Something alpha or beta, binary or source...
Posts: 2,280
Blog Entries: 4

Rep: Reputation: 47
Quote:
Originally posted by atticboy1
I added that to my modules.conf and rebooted. It didn't work.
lsmod? Is the module loaded? Can you load it manually? Are you running 2.4 kernel? If so, and the module is not loading at boot, put the name of the module in /etc/modules . Reboot and see. If 2.6, see my post above.
 
Old 07-28-2004, 11:40 AM   #15
rjs9
LQ Newbie
 
Registered: Jul 2004
Posts: 1

Rep: Reputation: 0
I am experiencing the exact same issues with the same hardware and drivers. I have tried numerous different switches and settings.

Has anyone solved this problem yet?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
eth0: link down during boot davcefai Debian 3 11-27-2005 04:25 PM
bcm5700: eth0 NIC link is DOWN cyclonecross Red Hat 0 10-18-2005 10:48 PM
Linux (CRUX 2.1) won't recognize/load my Network device on eth0 Mr. Asdf Linux - Networking 1 07-14-2005 09:16 AM
eth0 doesnt get activated on bootup funkymunky Linux - Networking 3 05-18-2005 11:30 PM
eth0 not activating during bootup nigma Linux - Networking 1 02-13-2004 05:23 AM


All times are GMT -5. The time now is 04:07 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration